FHEM Forum

FHEM - Hardware => Server - Linux => Thema gestartet von: Christian72D am 29 Januar 2022, 06:03:08

Titel: [gelöst] Neu Installation schlägt fehl
Beitrag von: Christian72D am 29 Januar 2022, 06:03:08
Ich wollte nach dieser Seite eine neue Installation auf meiner Proxmox VM vornehmen:

https://debian.fhem.de/ (https://debian.fhem.de/)

Leider tut sich schon beim ersten Schritt nicht mehr wirklich viel. Nach dem wget Download tut sich NICHTS, drücke ich dann irgendwann die Enter Taste werde ich nach meinem Admin PW gefragt, danach sieht mein Screen folgendermassen aus.


Titel: Antw:Neu Installation schlägt fehl
Beitrag von: CoolTux am 29 Januar 2022, 06:10:59
Wirklich hilfreich ist Deine Beschreibung nicht. So wird man Dir schwer helfen können.

Beschreibe bitte ganz genau was Du gemacht hast und welches Ergebnis daraus folgte.
Titel: Antw:Neu Installation schlägt fehl
Beitrag von: Benni am 29 Januar 2022, 07:31:16
Ich wollte nach dieser Seite eine neue Installation auf meiner Proxmox VM vornehmen:

https://debian.fhem.de/ (https://debian.fhem.de/)

Leider tut sich schon beim ersten Schritt nicht mehr wirklich viel. Nach dem wget Download tut sich NICHTS, drücke ich dann irgendwann die Enter Taste werde ich nach meinem Admin PW gefragt, danach sieht mein Screen folgendermassen aus.

Auf debian.fhem.de sind verschiedene Varianten der Installation beschrieben. Ich nehme mal an:


Wenn das der Fall ist, fehlen dir wahrscheinlich die Pakete gpg und sudo.

Bitte die zunächst mal installieren (mit root-rechten):

apt install gpg sudo

Und dann nochmal bei Schritt 1 beginnen.

gb#

PS: Ggf. sollte man das auf der Seite mal entsprechend ergänzen, das kommt immer mal wieder auf.
Eventuell wäre auch eine deutlichere Anweisung bei Schritt 2 sinnvoll, damit klar ist, dass das kein Befehl ist der auf der Kommandozeile eingegeben werden muss, sonder dass die Zeile so in die genannte Datei eingetragen werden muss. Auch das wird gerne mal übersehen.
Titel: Antw:Neu Installation schlägt fehl
Beitrag von: CoolTux am 29 Januar 2022, 07:51:47
Auf debian.fhem.de sind verschiedene Varianten der Installation beschrieben. Ich nehme mal an:

  • Du hast dich für den "Easy way" per apt entschieden
  • Du hast ein Debian-System Buster oder Bullseye installiert und bei der Installation ein passwort für root angegeben

Wenn das der Fall ist, fehlen dir wahrscheinlich die Pakete gpg und sudo.

Bitte die zunächst mal installieren (mit root-rechten):

apt install gpg sudo

Und dann nochmal bei Schritt 1 beginnen.

gb#

PS: Ggf. sollte man das auf der Seite mal entsprechend ergänzen, das kommt immer mal wieder auf.
Eventuell wäre auch eine deutlichere Anweisung bei Schritt 2 sinnvoll, damit klar ist, dass das kein Befehl ist der auf der Kommandozeile eingegeben werden muss, sonder dass die Zeile so in die genannte Datei eingetragen werden muss. Auch das wird gerne mal übersehen.

Das hast Du alles aus der Beschreibung und dem Screenshot rausgelesen? Oder gut geraten  ;D
Titel: Antw:Neu Installation schlägt fehl
Beitrag von: Benni am 29 Januar 2022, 08:11:34
Das hast Du alles aus der Beschreibung und dem Screenshot rausgelesen?

Ja, der Screenshot gibt den Hinweis darauf! Schätzungsweise ist gpg sogar vorhanden und das dearmour funktioniert und das wird dann mangels sudo ausschließlich auf stdout ausgegeben. Sieht dann ungefähr so aus.

Bisschen raten ist natürlich schon dabei!  :D

gb#
Titel: Antw:Neu Installation schlägt fehl
Beitrag von: CoolTux am 29 Januar 2022, 08:21:39
Ah, nicht schlecht. Wieder was gelernt.
Titel: Antw:Neu Installation schlägt fehl
Beitrag von: Christian72D am 29 Januar 2022, 08:54:02
Also noch mal, ich habe folgenden Befehl ausgeführt:

wget -O- https://debian.fhem.de/archive.key | gpg --dearmor | sudo tee /usr/share/keyrings/debianfhemde-archive-keyring.gpg
sudo und gpg sind NATÜRLICH installiert, noch nie eine Ubuntu Server Installation gesehen, bei der die fehlen würden.

Und nach dem drücken von Enter nach etlichen Minuten Stillstand nach der wget Download Meldung werde ich nach meinem sudo PW gefragt, gebe es ein und bekomme die im Screenshot gezeigte Meldung.
Titel: Antw:Neu Installation schlägt fehl
Beitrag von: CoolTux am 29 Januar 2022, 09:25:27
sudo und gpg sind NATÜRLICH installiert, noch nie eine Ubuntu Server Installation gesehen, bei der die fehlen würden.

Na wie gut das Du gleich als erstes erwähnt hast das es sich um Ubuntu als Distribution handelt.
Wünsche Allen ein zauberhaftes Wochenende.
Titel: Antw:Neu Installation schlägt fehl
Beitrag von: Benni am 29 Januar 2022, 10:23:19
Also noch mal...

Bloß! nicht zuviel Information auf einmal!

Kann es denn sein, dass die Datei dennoch korrekt bei dir angelegt wurde?

Schon mal versucht einfach mit Schrit 2 und 3 weiter zu machen?
Was passiert bei Schritt 3? Klappt die Installation oder gibt es einen Feheler?

Ansonsten lässt sich Schritt 1 auch mal aufteilen.

Also erst mal den key-File runterladen

wget https://debian.fhem.de/archive.key

Und dann das gpg dearmour ausführen und in die angegebene Datei schreiben. (Geht auch ohne tee):

sudo gpg --dearmour < archive.key > /usr/share/keyrings/debianfhemde-archive-keyring.gpg

Dann mal prüfen, ob die Datei auch angelegt wurde:

ls -l /usr/share/keyrings/debianfhemde-archive-keyring.gpg

gb#
Titel: Antw:Neu Installation schlägt fehl
Beitrag von: Christian72D am 29 Januar 2022, 12:06:32
Na wie gut das Du gleich als erstes erwähnt hast das es sich um Ubuntu als Distribution handelt.
Wünsche Allen ein zauberhaftes Wochenende.
Und trotzdem wäre beim ersten Befehlssatz keine Abfrage nach dem root PW gekommen, wenn SUDO niht installiert wäre bzw. es wäre vorher schon eine Fehlermeldung gekommen.
Oder nicht???
Titel: Antw:Neu Installation schlägt fehl
Beitrag von: Christian72D am 29 Januar 2022, 16:32:39

ls -l /usr/share/keyrings/debianfhemde-archive-keyring.gpg

Ja, die Datei war vorhanden.

Dann weiter gemacht, jetzt läuft es, danke.
Titel: Antw:Neu Installation schlägt fehl
Beitrag von: Benni am 29 Januar 2022, 16:43:58
jetzt läuft es, danke.

Dann bitte noch bei Gelegenheit den Thread über den Betreff im ersten Post als gelöst kennzeichnen.

gb#