FHEM Forum

FHEM => Frontends => FHEMWEB => Thema gestartet von: hmtec99 am 27 Februar 2021, 13:13:53

Titel: (Autom.) Bereinigung nicht-existenter Attribute ?!
Beitrag von: hmtec99 am 27 Februar 2021, 13:13:53
Wenn man seine FHEM-Instanz für einige Jahre gehegt und gepflegt hat und dann mal wieder an Teilen rumfummelt, die man einige Zeit nicht mehr berührt hat, fallen einem manchmal Attribute auf, die es in der
Form nicht mehr gibt oder welche ersetzt worden sind.

Wäre es nicht sinnvoll wenn FHEM (bzw. die Module) solche Dinge prüfen könnten/würden und dann entsprechende Hinweise ins Log schreiben bzw. (noch besser!) die Attribute einfach löschen
würden?

Gruß, Oli
Titel: Antw:(Autom.) Bereinigung nicht-existenter Attribute ?!
Beitrag von: rudolfkoenig am 27 Februar 2021, 13:32:15
Ich verstehe das Problem nicht.

"Nicht-existente" Attribute:
- werden nicht uebernommen, und beim save damit auch nicht gespeichert.
- beim FHEM-start wird eine Fehlermeldung ins Log geschrieben (DEVNAME: unknown attribute XX)
- fuers Attribut-Umbenennen gibts eine Hilfsfunktion fuer die Module (resolveAttrRename() / $hash->AttrRenameMap)
Titel: Antw:(Autom.) Bereinigung nicht-existenter Attribute ?!
Beitrag von: hmtec99 am 27 Februar 2021, 13:58:28
Dann hast du die Frage/das Problem ja doch verstanden!  ;)

Gut, vielleicht habe ich das falsch in Erinnerung...

Was mir aber definitiv aufgefallen ist (beim letzten Firmwareupdate von HM-Komponenten): Attributwerte werden dabei nicht geprüft, oder?

D.h. wenn ich auf ein Attribut klicke kann es vorkommen, daß der aktuell eingetragen Wert eigenlich nicht (mehr) zulässig ist, weil er gar nicht (mehr) in der
Auswahlliste erscheint.

Ist damit dann noch eine (die ursprüngliche) Funktion gegeben?
Titel: Antw:(Autom.) Bereinigung nicht-existenter Attribute ?!
Beitrag von: Phill am 03 März 2021, 10:08:52
Hallo,

wenn ein Attribut aus einem Gerät entfernt wurde, bleibt die Attributdefinition in der fhem.cfg erst mal bestehen. Das ist korrekt.
Aber eben nur bis zum nächsten Speichern, dabei fliegt es aus der fhem.cfg raus.
Anscheinend hast du nach dem Upgrade keinen Neustart gemacht. Denn dabei werden die alten Attribute auch nicht mehr geladen, mit der bereits erwähnten Fehlermeldung.

Eine Funktion ist höchst wahrscheinlich nicht mehr gegeben, da das Modul das Attribut ja nicht mehr anbietet.

Titel: Antw:(Autom.) Bereinigung nicht-existenter Attribute ?!
Beitrag von: Beta-User am 03 März 2021, 10:18:18
Was mir aber definitiv aufgefallen ist (beim letzten Firmwareupdate von HM-Komponenten): Attributwerte werden dabei nicht geprüft, oder?
Ähm, CUL_HM ist teilweise speziell, weil da Attribute in der cfg zulässig sind, die über FHEMWEB nicht gesetzt werden können (da normalerweise vom Modul befüllt)...
Vielleicht steckt auch das hinter deiner Frage?