FHEM Forum

FHEM => Sonstiges => Thema gestartet von: Hubi22 am 27 Januar 2019, 14:59:31

Titel: HTTPMOD liefert "HTTP/1.1 301 Moved Permanently"
Beitrag von: Hubi22 am 27 Januar 2019, 14:59:31
Moin,

ich würde gern donnerwetter.de für OZON und UV und Kratzprognose (Autoscheiben) nutzen. leider bekomme ich keine Werte in Readings eingelesen. im httpheader steht z.B.:

HTTP/1.1 301 Moved Permanently
Date: Sun, 27 Jan 2019 13:55:14 GMT
Server: Apache/2.2.15 (CentOS)
Location: https://www.donnerwetter.de/pollenflug/region.hts?plz=29356
Cache-Control: max-age=600
Expires: Sun, 27 Jan 2019 14:05:14 GMT
Vary: Accept-Encoding
Content-Encoding: gzip
Content-Length: 271
Connection: close
Content-Type: text/html; charset=iso-8859-1

Könnte mir bitte jmd. einen Tipp geben?

Gruß, Hubi
Titel: Antw:HTTPMOD liefert "HTTP/1.1 301 Moved Permanently"
Beitrag von: Hubi22 am 30 Januar 2019, 06:48:15
Hi, keiner eine Idee? Ich wäre für jeden Tipp dankbar... Gruß, Hubi
Titel: Antw:HTTPMOD liefert "HTTP/1.1 301 Moved Permanently"
Beitrag von: frank am 30 Januar 2019, 14:51:48
idee: du nutzt die falsche url.
Titel: Antw:HTTPMOD liefert "HTTP/1.1 301 Moved Permanently"
Beitrag von: Hubi22 am 10 Februar 2019, 11:24:56
Hi frank

nein, die URL oben ist nur ein Beispiel (hier Pollenflug). Die URL ist erreichbar und stimmt auch. Im Browser lässt sie sich einwandfrei laden.

Vor ca. 1/2 Jahr liefen die Abfragen ohne Probleme. Nun leider nicht mehr. Es ist mir allerdings erst spät aufgefallen, da ich die Werte ja nun nicht täglich anschaue.

Gruß, Hubi 
Titel: Antw:HTTPMOD liefert "HTTP/1.1 301 Moved Permanently"
Beitrag von: dev0 am 10 Februar 2019, 12:15:46
Vmtl. blockiert die Website Aufrufe mit dem User-Agent "FHEM" oder anderen Indizien, dass der Aufruf automatisiert erfolgt...
Das kannst Du z.B so ausprobieren, wenn Du den User-Agent anpasst:

{use HttpUtils;; my $p = { 'url' => 'https://www.donnerwetter.de/pollenflug/region.hts?plz=29356', header => { "User-Agent" => "FHEM"} };; my ($e, $d ) = HttpUtils_BlockingGet($p);; Debug $d}
{use HttpUtils;; my $p = { 'url' => 'https://www.donnerwetter.de/pollenflug/region.hts?plz=29356', header => { "User-Agent" => "Mozilla/1.22"} };; my ($e, $d ) = HttpUtils_BlockingGet($p);; Debug $d}

Und Dir dann die unterschiedlichen Ausgaben im Log ansiehst...
Titel: Antw:HTTPMOD liefert "HTTP/1.1 301 Moved Permanently"
Beitrag von: Hubi22 am 22 Februar 2019, 15:44:06
 :-\
lasterror gibt
https://www.donnerwetter.de/biowetter/uvregion.hts?lid=DE14995&Ort=BROECKEL: Can't connect(2) to https://www.donnerwetter.de:443: SSL connect attempt failed error:14077102:SSL routines:SSL23_GET_SERVER_HELLO:unsupported protocol
aus...
im log steht nichts weiter...
...muss ich den loglevel (zurzeit 4) ändern?
Titel: Antw:HTTPMOD liefert "HTTP/1.1 301 Moved Permanently"
Beitrag von: herrmannj am 22 Februar 2019, 17:53:08
zu post #1: das ist typisch wenn man eine Seite per http aufruft und dort auf die https version geleitet wird.
Titel: Antw:HTTPMOD liefert "HTTP/1.1 301 Moved Permanently"
Beitrag von: Hubi22 am 27 Februar 2019, 20:36:50
Ok, danke für den Hinweis. Ich hatte zuvor den Aufruf http nun verwende ich https.

... aber wie bekomme ich die SSL Fehlermeldung weg?

Gruß, Hubi