Autor Thema: [erledigt] FHEM startet nach ConBee-Update nicht mehr / Missgestalteter Eintrag  (Gelesen 427 mal)

Offline Jogi

  • Sr. Member
  • ****
  • Beiträge: 513
Hallo,
ich habe heute meinen Conbee-Stick manuell upgedatet.
Nach dieser Anleitung:
https://github.com/dresden-elektronik/deconz-rest-plugin/wiki/Update-deCONZ-manually#update-in-raspbian
Das ist auch alles ohne Fehlermeldung durchgelaufen.
Der Conbee-Stick ist auch erreichbar und zeigt in der Phoscon App die neue Version.
Allerdings startet FHEM jetzt nicht mehr und ich bekomme folgende Fehlermeldung:
● fhem.service - LSB: FHEM server
   Loaded: loaded (/etc/init.d/fhem; generated)
   Active: failed (Result: exit-code) since Sat 2020-06-27 18:14:03 CEST; 6min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 388 ExecStart=/etc/init.d/fhem start (code=exited, status=100)

Jun 27 18:14:02 raspberrypi systemd[1]: Starting LSB: FHEM server...
Jun 27 18:14:03 raspberrypi fhem[388]: E: Missgestalteter Eintrag 1 in list Datei /etc/apt/sources.list.d/deconz.list (Component)
Jun 27 18:14:03 raspberrypi fhem[388]: E: Die Liste der Quellen konnte nicht gelesen werden.
Jun 27 18:14:03 raspberrypi systemd[1]: fhem.service: Control process exited, code=exited, status=100/n/a
Jun 27 18:14:03 raspberrypi systemd[1]: fhem.service: Failed with result 'exit-code'.
Jun 27 18:14:03 raspberrypi systemd[1]: Failed to start LSB: FHEM server.
Der Inhalt der Datei deconz.list sieht wie folgt aus:
deb http://phoscon.de/apt/deconz              main
Ich will nicht ausschliessen, dass der Fehler bei mir liegt. Bin mir dessen nur nicht bewusst.
Wo liegt der Fehler und wie bekomme ich FHEM wieder zum laufen. Ich bin leider überfordert.

Tipps wären super.

Danke
« Letzte Änderung: 28 Juni 2020, 09:39:58 von Jogi »

Offline amenomade

  • Developer
  • Hero Member
  • ****
  • Beiträge: 7416
Ich würde die Zeile in deconz.list einfach löschen, bzw die Datei selbst, und dann ein sudo apt-get update machen.

Die Zeile ist sowieso falsch: es fehlt die Distribution/Relase zwischen URL und main. Alternative kann man dann dort das Ergebnis von "lsb_release -cs" hinzufügen
« Letzte Änderung: 27 Juni 2020, 19:19:07 von amenomade »
Pi 3B, Alexa, CUL868+Selbstbau 1/2λ-Dipol-Antenne, USB Optolink / Vitotronic, Debmatic und HM / HmIP Komponenten, Rademacher Duofern Jalousien, Fritz!Dect Thermostaten, Proteus
Informativ Informativ x 1 Liste anzeigen

Offline Jogi

  • Sr. Member
  • ****
  • Beiträge: 513
Ich würde die Zeile in deconz.list einfach löschen, bzw die Datei selbst, und dann ein sudo apt-get update machen.
Vielen Dank,
das hat geholfen. Funktioniert wieder.

Gruß,
Jogi