Autor Thema: [GELÖST] - CUNO2 im rfmode HomeMatic  (Gelesen 3421 mal)

Offline eckhard scholz

  • New Member
  • *
  • Beiträge: 48
  • schon länger im FHEM-Forum als man annimmt
[GELÖST] - CUNO2 im rfmode HomeMatic
« am: 17 Oktober 2021, 10:17:58 »
Hallo Fhem-Gemeinde,

ich habe seit einigen Tagen ein Problem.
1. CUNO meldet sich schon seit längerer Zeit immer mal ab und wieder an. Ist das normal?
2. seit kurzem ist die Meldung "Setting CUNO fhtid ..." dazu gekommen, Dies könnte seit dem letzten Fhem-Update gekommen sein.
Ich habe überall gesucht und nix dazu gefunden. Was ist der Code "A00xxx"?
3. Was bedeutet "CUNO: Unknown code ...". Was für ein Code soll unbekannt sein?

Alle HomeMatic Devices und auch der CUNO arbeiten ansonst einwandfrei.
Ich bitte um eine kleine Hilfestellung.

Gruß
Eckhard


Auszug aus log-file

2021.10.17 06:14:57 1: 192.168.178.xxx:2323 disconnected, waiting to reappear (CUNO)
2021.10.17 06:14:58 3: CUNO: Possible commands: mBCFiAIGMRTVWXOefyyyyyyy
2021.10.17 06:14:58 2: Setting CUNO fhtid from A00BE to 0000
2021.10.17 06:14:58 1: 192.168.178.xxx:2323 reappeared (CUNO)
2021.10.17 06:21:31 3: CUNO: Unknown code 0000, help me!

2021.10.17 07:09:42 1: 192.168.178.xxx:2323 disconnected, waiting to reappear (CUNO)
2021.10.17 07:09:42 3: CUNO: Possible commands: mBCFiAIGMRTVWXOefyyyyyyy
2021.10.17 07:09:42 1: 192.168.178.xxx:2323 reappeared (CUNO)

2021.10.17 07:21:15 1: 192.168.178.xxx:2323 disconnected, waiting to reappear (CUNO)
2021.10.17 07:21:15 3: CUNO: Possible commands: mBCFiAIGMRTVWXOefyyyyyyy
2021.10.17 07:21:15 2: Setting CUNO fhtid from A0085 to 0000
2021.10.17 07:21:15 1: 192.168.178.xxx:2323 reappeared (CUNO)
2021.10.17 07:45:00 3: CUNO: Unknown code 0000, help me!


Auszug aus fhem.cfg

define CUNO CUL 192.168.178.xxx:2323 0000
setuuid CUNO 60f11850-f33f-0f9b-eada-f820f30864fyyyyyyy
attr CUNO hmId 5zzzz9
attr CUNO icon cul_868
attr CUNO rfmode HomeMatic
attr CUNO room 09.01_System

« Letzte Änderung: 20 Oktober 2021, 14:33:30 von eckhard scholz »
F!B,RPi,Cuno,Cul,S7-300,LOGO,HM,FS20,Shelly

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 18137
Antw:CUNO im rfmode HomeMatic
« Antwort #1 am: 17 Oktober 2021, 10:25:06 »
Seit einigen Tagen bedeutet? Interessant wäre v.a. die "version CUL_HM" - da gab es vor wenigen Tagen das letzte wichtige update. Wenn das nicht aktuell ist, wäre das das erste, was zu ändern wäre.

Ansonsten: bitte Code-Tags nutzen (der #-Button), und keine cfg-Auszüge, sondern "list" oder "list -r".

"unknowncode" ist ziemlich "beliebt", du solltest auf alle Fälle eine VCCU definieren (https://wiki.fhem.de/wiki/Virtueller_Controller_VCCU).
Server: HP-T620@Debian 11, aktuelles FHEM@ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn: u.a MySensors, Weekday-&RandomTimer, Twilight,  div. attrTemplate-files

Offline eckhard scholz

  • New Member
  • *
  • Beiträge: 48
  • schon länger im FHEM-Forum als man annimmt
Antw:CUNO im rfmode HomeMatic
« Antwort #2 am: 17 Oktober 2021, 10:39:38 »
OK ich bin nicht so oft im Forum, bis jetzt habe ich fast alle meine Probleme und Fragen im Forum oder anders wo finden können.

Die Version von CUL_HM könnte noch eine ältere sein, wenn sie nicht mit Fhem-Update aktualisiert wird.

VCCU ist definiert
F!B,RPi,Cuno,Cul,S7-300,LOGO,HM,FS20,Shelly

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 18137
Antw:CUNO im rfmode HomeMatic
« Antwort #3 am: 17 Oktober 2021, 10:48:19 »
Sie wird mit FHEM-update aktualisiert. Das Problem könnte nur sein, dass bis vor ein paar Tagen eine Version im Umlauf war, die manche Wackler enthielt. Also: ist das 25059 oder höher, was "version CUL_HM" liefert, oder was kommt da raus?
Server: HP-T620@Debian 11, aktuelles FHEM@ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn: u.a MySensors, Weekday-&RandomTimer, Twilight,  div. attrTemplate-files

Offline eckhard scholz

  • New Member
  • *
  • Beiträge: 48
  • schon länger im FHEM-Forum als man annimmt
Antw:CUNO im rfmode HomeMatic
« Antwort #4 am: 17 Oktober 2021, 15:05:27 »
also es ist die Version
CUL_HM.pm      25059 2021-10-10
F!B,RPi,Cuno,Cul,S7-300,LOGO,HM,FS20,Shelly

Offline eckhard scholz

  • New Member
  • *
  • Beiträge: 48
  • schon länger im FHEM-Forum als man annimmt
Antw:CUNO im rfmode HomeMatic
« Antwort #5 am: 17 Oktober 2021, 15:13:13 »
Habe gerade noch mal ein Update gemacht:

00_CUL.pm             24815 2021-08-01 16:14:02
10_CUL_HM.pm       25078 2021-10-16 10:31:26
14_CUL_WS.pm       20918 2020-01-08 19:20:38

Mal sehen ob das hilft.
Und wenn nicht ???
F!B,RPi,Cuno,Cul,S7-300,LOGO,HM,FS20,Shelly

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 18137
Antw:CUNO im rfmode HomeMatic
« Antwort #6 am: 17 Oktober 2021, 15:31:40 »
OK, CUL 24815.
Dazu hat bisher keiner Probleme gemeldet, aber CUNO sind vermutlich auch nicht mehr so viele im Umlauf. Vielleicht kannst du noch die firmware version liefern?

An sich glaube ich auch nicht, dass es was mit 00_CUL.pm zu tun hat, sondern eher mit der geänderten IO-Initialisierung in CUL_HM.

@frank hatte da noch einen Vorschlag, der (eher vielleicht) helfen könnte, ist hier eingearbeitet: https://forum.fhem.de/index.php/topic,123473.0.html.

Sonst habe ich grade keine Idee, wo was fünfstelliges herkommen könnte, das paßt nicht zu CUL_HM-Hauptgeräten...
Server: HP-T620@Debian 11, aktuelles FHEM@ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn: u.a MySensors, Weekday-&RandomTimer, Twilight,  div. attrTemplate-files

Offline eckhard scholz

  • New Member
  • *
  • Beiträge: 48
  • schon länger im FHEM-Forum als man annimmt
Antw:CUNO im rfmode HomeMatic
« Antwort #7 am: 17 Oktober 2021, 20:29:37 »
Also die CUNO Version ist V1.44 CUNO868.
Auch das heutige Update von CUL_HM.pm 25078 2021-10-16 hat nix gebracht, die Meldung tritt immer noch auf.
Das Gute ist erstmal, das trotzdem alle Devices einwandfrei arbeiten.
Na mal sehen was ich noch finde und ev. machen kann.
Was ist eigentlich der Nachfolger von dem CUNO? Ich hab das Teil bestimmt schon 6-7 Jahre.

Danke erstmal
Gruß
Eckhard
F!B,RPi,Cuno,Cul,S7-300,LOGO,HM,FS20,Shelly

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 18137
Antw:CUNO im rfmode HomeMatic
« Antwort #8 am: 17 Oktober 2021, 20:54:04 »
Bin kein CUNO-Experte, aber bei CUL ist die firmware firmwareversion irgendwo bei um die 1.6. Vielleicht reicht ein update der firmware?

(Wobei es eine Variante mit "timestamp" gibt, die für Homematic eigentlich zu empfehlen wäre (braucht ein anders (TS-) CUL-Modul).

"Nachfolger" ist schwierig, weil BidCoS (das alte HomeMatic-Protokoll) an sich ein Auslaufmodell ist und man vermutlich damit heute gar nicht mehr einsteigen würde. Direkter "Enkel" des CUNO dürfe MapleCUN sein (gibt's einen Wiki-Artikel zu), aber für Homematic ist ein "natives" Interface besser, für BidCoS "solo" mAn. dann also das HM-Mod-RPI-PCB, das man auch via Netzwerk einbinden kann (auch dazu gibt es einen Wiki-Artikel).

Würde erst mal nachsehen, ob eine aktuellere firmware bereit Abhilfe schafft.
Server: HP-T620@Debian 11, aktuelles FHEM@ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn: u.a MySensors, Weekday-&RandomTimer, Twilight,  div. attrTemplate-files

Offline eckhard scholz

  • New Member
  • *
  • Beiträge: 48
  • schon länger im FHEM-Forum als man annimmt
Antw:CUNO im rfmode HomeMatic
« Antwort #9 am: 18 Oktober 2021, 07:22:17 »
Danke erstmal Betta-User,

ich werde das mit der 1.6 Firmware mal probieren. Das CUNO-Modul ist sonst i.o. hatte bis jetzt auch keine Probleme damit. Das Teil hatte für mich den Vorteil das ich es recht Zentral im Haus an das Netzwerk anschließen konnte.
Deine Vorschläge für den CUNO-Nachfolger werde ich mir mal ansehen.  Das HM-Mod-RPI-PCB ist bestimmt die beste Wahl, leider eben nur direkt am Rpi betreibbar. MapleCUN kenne ich nicht, werde also mal Wiki studieren.
Mit "timestamp" und  (TS-) CUL-Modul kann ich nichts anfangen, kannst Du mir da vielleicht noch auf die Sprünge helfen?
Es eilt ja nicht, da ja ansonsten alles Funktioniert.

Erstmal vielen Dank
Gruß
Eckhard
F!B,RPi,Cuno,Cul,S7-300,LOGO,HM,FS20,Shelly

Offline MadMax-FHEM

  • Hero Member
  • *****
  • Beiträge: 12052
  • NIVEAu ist keine Creme...
Antw:CUNO im rfmode HomeMatic
« Antwort #10 am: 18 Oktober 2021, 07:38:11 »
Zitat
Das HM-Mod-RPI-PCB ist bestimmt die beste Wahl, leider eben nur direkt am Rpi betreibbar.

Hatte Beta-User doch schon geschrieben: geht auch per Netzwerk!
Siehe: https://wiki.fhem.de/wiki/HM-MOD-RPI-PCB_HomeMatic_Funkmodul_f%C3%BCr_Raspberry_Pi

(PI ser2net o.ä. LAN-Adapter [WLAN mittels ESP])

Gruß, Joachim
FHEM PI3B+ Bullseye: HM-CFG-USB, 40x HM, ZWave-USB, 13x ZWave, EnOcean-PI, 15x EnOcean, HUE/deCONZ, CO2, ESP-Multisensor, Shelly, alexa-fhem, ...
FHEM PI2 Buster: HM-CFG-USB, 25x HM, ZWave-USB, 4x ZWave, EnOcean-PI, 3x EnOcean, Shelly, ha-bridge, ...
FHEM PI3 Buster (Test)

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 18137
Antw:CUNO im rfmode HomeMatic
« Antwort #11 am: 18 Oktober 2021, 07:45:23 »
ich werde das mit der 1.6 Firmware mal probieren. Das CUNO-Modul ist sonst i.o. hatte bis jetzt auch keine Probleme damit. Das Teil hatte für mich den Vorteil das ich es recht Zentral im Haus an das Netzwerk anschließen konnte.
Dann mal viel Erfolg. Falls du fertige firmware suchst, kannst du ggf. auch "aculfw" verwenden: https://github.com/heliflieger/a-culfw/tree/master/culfw/Devices/CUNO (bzw. unter https://github.com/heliflieger/a-culfw gibt's einen Link).

Zitat
Deine Vorschläge für den CUNO-Nachfolger werde ich mir mal ansehen.  Das HM-Mod-RPI-PCB ist bestimmt die beste Wahl, leider eben nur direkt am Rpi betreibbar.
Das mit dem Wiki hätte geklärt, dass es auch ohne Pi geht. Meines hängt z.B. an einem USB-seriell-Wandler, weitere Beispiele sind da auch zu finden, z.B. https://wiki.fhem.de/wiki/HM-MOD-RPI-PCB_HomeMatic_Funkmodul_f%C3%BCr_Raspberry_Pi#Betrieb_mit_einem_LAN-TTL-Wandler.
(Mit einem MapleCUN müßte auch OneWire gehen).

Zitat
Mit "timestamp" und  (TS-) CUL-Modul kann ich nichts anfangen, kannst Du mir da vielleicht noch auf die Sprünge helfen?
https://forum.fhem.de/index.php/topic,24436.msg1167796.html#msg1167796
Server: HP-T620@Debian 11, aktuelles FHEM@ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW, BT@OpenMQTTGw | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN | RHASSPY
svn: u.a MySensors, Weekday-&RandomTimer, Twilight,  div. attrTemplate-files

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25346
Antw:CUNO im rfmode HomeMatic
« Antwort #12 am: 18 Oktober 2021, 09:24:51 »
Vor dem Flashen bitte pruefen, ob es ein CUNO (ab 2010-11) oder ein CUNO2 (ab 2011-09) ist.

Offline eckhard scholz

  • New Member
  • *
  • Beiträge: 48
  • schon länger im FHEM-Forum als man annimmt
Antw:CUNO im rfmode HomeMatic
« Antwort #13 am: 18 Oktober 2021, 11:41:53 »
An Rudolf,

danke für den Tipp !!!
Ich werde vorher auf die Leiterplatte schauen.
F!B,RPi,Cuno,Cul,S7-300,LOGO,HM,FS20,Shelly

Offline eckhard scholz

  • New Member
  • *
  • Beiträge: 48
  • schon länger im FHEM-Forum als man annimmt
Antw:CUNO im rfmode HomeMatic
« Antwort #14 am: 19 Oktober 2021, 07:46:41 »
Hallo Rudolf,

ich noch mal.
Was ist zu beachten beim flashen des CUNO2 ?
In culfw ist kein Unterschied beschrieben und es sieht so aus als ob ich die firmware 1.67 flashen kann.
Aktuell habe ich ein CUNO V2.1b mit FW V1.4

Gruß
Eckhard
F!B,RPi,Cuno,Cul,S7-300,LOGO,HM,FS20,Shelly

 

decade-submarginal