Autor Thema: Raspberry Pi CUL HomeMatic not supported  (Gelesen 1365 mal)

Guest

  • Gast
Raspberry Pi CUL HomeMatic not supported
« am: 14 Dezember 2012, 18:49:53 »
Originally posted by: <email address deleted>

Hallo FHEM users,

ich versuche gerade die CUL auf dem Raspberry Pi zum laufen zu bekommen.
Zur Zeit bin ich soweit, das FHEM die CUL findet aber nicht richtig
einbinden kann. Hier ein Auszug aus dem Log:
 

> 2012.12.14 18:43:17 3: Opening CUL1 device /dev/ttyAMA0
> 2012.12.14 18:43:17 3: Setting CUL1 baudrate to 9600
> 2012.12.14 18:43:17 3: CUL1 device opened
> 2012.12.14 18:43:26 1: Cannot init /dev/ttyAMA0, ignoring it
> 2012.12.14 18:43:26 2: CUL1: Mode HomeMatic not supported
>
>  
Leider bin ich noch absoluter Anfänger mit FHEM und kann mir nicht mehr
weiterhelfen. Im Forum bin ich auch nicht wirklich fündig geworden.
Die Software Versionen dürften alle auf dem aktuellen Stand sein.

Hat jemand dieses Problem auch schon mal gehabt?

Vielen Dank für eure Hilfe. Schöne Weihnachtszeit
olum

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25594
Re: Raspberry Pi CUL HomeMatic not supported
« Antwort #1 am: 16 Dezember 2012, 15:18:14 »
                                                   

> ich versuche gerade die CUL auf dem Raspberry Pi zum laufen zu bekommen.
...
> > 2012.12.14 18:43:17 3: Opening CUL1 device /dev/ttyAMA0

- das CUL wird auch auf dem RPi unter /dev/ttyACM0 eingebunden, genau wie auf
  allen anderen Linux Systemen

- /dev/ttyAMA0 auf der RPi ist die serielle Schnittstelle, dieser ist per
  default mit einem getty bestueckt, damit jemand seinen guten alten VT100 per
  RS232 anschliessen kann, und sich darueber anmelden kann.
  fhem sucht auf /dev/ttyAMA0 nach einem CUL, da das COC darueber eingebunden
  wird, und fuer fhem ist COC gleich CUL.  Dazu muss man aber das getty auf dem
  RPi vorher abschalten, und natuerlich ein COC einstecken.

-> Das relevante Log (das mit /dev/ttyACM0) wurde hier nicht gepostet, nur das
   Fehlversuch, wo fhem nach dem COC geschaut hat.

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com

Offline tostmann

  • Developer
  • Full Member
  • ****
  • Beiträge: 291
Re: Raspberry Pi CUL HomeMatic not supported
« Antwort #2 am: 17 Dezember 2012, 20:18:30 »
                                                 

Am 14.12.2012 um 18:49 schrieb Olum:

> 2012.12.14 18:43:17 3: Setting CUL1 baudrate to 9600

Das COC erfordert 38400 - nicht 9600 Baud!!

Bitte trotz aller unguten Gewohnheiten diese Seite lesen und befolgen:
http://busware.de/tiki-index.php?page=COC_Installation


--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com

Guest

  • Gast
Re: Raspberry Pi CUL HomeMatic not supported
« Antwort #3 am: 18 Dezember 2012, 22:10:49 »
Originally posted by: <email address deleted>

@RudolfKoenig: ich habe jetzt die getty Einträge entfernt nach dieser
Anleitung: http://www.fhemwiki.de/wiki/Raspberry_Pi:_CSM
Leider hatte es keine Auswirkung.
Die CULl wird immer noch unter ttyAMA0 eingebunden.

@DT ich verwende eine USB CUL von Busware und nicht die COC.

Habe nochmal den Log vom Booten angehängt.
Wenn ich es richtig verstehe, müsste die CUL als ttyACM0 eingebunden werden?

Ich werde es weiter versuchen.

2012.12.18 21:59:47 1: Including fhem.cfg
2012.12.18 21:59:51 3: telnetPort: port 7072 opened
2012.12.18 21:59:52 3: WEB: port 8083 opened
2012.12.18 21:59:52 3: WEBphone: port 8084 opened
2012.12.18 21:59:52 3: WEBtablet: port 8085 opened
2012.12.18 21:59:53 1: Including ./log/fhem.save
2012.12.18 21:59:54 1: usb create starting
2012.12.18 22:00:33 1: CULflash (dfu-programmer atmega32u4 erase && dfu-programmer atmega32u4 flash ./FHEM/CUL_V3.hex && dfu-programmer atmega32u4 start) 2>&1
2012.12.18 22:00:33 1: CULflash dfu-programmer: no device present.

2012.12.18 22:00:37 3: Opening CUL device /dev/ttyAMA0
2012.12.18 22:00:37 3: Setting CUL baudrate to 38400
2012.12.18 22:00:37 3: CUL device opened
2012.12.18 22:00:38 1: usb create end
2012.12.18 22:00:38 2: SecurityCheck:  WEB,WEBphone,WEBtablet has no basicAuth attribute. telnetPort has no password/globalpassword attribute.  Restart fhem for a new check if the problem is fixed, or set the global attribute motd to none to supress this message.
2012.12.18 22:00:38 0: Server started (version Fhem 5.3 (DEVELOPMENT), $Id: fhem.pl 1996 2012-10-20 07:11:56Z rudolfkoenig $, pid 1796)




--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com

Guest

  • Gast
Re: Raspberry Pi CUL HomeMatic not supported
« Antwort #4 am: 19 Dezember 2012, 07:40:45 »
Originally posted by: <email address deleted>

>
>
> Nochmal: wie oben schon gesagt, kommst du mit ttyAMA0 nicht weiter...
>

Versuche:

define CUL_0 CUL /dev/ttyACM0@9600 0000

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com

Offline Mr. P

  • Tester
  • Sr. Member
  • ****
  • Beiträge: 988
Re: Raspberry Pi CUL HomeMatic not supported
« Antwort #5 am: 19 Dezember 2012, 07:54:46 »
                                                       

Hej hej,

Steck den CUL ab, nach ein paar Sekunden wieder an und dann poste doch
einmal die letzten 20 Zeilen, was 'dmesg' in der bash-shell ausgibt. Vorher
brauchen wir nicht weiter reden. ;-)

Greetz,
   Gerhard
Am 19.12.2012 07:40 schrieb "dougie@m1n1.de" :

>
>> Nochmal: wie oben schon gesagt, kommst du mit ttyAMA0 nicht weiter...
>>
>
> Versuche:
>
> define CUL_0 CUL /dev/ttyACM0@9600 0000
>
> --
> To unsubscribe from this group, send email to
> fhem-users+unsubscribe@googlegroups.com
>

--
To unsubscribe from this group, send email to
fhem-users+unsubscribe@googlegroups.com
Greetz,
   Mr. P

 

decade-submarginal