Autor Thema: Fehlerhafte MAX1724 Bausteine  (Gelesen 1086 mal)

Offline vbs

  • Hero Member
  • *****
  • Beiträge: 2295
Fehlerhafte MAX1724 Bausteine
« am: 03 Mai 2019, 00:09:00 »
Als ich dabei war, mir einen von TomMajor's Homematic-Sensoren zu bauen (https://github.com/TomMajor/SmartHome/tree/master/HB-UNI-Sensor1), hab ich mir StepUp-Wandler MAX1724 bei Aliexpress bestellt. Jedoch hat sich der StepUp dann auf der Platine nicht erwartungsgemäß Verhalten (Details hier: https://forum.fhem.de/index.php/topic,20620.msg929740.html#msg929740).

Zitat
Und zwar hab ich den Sensor aufgebaut mit zwei Sensoren und das war erstmal alles ok. Nun hab ich noch den Step-Up dazu gebastelt. Soweit ich weiß, macht der ja aus verschiedenen Eingangsspannungen die benötigten 3,3 V.
Das Problem ist nun, dass der Controller sehr früh aussteigt, wenn ich die Spannung absenke. Also wenn ich 3,3 V anlege, dann läuft er stabil. Eben so bei z.B. 2,8 V. Wenn ich jedoch auf 2,5 V runterregele, dann läuft er erst weiterhin (und es werden auch 3,3 V am StepUp ausgegeben), aber sobald dann der Controller senden will, bricht die Spannung offenbar ein (auf 1,0 V glaub ich) und dann scheint der Controller zu stehen.
In dem Moment steigt dann komischerweise auf einmal auch der Stromverbrauch von 0,00 A (also sehr wenig) auf 0,07 A (und mein günstiges regelbares Netzteil fängt an so komische sirrende Geräusche zu machen).

Ich hätte eigentlich erwartet, dass ich die Spannung bis ca. 2,1 V runterregeln kann und der Controller weiter läuft, oder? Zumindest ist 2,1 V ja als LowBatVoltage eingetragen.

Auch ein Austausch gegen ein anders Exemplar (aus der gleichen Bestellung) hat am Verhalten nichts geändert. Ich habe dann nochmal MAX1724s in Deutschland (RSOnline) bestellt und damit hat sich die Schaltung dann sofort erwartungsgemäß Verhalten. Also definitiv war mit den Teilen von Aliexpress etwas faul. Parallel hatte ich noch von einem andere Händler bei Aliexpress nochmals welche bestellt. Die sahen wieder identisch aus und haben sich identisch (falsch) verhalten. Ich kann nicht beurteilen, ob die Dinger gefälscht oder kaputt oder einfach nur falsch beschriftet (?!) sind. Ich kann nur sagen, dass sie sich meiner Meinung nach nicht gemäß Spezifikation verhalten.

Es waren diese beiden Angebote:

Im Anhang findet ihr Bilder der Bauteile in der Hoffnung, dass jemand anderem das gleiche Schicksal erspart leibt. Danke nochmals an die Kollegen aus dem Selbstbau-Thread für die Unterstützung bei der Fehlersuche (https://forum.fhem.de/index.php/topic,20620.0.html).

EDIT:
Link zum zweiten Ali-Angebot korrigiert.
« Letzte Änderung: 04 Mai 2019, 13:36:28 von vbs »
Gefällt mir Gefällt mir x 2 Informativ Informativ x 3 Liste anzeigen

Offline tndx

  • Full Member
  • ***
  • Beiträge: 447
Antw:Fehlerhafte MAX1724 Bausteine
« Antwort #1 am: 03 Mai 2019, 07:59:27 »
Ich habe hier das gleiche Problem, habe das bis jetzt einem schlechten CC1101 zugeschrieben und hatte noch keine Zeit gehabt, genau zu analysieren. Das Funkmodul stammt eigentlich aus einer "guten" Lieferung, aber der MAX1724 aus der gleichen Quelle, wie bei Dir. Kannst Du folgendes bestätigen: der Controller startet nicht etwa neu, das würde ich nämlich am Blinken der LED merken, sondern er sendet "nur" nicht?
« Letzte Änderung: 03 Mai 2019, 10:34:10 von tndx »
Informativ Informativ x 1 Liste anzeigen

Offline PeMue

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4842
Antw:Fehlerhafte MAX1724 Bausteine
« Antwort #2 am: 03 Mai 2019, 09:57:26 »
Ups, ich habe mir aus dem gleichen Shop diese hier
https://www.aliexpress.com/item/20PCS-MAX1724EZK33-MAX1724EZK-MAX1724EZ-MAX1724E-MAX1724-SOT23-5/32953435768.html?spm=a2g0s.9042311.0.0.27424c4dD6skfZ
gekauft, aber mir ist noch nichts dergleichen aufgefallen. Aber ich werde mal die Bilder vergleichen.

@vbs: danke für die Zusammenfassung.

Gruß Peter
1x FB7170 (29.04.88) 5.7 1xCUNO2 1.67 2xEM1000WZ 2xUniroll 1xASH2200 3xHMS100T(F)
1x RPi BV2LCDCSM 1.63 5.7 2xMAX HKT, 1xMAX RT, V200KW1
1xFB 7490 (113.06.05) 5.7 1xCUL V3 1.63 1xHM-CC-RT-DN 1.4 1xHM-TC-IT-WM 1.1 1xHB-UW-Sen-THPL-O 0.15 1x-I 0.14OTAU 1xRFXtrx 90 1xWT440H 1xCM160 3xTFA30.3150 5xFA21

Offline vbs

  • Hero Member
  • *****
  • Beiträge: 2295
Antw:Fehlerhafte MAX1724 Bausteine
« Antwort #3 am: 03 Mai 2019, 16:12:26 »
der Controller startet nicht etwa neu, das würde ich nämlich am Blinken der LED merken, sondern er sendet "nur" nicht?
Ja, meiner Meinung nach bleibt der Controller stehen, sobald der MAX belastet wird. Ich hab es bei mir mit einem regelbaren Netzteil getestet und ich kann die Spannung runter drehen, aber der Controller bleibt dann beim nächsten Sendeversuch (der Last erzeugt) stehen.

PS.
Im ersten Post war der Link zum zweiten Ali-Angebot falsch. Das hab ich korrigiert.
« Letzte Änderung: 03 Mai 2019, 21:08:51 von vbs »

Offline Tom Major

  • Full Member
  • ***
  • Beiträge: 423
    • TomMajor@github
Antw:Fehlerhafte MAX1724 Bausteine
« Antwort #4 am: 03 Mai 2019, 22:49:23 »
Sehr gut, das Thema im eigenen Thread zu dokumentieren, @vbs: Daumen hoch.

Weil es hier reinpasst auch noch mal meine Erkenntnisse aus dem anderen Thread:

... habe gerade noch mal meine MAX angeschaut, darunter sind auch welche original von Maxim geliefert. Was mir auffällt ist die Stelle des kleinen +, bei mir und bei den RSOnline ist das zwischen pin 1 & 2, bei den Ali Fakes viel zu weit links außen. Wobei die Ali Fakes auch irgendwie pinkompatible DC/DC Wandler sein müssen (zumindest bei geringen Lasten ist es ja nicht ohne weiteres aufgefallen)

FHEM 5.x auf Raspberry Pi 3 | OWServer mit I2C/DS2482 | 1-Wire 6fach S0-Stromzähler ATtiny/DS2423 Emu. | Heizungs-Mon. mit Firmata (mighty-1284p) | Ölstand-Mon. mit Ultraschall, RFM69 und JeeLink
RaspberryMatic HM Zentrale | diverse HM Devices | AskSinPP Devices

Offline vbs

  • Hero Member
  • *****
  • Beiträge: 2295
Antw:Fehlerhafte MAX1724 Bausteine
« Antwort #5 am: 04 Mai 2019, 13:36:06 »
... habe gerade noch mal meine MAX angeschaut, darunter sind auch welche original von Maxim geliefert
Sieht dein Original-Maxim eigentlich genau so aus, wie meiner von RSOnline?

Offline Tom Major

  • Full Member
  • ***
  • Beiträge: 423
    • TomMajor@github
Antw:Fehlerhafte MAX1724 Bausteine
« Antwort #6 am: 04 Mai 2019, 18:28:07 »
Sieht dein Original-Maxim eigentlich genau so aus, wie meiner von RSOnline?

Ja, das war mein Eindruck. Ich werde morgen noch mal ein Foto hochladen.
FHEM 5.x auf Raspberry Pi 3 | OWServer mit I2C/DS2482 | 1-Wire 6fach S0-Stromzähler ATtiny/DS2423 Emu. | Heizungs-Mon. mit Firmata (mighty-1284p) | Ölstand-Mon. mit Ultraschall, RFM69 und JeeLink
RaspberryMatic HM Zentrale | diverse HM Devices | AskSinPP Devices

Offline Tom Major

  • Full Member
  • ***
  • Beiträge: 423
    • TomMajor@github
Antw:Fehlerhafte MAX1724 Bausteine
« Antwort #7 am: 06 Mai 2019, 22:11:24 »
Und hier noch ein Original direkt von Maxim. Sieht für mich wie der RSOnline chip aus.
Es ist ein 3,0V Typ, deswegen letzter Buchstabe anders.
FHEM 5.x auf Raspberry Pi 3 | OWServer mit I2C/DS2482 | 1-Wire 6fach S0-Stromzähler ATtiny/DS2423 Emu. | Heizungs-Mon. mit Firmata (mighty-1284p) | Ölstand-Mon. mit Ultraschall, RFM69 und JeeLink
RaspberryMatic HM Zentrale | diverse HM Devices | AskSinPP Devices

Offline Ranseyer

  • Hero Member
  • *****
  • Beiträge: 1510
    • Homepage
Antw:Fehlerhafte MAX1724 Bausteine
« Antwort #8 am: 07 Mai 2019, 16:07:20 »
Jedoch hat sich der StepUp dann auf der Platine nicht erwartungsgemäß Verhalten (Details hier: https://forum.fhem.de/index.php/topic,20620.msg929740.html#msg929740).


Der mit "Bad" markiert ist doch abgeschliffen... ((Oder?))
-Dann ist es eigentlich immer ein Fake. Und manchmal auch wirklich Mist. Das Selbe beim simplem AMS1117...
FHEM mit FTUI. Homematic-Funk für Thermostate und Licht. MySensors als Basis für eigene HW.
Zentrale ist der MAPLE-CUL mit RFM69+HModUART-AddOn.
Doku zu meinen Projekten: Github/Ranseyer. Platinen falls verfügbar gerne auf Anfrage.
Support: gerne wenn ich Zeit+Lust habe im Forum. Nicht per PN!
Informativ Informativ x 1 Liste anzeigen

Offline PeMue

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4842
Antw:Fehlerhafte MAX1724 Bausteine
« Antwort #9 am: 12 Mai 2019, 20:01:15 »
Hallo zusammen,

ich denke, dass meine auch Fakes sind, siehe Bild. Den Sketch habe ich schon compiliert, es fehlt nur noch die Ruhestrommessung.

Gruß Peter
1x FB7170 (29.04.88) 5.7 1xCUNO2 1.67 2xEM1000WZ 2xUniroll 1xASH2200 3xHMS100T(F)
1x RPi BV2LCDCSM 1.63 5.7 2xMAX HKT, 1xMAX RT, V200KW1
1xFB 7490 (113.06.05) 5.7 1xCUL V3 1.63 1xHM-CC-RT-DN 1.4 1xHM-TC-IT-WM 1.1 1xHB-UW-Sen-THPL-O 0.15 1x-I 0.14OTAU 1xRFXtrx 90 1xWT440H 1xCM160 3xTFA30.3150 5xFA21

Offline vbs

  • Hero Member
  • *****
  • Beiträge: 2295
Antw:Fehlerhafte MAX1724 Bausteine
« Antwort #10 am: 12 Mai 2019, 23:21:50 »
Hm, das "+" fehlt aber ansonsten sehen die mMn aus wie meine "good"?

Offline Gernott

  • Full Member
  • ***
  • Beiträge: 420
Antw:Fehlerhafte MAX1724 Bausteine
« Antwort #11 am: 30 Juni 2019, 12:01:04 »
Will hier auch mal meine Erfahrung teilen. Mit den China-Teilen bin ich bei den Ruhestrommessungen (3 V an +3.3V-Schiene, also Rückbestromung) nicht auf die 4 µA gekommen, sondern hatte etwas mehr als 40 µA. Als ich das Teil durch das Original ersetzt hatte, ging es dann. Messung des Batteriestromes habe ich allerdings nicht gemacht, gehe aber davon aus, daß die 40 µA der generelle Leckstrom sind. Leider sind die Originale mit ~ 4 € teurer als der ganze Rest zusammen. Die China-Teile werden entsorgt.

Offline Ranseyer

  • Hero Member
  • *****
  • Beiträge: 1510
    • Homepage
Antw:Fehlerhafte MAX1724 Bausteine
« Antwort #12 am: 30 Juni 2019, 12:36:09 »
ich denke, dass meine auch Fakes sind, siehe Bild. Den Sketch habe ich schon compiliert, es fehlt nur noch die Ruhestrommessung.


Man sieht super den Schleifpapiereinsatz im Verleich zu dem IC unten der glatt ist...
FHEM mit FTUI. Homematic-Funk für Thermostate und Licht. MySensors als Basis für eigene HW.
Zentrale ist der MAPLE-CUL mit RFM69+HModUART-AddOn.
Doku zu meinen Projekten: Github/Ranseyer. Platinen falls verfügbar gerne auf Anfrage.
Support: gerne wenn ich Zeit+Lust habe im Forum. Nicht per PN!

Offline vbs

  • Hero Member
  • *****
  • Beiträge: 2295
Antw:Fehlerhafte MAX1724 Bausteine
« Antwort #13 am: 30 Juni 2019, 12:51:32 »
Hm, aber mein originaler ("good") aus dem ersten Post hat auch so eine raue Oberfläche. Eigentlich sieht Peter's Baustein meinem "good" sehr ähnlich sogar.

Offline Ranseyer

  • Hero Member
  • *****
  • Beiträge: 1510
    • Homepage
Antw:Fehlerhafte MAX1724 Bausteine
« Antwort #14 am: 30 Juni 2019, 12:58:29 »
Hmm, dann müsste ich das ja fast zurücknehmen...

RS-Online sollte ja wohl echt sein. ((Aber rauh sind die Teile meist nur nach der Nutzung von Schleifpapier...))
Hast du evtl mal ein Foto mit 1-2 Megapixeln vom guten ?


FHEM mit FTUI. Homematic-Funk für Thermostate und Licht. MySensors als Basis für eigene HW.
Zentrale ist der MAPLE-CUL mit RFM69+HModUART-AddOn.
Doku zu meinen Projekten: Github/Ranseyer. Platinen falls verfügbar gerne auf Anfrage.
Support: gerne wenn ich Zeit+Lust habe im Forum. Nicht per PN!