Autor Thema: Shelly1 per Mqtt - attrTemplate lässt sich nicht abschliessen  (Gelesen 347 mal)

Offline elDudereeno

  • New Member
  • *
  • Beiträge: 17
Hallo Zusammen,

ich nutze mittlerweile sicherlich 10 Jahren FHEM problemlos.
Nun habe ich aber irgendwie einen "bug" den ich nicht loswerde.

Und zwar kann ich Geräte problemlos per MQTT einbinden, aber wenn ich das Template anwenden möchte, dann bekomme ich (oft) noch Parameter zum nachspezifizieren.
In dem konkreten Fall bei einem Shelly1+ werde ich nach dem "shelly1 name in the topic" gefragt (was immer auch damit gemeint ist)

Jetzt mein Problem: Ich kann da was eintragen, aber nirgendwo bestätigen.
Ein "Enter" hilft nicht, einen Bestätigungsknopf gibt es nicht !?
Leider wird das Template so dann auch nicht angewendet.

Kenn das Problem und die Lösung dazu jemand? Oder kann ich den Parameter von Anfang an mitgeben sodass ich nicht mehr gefragt werde?

Vielen Dank
Grüße
Dominik

Online Otto123

  • Tester
  • Hero Member
  • ****
  • Beiträge: 21095
  • schon mal restore trainiert?
    • Otto's Technik Blog
Hallo,

dann bekomme ich (oft) noch Parameter zum nachspezifizieren.
normalerweise ist dann das Gerät noch nicht komplett angelegt. Hier hilft ein Neustart des Gerätes oder mal per Hand schalten o.ä.
Zitat
In dem konkreten Fall bei einem Shelly1+
ähm Shelly 1, Shell Plus 1, Shelly Pro 1 ?
Hintergrund: Pro 1 und Plus 1 haben eine neue API, dafür braucht es neue Templates.

Für den Shelly Plus 1 sollte es schon eines mit diesem Namen shellyPlus_1 geben. https://svn.fhem.de/trac/browser/trunk/fhem/FHEM/lib/AttrTemplate/mqtt2.template#L3427

Gruß Otto
« Letzte Änderung: 30 Juli 2022, 14:54:47 von Otto123 »
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7590,WRT3200ACS-OpenWrt,Sonos,VU+,Arduino nano,ESP8266,MQTT,Zigbee,deconz

Offline elDudereeno

  • New Member
  • *
  • Beiträge: 17
Hallo Otto,

vielen Dank für die schnelle Antwort

Es ist ein "Shelly Plus 1". Das Gleiche ist mir aber auch schon oft bei allen möglichen anderen Shellys aufgefallen.

Ein eigenes Template habe ich nicht gefunden, habe also das Template shelly1 genutzt.

Ich habe den Shelly mehrfach geschalten (per Hand) und auch mal com Strom getrennt.
Das ändert aber nichts daran, dass ich das Template nicht anwenden kann ... weil es das falsche ist?

Danke und Grüße
Dominik

Offline elDudereeno

  • New Member
  • *
  • Beiträge: 17
Ich habe gerade FHEM nochmal geupdated. Seitdem habe ich auch das template für den ShellyPlus1 (Danke für den Hinweis)

Dieses konnte ich auch nutzen/anwenden, dennoch kommen auch hier Parameter die ich nicht auswählen kann (siehe Bild)
Hier stört es aber weniger, da ich ja ansonsten das Template nutzen kann, ist da also eher ein Schönheitsfehler

Online Otto123

  • Tester
  • Hero Member
  • ****
  • Beiträge: 21095
  • schon mal restore trainiert?
    • Otto's Technik Blog
Das Template ist noch in Entwicklung :) ich habe hier nur mitgelesen. Kann dazu jetzt nix sagen. Ich habe kein Alexa
Viele Grüße aus Leipzig
RaspberryPi B B+ B2 B3 B3+ ZeroW,HMLAN,HMUART,Homematic,Fritz!Box 7590,WRT3200ACS-OpenWrt,Sonos,VU+,Arduino nano,ESP8266,MQTT,Zigbee,deconz

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25622
Wenn ich die Screenshots richtig deute, dann landen die Elemente, die normalerweise in einem Dialog mit Ok Knopf landen sollten (siehe Anhang), in diesem Fall direkt auf der Seite. Ich habe keine Ahnung wie man das hinkriegt, ich vermute zusaetzliches JavaScript, was den FHEM-Programmkode verstoert oder einen Viruspruefer / Browser-Plugin, was bestimmte JavaScript-Elemente rausfiltert.

Gibt es Probleme, wenn man die FHEM Seite in einem Inkognito-Fenster aufruft? Hier sind per Voreinstellung die Plugins deaktiviert.

Laut Screenshot wird das alte f11 Style (frueher default) verwendet, aber damit hatte ich gerade eben auch keine Probleme.
Gibt es Probleme mit der aktuellen Style-Voreinstellung, f18?

Offline elDudereeno

  • New Member
  • *
  • Beiträge: 17
Nochmal danke für die Rückmeldungen!

Ich habe normalerweise auch ein anderen Style eingestellt und vorher nur testweise den "alten f11" gewählt um zu prüfen ob es daran liegt.
Es ist aber egal welcher Style, keiner ändert was an der Situation.

Auch im Inkognito-Fenster ist es das selber Verhalten. (In allen anderen Browsern und am Handy im übrigen auch)

Aber jetzt weiß ich wenigstens wie es aussehen sollte, vielleicht ist ja wirklich was im Hintergrund was Java blockiert (zB Pi-Hole, der würde ja jedes Device beeinflussen)
Da probiere ich mal ein wenig rum

Danke und Grüße
Dominik

 

decade-submarginal