Autor Thema: Gelegentlich Fehler beim Start von FHEM (00_TCM.pm)  (Gelesen 5974 mal)

Offline Arek

  • Full Member
  • ***
  • Beiträge: 112
Gelegentlich Fehler beim Start von FHEM (00_TCM.pm)
« am: 26 August 2014, 22:16:44 »
Hi,

ich bekomme neuerdings ab und zu einen Fehler beim Start von FHEM (egal ob reboot des Cubietruck oder shutdown restart):

Can't locate object method "TCM" via package "TCM310" (perhaps you forgot to load "TCM310"?) at ./FHEM/00_TCM.pm line 593.
Danach muss ich mich über SSH anmelden und manuell starten, was dann auf Anhieb klappt.

Woran kann das liegen?

Gruß

Offline krikan

  • Developer
  • Hero Member
  • ****
  • Beiträge: 7029
Antw:Gelegentlich Fehler beim Start von FHEM (00_TCM.pm)
« Antwort #1 am: 26 August 2014, 22:27:44 »
Könntest Du bitte ein paar mehr Infos liefern. Zumindest: Gateway? Versionswechsel? Besonderheiten? Danke!

Ach so: Spasseshalber hatten wir dazu mal was im Wiki geschrieben: http://www.fhemwiki.de/wiki/EnOcean_Starter_Guide#Welche_Infos_sollten_Anfragen_im_EnOcean-Forum_enthalten.3F  ;)
« Letzte Änderung: 26 August 2014, 22:30:37 von krikan »

Offline Arek

  • Full Member
  • ***
  • Beiträge: 112
Antw:Gelegentlich Fehler beim Start von FHEM (00_TCM.pm)
« Antwort #2 am: 26 August 2014, 22:50:38 »
Es ist ein EnOcean TCM310 USB Stick von busware.
Versionen:
# $Id: fhem.pl 6425 2014-08-19 20:55:00Z rudolfkoenig $
# $Id: 10_CUL_HM.pm 6453 2014-08-24 16:00:23Z martinp876 $
# $Id: 95_Dashboard.pm 5921 2014-05-21 18:47:19Z svenson08 $
# $Id: 10_EnOcean.pm 6143 2014-06-19 19:11:44Z klaus-schauer $
# $Id: 93_FHEM2FHEM.pm 6203 2014-07-06 12:31:20Z rudolfkoenig $
# $Id: 01_FHEMWEB.pm 6447 2014-08-24 07:38:52Z rudolfkoenig $
# $Id: 95_FLOORPLAN.pm 6174 2014-06-29 05:51:28Z ulimaass $
# $Id: 92_FileLog.pm 5876 2014-05-16 19:54:51Z rudolfkoenig $
# $Id: 00_HMLAN.pm 6403 2014-08-13 18:33:04Z martinp876 $
# $Id: 98_HMinfo.pm 6452 2014-08-24 12:47:37Z martinp876 $
# $Id: 31_LightScene.pm 6120 2014-06-15 19:11:28Z justme1968 $
# $Id: 70_PIONEERAVR.pm 6369 2014-08-06 21:58:18Z hofrichter $
# $Id: 71_PIONEERAVRZONE.pm 6171 2014-06-28 00:06:17Z hofrichter $
# $Id: 73_PRESENCE.pm 6341 2014-08-01 21:56:21Z markusbloch $
# $Id: 99_SUNRISE_EL.pm 5851 2014-05-13 19:39:03Z rudolfkoenig $
# $Id: 98_SVG.pm 6446 2014-08-23 10:09:44Z rudolfkoenig $
# $Id: 42_SYSMON.pm 6390 2014-08-10 22:06:38Z hexenmeister $
# $Id: 00_TCM.pm 6239 2014-07-11 14:52:22Z klaus-schauer $
# $Id: 99_Utils.pm 6446 2014-08-23 10:09:44Z rudolfkoenig $
# $Id: 98_WOL.pm 6334 2014-07-30 18:59:07Z dietmar63 $
# $Id: 59_Weather.pm 6432 2014-08-20 15:46:12Z borisneubert $
# $Id: 90_at.pm 5319 2014-03-25 10:11:47Z rudolfkoenig $
# $Id: 98_autocreate.pm 6436 2014-08-21 05:40:35Z rudolfkoenig $
# $Id: 98_dummy.pm 4934 2014-02-15 08:23:12Z rudolfkoenig $
# $Id: 91_eventTypes.pm 6428 2014-08-20 11:51:27Z rudolfkoenig $
# $Id: 99_myUtilsThermostat.pm 2013-12-12 Elektrolurch $
# $Id: 91_notify.pm 6371 2014-08-07 05:33:37Z rudolfkoenig $
# $Id: 33_readingsGroup.pm 6221 2014-07-08 18:08:39Z justme1968 $
# $Id: 98_structure.pm 6401 2014-08-13 07:00:48Z rudolfkoenig $
# $Id: 98_telnet.pm 4844 2014-02-08 07:54:03Z rudolfkoenig $
# $Id: 98_update.pm 6454 2014-08-24 16:42:18Z rudolfkoenig $
# $Id: 98_weblink.pm 5608 2014-04-23 10:57:16Z rudolfkoenig $

Internals:
BaseID FFEEEC00
DEF 310 /dev/ttyUSB0@57600
DeviceName /dev/ttyUSB0@57600
FD 11
LastID FFEEEC7F
MODEL ESP3
NAME TCM310
NR 27
NTFY_ORDER 50-TCM310
PARTIAL RSSI -67
STATE initialized
TYPE TCM

readings:
baseID BaseID: FFEEEC00 RemainingWriteCycles: 0A
maturity 01
repeater RepEnable: 00 RepLevel: 00
state initialized

Config:
define TCM310 TCM 310 /dev/ttyUSB0@57600
attr TCM310 alias USB300
attr TCM310 icon cul
attr TCM310 room EnOcean
attr TCM310 sendInterval 0
attr TCM310 verbose 5

Ich schau ob das log mit verbose 5 noch irgendwelche Informationen ausspuckt, aber die letzten 5 restarts haben geklappt...
Wenn noch Informationen benötigt werden, bitte bescheid geben.

Offline krikan

  • Developer
  • Hero Member
  • ****
  • Beiträge: 7029
Antw:Gelegentlich Fehler beim Start von FHEM (00_TCM.pm)
« Antwort #3 am: 26 August 2014, 22:57:34 »
Top, bin begeistert! ABER ich habe leider keine Ideen für Dich :-[. Das scheint eher was für klaus.schauer....
Sorry und Gruß, Christian

Offline Arek

  • Full Member
  • ***
  • Beiträge: 112
Antw:Gelegentlich Fehler beim Start von FHEM (00_TCM.pm)
« Antwort #4 am: 26 August 2014, 23:09:58 »
Trotzdem danke für deine Mühe und Tips mit den Infos  :)

Offline flurin

  • Sr. Member
  • ****
  • Beiträge: 609
Antw:Gelegentlich Fehler beim Start von FHEM (00_TCM.pm)
« Antwort #5 am: 26 August 2014, 23:11:29 »
Hi,

ich bekomme neuerdings ab und zu einen Fehler beim Start von FHEM (egal ob reboot des Cubietruck oder shutdown restart):

Can't locate object method "TCM" via package "TCM310" (perhaps you forgot to load "TCM310"?) at ./FHEM/00_TCM.pm line 593.
Danach muss ich mich über SSH anmelden und manuell starten, was dann auf Anhieb klappt.

Woran kann das liegen?

Gruß

ich würde die Zeile 593 in 00_TCM.pm wie folgt ändern:

- Log3 undef, 1, TCM $name $err;
+ Log3 undef, 1, "TCM $name $err";

Gruss
flurin
« Letzte Änderung: 26 August 2014, 23:14:47 von flurin »

Offline krikan

  • Developer
  • Hero Member
  • ****
  • Beiträge: 7029
Antw:Gelegentlich Fehler beim Start von FHEM (00_TCM.pm)
« Antwort #6 am: 26 August 2014, 23:25:00 »
@flurin: Hab das mal verlinkt nach: http://forum.fhem.de/index.php/topic,14386.msg189689.html#msg189689 . Da gab es ein ähnliches Fehlerbild und ich konnte nicht helfen.

Offline flurin

  • Sr. Member
  • ****
  • Beiträge: 609
Antw:Gelegentlich Fehler beim Start von FHEM (00_TCM.pm)
« Antwort #7 am: 26 August 2014, 23:33:51 »
@flurin: Hab das mal verlinkt nach: http://forum.fhem.de/index.php/topic,14386.msg189689.html#msg189689 . Da gab es ein ähnliches Fehlerbild und ich konnte nicht helfen.

Ich kann es jetzt nicht untersuchen aber ich vermute, es hängt mit dem Fehler, den ich schon gemeldet habe, zusammen.

http://forum.fhem.de/index.php/topic,26459.msg194863.html#new

klaus.schauer wird es beim nächsten Update berichtigen aber solange kann man es selbst tun.

Gruss
flurin

Offline Arek

  • Full Member
  • ***
  • Beiträge: 112
Antw:Gelegentlich Fehler beim Start von FHEM (00_TCM.pm)
« Antwort #8 am: 27 August 2014, 02:14:12 »
ich würde die Zeile 593 in 00_TCM.pm wie folgt ändern:

- Log3 undef, 1, TCM $name $err;
+ Log3 undef, 1, "TCM $name $err";

Gruss
flurin

Ich habe das geändert. Resultat:
Error messages while initializing FHEM:
configfile: Cannot load module TCM
Please define TCM310 first

Offline flurin

  • Sr. Member
  • ****
  • Beiträge: 609
Antw:Gelegentlich Fehler beim Start von FHEM (00_TCM.pm)
« Antwort #9 am: 27 August 2014, 05:06:56 »
Ich habe das geändert. Resultat:
Error messages while initializing FHEM:
configfile: Cannot load module TCM
Please define TCM310 first

... könntest Du bitte 00_TCM.pm hochladen ev als zip File. Ich kann dann Deine Version mit FileMerge vergleichen.
zusätzlich einen Log-Ausschnitt mit den Einträgen nach dem Start, also ab "Including fhem.cfg"
« Letzte Änderung: 27 August 2014, 06:24:14 von flurin »

Offline Arek

  • Full Member
  • ***
  • Beiträge: 112
Antw:Gelegentlich Fehler beim Start von FHEM (00_TCM.pm)
« Antwort #10 am: 06 September 2014, 21:10:18 »
Hi,

bin erst gestern wieder aus dem Urlaub zurückgekehrt...

Hier ist das Log zunächst mit einem Fehlgeschlagenem Start von Fhem und danach mit "service fhem start" erfolgreich gestartet:
2014.09.06 20:58:15 1: Including fhem.cfg
2014.09.06 20:58:15 3: telnetPort: port 7072 opened
2014.09.06 20:58:16 3: WEB: port 8083 opened
2014.09.06 20:58:16 3: WEBUser: port 8084 opened
2014.09.06 20:58:16 2: eventTypes: loaded 2055 events from ./log/eventTypes.txt
2014.09.06 20:58:16 1: HMLAN_Parse: HMUSB new condition disconnected
2014.09.06 20:58:16 3: Opening HMUSB device 127.0.0.1:1234
2014.09.06 20:58:16 3: HMUSB device opened
2014.09.06 20:58:16 1: HMLAN_Parse: HMUSB new condition init
2014.09.06 20:58:16 1: Including fhem.cfg
2014.09.06 20:58:16 1: telnetPort: Can't open server port at 7072: Address already in use. Exiting.
2014.09.06 20:58:16 3: Opening TCM310 device /dev/ttyUSB0
2014.09.06 20:58:16 3: Can't open /dev/ttyUSB0: Device or resource busy
2014.09.06 20:58:17 2: EnOcean Cryptographic functions are not available.
2014.09.06 20:58:19 3: FHEM2FHEM opening FritzBox at 192.168.178.001:7072
2014.09.06 20:58:19 3: FHEM2FHEM device opened (FritzBox)
2014.09.06 20:58:20 3: Opening VSX921 device 192.168.178.29:23
2014.09.06 20:58:20 3: VSX921 device opened
2014.09.06 20:58:32 3: PIONEERAVR VSX921: PIONEERAVR_statusUpdate()
2014.09.06 20:58:36 1: Including ./log/fhem.save
2014.09.06 20:58:36 3: data is {"deviceName": "global","changes":"state:INITIALIZED","type":"notify""source":"gcmsend_fhem","vibrate":"false"}
2014.09.06 20:58:37 2: TCM set TCM310 reset
2014.09.06 20:58:37 1: TCM TCM310 No FD
2014.09.06 20:58:37 2: TCM set TCM310 repeater 0000
2014.09.06 20:58:37 1: TCM TCM310 No FD
2014.09.06 20:58:37 2: TCM TCM310 repeater 0000 restored
2014.09.06 20:58:37 2: TCM set TCM310 mode 00
2014.09.06 20:58:37 1: TCM TCM310 No FD
2014.09.06 20:58:37 2: TCM set TCM310 maturity 01
2014.09.06 20:58:37 1: TCM TCM310 No FD
2014.09.06 20:58:37 2: TCM TCM310 maturity 01 restored
2014.09.06 20:58:37 2: TCM get TCM310 baseID

ab hier manueller Start:
2014.09.06 20:59:01 1: Including fhem.cfg
2014.09.06 20:59:01 3: telnetPort: port 7072 opened
2014.09.06 20:59:02 3: WEB: port 8083 opened
2014.09.06 20:59:02 3: WEBUser: port 8084 opened
2014.09.06 20:59:02 2: eventTypes: loaded 2055 events from ./log/eventTypes.txt
2014.09.06 20:59:02 1: HMLAN_Parse: HMUSB new condition disconnected
2014.09.06 20:59:02 3: Opening HMUSB device 127.0.0.1:1234
2014.09.06 20:59:02 3: HMUSB device opened
2014.09.06 20:59:02 1: HMLAN_Parse: HMUSB new condition init
2014.09.06 20:59:02 3: Opening TCM310 device /dev/ttyUSB0
2014.09.06 20:59:02 3: Setting TCM310 baudrate to 57600
2014.09.06 20:59:02 3: TCM310 device opened
2014.09.06 20:59:03 2: EnOcean Cryptographic functions are not available.
2014.09.06 20:59:06 3: FHEM2FHEM opening FritzBox at 192.168.178.001:7072
2014.09.06 20:59:06 3: FHEM2FHEM device opened (FritzBox)
2014.09.06 20:59:06 3: Opening VSX921 device 192.168.178.29:23
2014.09.06 20:59:06 3: VSX921 device opened
2014.09.06 20:59:19 3: PIONEERAVR VSX921: PIONEERAVR_statusUpdate()
2014.09.06 20:59:22 1: Including ./log/fhem.save
2014.09.06 20:59:23 3: data is {"deviceName": "global","changes":"state:INITIALIZED","type":"notify""source":"gcmsend_fhem","vibrate":"false"}
2014.09.06 20:59:26 2: TCM set TCM310 reset
2014.09.06 20:59:26 2: TCM TCM310 RESPONSE: OK
2014.09.06 20:59:26 2: TCM set TCM310 repeater 0000
2014.09.06 20:59:26 2: TCM TCM310 RESPONSE: OK
2014.09.06 20:59:26 3: data is {"deviceName": "TCM310","changes":"repeater:RepEnable: 00 RepLevel: 00","type":"notify""source":"gcmsend_fhem","vibrate":"false"}
2014.09.06 20:59:26 2: TCM TCM310 repeater 0000 restored
2014.09.06 20:59:26 2: TCM set TCM310 mode 00
2014.09.06 20:59:26 2: TCM TCM310 RESPONSE: NOT_SUPPORTED
2014.09.06 20:59:26 2: TCM set TCM310 maturity 01
2014.09.06 20:59:26 2: TCM TCM310 RESPONSE: OK
2014.09.06 20:59:26 3: data is {"deviceName": "TCM310","changes":"maturity:01","type":"notify""source":"gcmsend_fhem","vibrate":"false"}
2014.09.06 20:59:27 2: TCM TCM310 maturity 01 restored
2014.09.06 20:59:27 2: TCM get TCM310 baseID
2014.09.06 20:59:27 2: TCM TCM310 RESPONSE: BaseID: FFEEEC00 RemainingWriteCycles: 0A
2014.09.06 20:59:27 3: data is {"deviceName": "TCM310","changes":"baseID:BaseID: FFEEEC00 RemainingWriteCycles: 0A","type":"notify""source":"gcmsend_fhem","vibrate":"false"}
2014.09.06 20:59:27 3: data is {"deviceName": "TCM310","changes":"state:initialized","type":"notify""source":"gcmsend_fhem","vibrate":"false"}
2014.09.06 20:59:27 2: TCM TCM310 initialized
2014.09.06 20:59:27 0: Server started with 225 defined entities (version $Id: fhem.pl 6498 2014-09-01 19:24:40Z rudolfkoenig $, os linux, user root, pid 2431)
2014.09.06 20:59:27 3: telnetForBlockingFn: port 59659 opened

Es scheint ein Problem mit dem USB-Port zu sein? Aber auch wenn der TCM310 nicht erreichbar oder nicht angeschlossen ist, sollte doch FHEM trotzdem starten, oder?

Gruß Arek

Offline klaus.schauer

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1234
Antw:Gelegentlich Fehler beim Start von FHEM (00_TCM.pm)
« Antwort #11 am: 07 September 2014, 08:27:35 »
Ab 08.09.2014 steht ein geändertes Modul 00_TCM per update zur Verfügung.

 

decade-submarginal