Autor Thema: HM-CC-TC und sysTime  (Gelesen 1362 mal)

Offline volschin

  • Hero Member
  • *****
  • Beiträge: 1581
HM-CC-TC und sysTime
« am: 28 Juni 2015, 13:51:13 »
Hallo Martin,
die Zeit auf meinen HM-CC-TC-Thermostaten ging etwas stärker falsch, auf einem sogar 20 min. Ich habe daher versucht ein sysTime zu senden, ohne dass dies irgendeine Wirkung gehabt hätte. Das Device stand aber zuserst auf "1 CMD pending" und dann auf "CMD's done". Ich vermute, dass die tägliche Zeitaktualisierung schon ein Weilchen nicht mehr funktioniert, ich habe nicht darauf geachtet.

Als ich die Batterien am Thermostat herausgenommen und wieder eingelegt habe, hat er sich die aktuelle Zeit ohne Probleme geholt.

Hast Du eine Idee?

Gruß
Veit
Intel NUC+Ubuntu 20.04+Docker+FHEM6
HomeMatic: HM-MOD-RPI-PCB+HM-USB-CFG2+hmland+diverse, HUE: Hue-Bridge, RaspBee+deCONZ+diverse
Amzn Dash-Buttons, Siro Rollos
4xRPi, 4xCO20, OWL+USB, HarmonyHub, FRITZ!Box 7590, Echo Dots+Show5, Logi Circle 2, HomeBridge
TIG Stack (Telegraf, InfluxDB, Grafana)

Offline martinp876

  • Moderator
  • Hero Member
  • ***
  • Beiträge: 10782
Antw:HM-CC-TC und sysTime
« Antwort #1 am: 28 Juni 2015, 17:09:34 »
du kannst mit time-request nachsehen, wann der letzte timestamp geholt wurde. Sollte einmal an Tag stattfinde

Offline volschin

  • Hero Member
  • *****
  • Beiträge: 1581
Antw:HM-CC-TC und sysTime
« Antwort #2 am: 28 Juni 2015, 17:22:53 »
Mmhh, bei mir war das im Log der 16.9.2014. das muss mir jetzt irgendwie zu denken geben.  :o

PS: Klassischer Denkfehler bei
event-on-change-reading .*
Es wird ja immer "-" geloggt und damit kein Event getriggert.

Im reading steht für die beiden, bei denen ich nicht die Batterien rausgenommen hatte heute 0:01 Uhr. Bei den beiden anderen die Uhrzeit des Batteriewechsels.

Bleibt die Frage, wie es zu den gravierend unterschiedlichen Zeiten (Fehler zwischen 4 und 20 Minuten) bei korrekter Zeit auf dem Raspi kommen kann?  :(
« Letzte Änderung: 28 Juni 2015, 18:25:16 von volschin »
Intel NUC+Ubuntu 20.04+Docker+FHEM6
HomeMatic: HM-MOD-RPI-PCB+HM-USB-CFG2+hmland+diverse, HUE: Hue-Bridge, RaspBee+deCONZ+diverse
Amzn Dash-Buttons, Siro Rollos
4xRPi, 4xCO20, OWL+USB, HarmonyHub, FRITZ!Box 7590, Echo Dots+Show5, Logi Circle 2, HomeBridge
TIG Stack (Telegraf, InfluxDB, Grafana)

Offline stromer-12

  • Hero Member
  • *****
  • Beiträge: 1364
Antw:HM-CC-TC und sysTime
« Antwort #3 am: 28 Juni 2015, 19:52:17 »
Ging die Uhr auf den Thermostaten vor oder nach?  Es könnte zu Verzögerungen bei der Übertragung gekommen sein. (Vermutung meinerseits)
FHEM 5.9(SVN) auf cubietruck mit HMUSB
FHEM 5.9(SVN) auf RPi1B mit HMser | CUNO
FHEM 5.9(SVN) virtuell mit HMLAN | CUL

Offline volschin

  • Hero Member
  • *****
  • Beiträge: 1581
Antw:HM-CC-TC und sysTime
« Antwort #4 am: 28 Juni 2015, 20:41:54 »
Die Zeit ging in allen Fällen nach. Passt also zu seiner Vermutung.
Intel NUC+Ubuntu 20.04+Docker+FHEM6
HomeMatic: HM-MOD-RPI-PCB+HM-USB-CFG2+hmland+diverse, HUE: Hue-Bridge, RaspBee+deCONZ+diverse
Amzn Dash-Buttons, Siro Rollos
4xRPi, 4xCO20, OWL+USB, HarmonyHub, FRITZ!Box 7590, Echo Dots+Show5, Logi Circle 2, HomeBridge
TIG Stack (Telegraf, InfluxDB, Grafana)

Offline volschin

  • Hero Member
  • *****
  • Beiträge: 1581
Antw:HM-CC-TC und sysTime
« Antwort #5 am: 29 Juni 2015, 07:35:47 »
Heute sind die Zeiten wieder korrekt. Ich würde dazu tendieren, es auf die Overload/statusrequest-Probleme zu schieben, die Martin gerade fixt/gefixt hat. Ich werde es weiter beobachten. Was mich trotzdem irritiert ist, dass bei sysTime nichts passiert.
Intel NUC+Ubuntu 20.04+Docker+FHEM6
HomeMatic: HM-MOD-RPI-PCB+HM-USB-CFG2+hmland+diverse, HUE: Hue-Bridge, RaspBee+deCONZ+diverse
Amzn Dash-Buttons, Siro Rollos
4xRPi, 4xCO20, OWL+USB, HarmonyHub, FRITZ!Box 7590, Echo Dots+Show5, Logi Circle 2, HomeBridge
TIG Stack (Telegraf, InfluxDB, Grafana)

 

decade-submarginal