Autor Thema: OSX 10.10.4 - shutdown restart funktioniert nicht  (Gelesen 1906 mal)

Offline hive2015

  • Jr. Member
  • **
  • Beiträge: 57
OSX 10.10.4 - shutdown restart funktioniert nicht
« am: 27 Juli 2015, 19:21:32 »
Hi,

hatte die ganze Zeit fhem in einer Ubuntu VM auf meinem Mac mini laufen gehabt, wollte aber aus verschiedenen Gründen fhem direkt unter OSX zum laufen bringen. Das funktioniert soweit auch prima, nur habe ich das Problem, das ich kein "shutdown restart" benutzen kann. Wenn ich das mache, stoppt Fhem nur, startet aber nie wieder. Im Log ist hierzu folgendes zu finden:

2015.07.27 19:10:44 0: Server shutdown
2015.07.27 19:10:45 1: CallBlockingFn: Can't connect to localhost:7072: IO::Socket::INET: connect: Connection refused
Can't use an undefined value as a symbol reference at FHEM/Blocking.pm line 125

Hat jemand von  euch eine Idee? Das "nackte" Fhem konnte es seltsamerweise noch, aber seit ich da meine komplett cfg übernommen habe, geht es nicht mehr.

Gruss,
Hive


Offline herrmannj

  • Global Moderator
  • Hero Member
  • ****
  • Beiträge: 4662
Antw:OSX 10.10.4 - shutdown restart funktioniert nicht
« Antwort #1 am: 27 Juli 2015, 19:35:36 »
Hi,

hast Du fronthem am laufen ?

vg
joerg
smartVisu mit fronthem, einiges an HM, RFXTRX, Oregon, CUL, Homeeasy, ganz viele LED + Diverse

Offline hive2015

  • Jr. Member
  • **
  • Beiträge: 57
Antw:OSX 10.10.4 - shutdown restart funktioniert nicht
« Antwort #2 am: 27 Juli 2015, 20:26:37 »
Hi,

nein, das habe ich nicht. Ich habe "Tablet-UI" laufen, aber das nutzt m.E. Fronthem nicht.

Gruss,
Hive

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 19006
Antw:OSX 10.10.4 - shutdown restart funktioniert nicht
« Antwort #3 am: 09 August 2015, 16:40:45 »
Vermutlich ist einer der exotischeren Module schuld an das Problem, und man muesste sie eins nach dem anderen deaktivieren.

Offline hive2015

  • Jr. Member
  • **
  • Beiträge: 57
Antw:OSX 10.10.4 - shutdown restart funktioniert nicht
« Antwort #4 am: 19 August 2015, 20:58:08 »
hatte mir den tip zu herzen genommen, insbesondere da ich in der zwischenzeit sogar das problem bei rereadcfg oder speichern von edit config hatte... und welches modul wars? das PRESENCE modul. hatte von 7 devices den status checken lassen, das mochte es wohl nicht.

shutdown restart geht zwar immernoch nicht, aber damit kann ich leben, aber wenigstens geht rereadcfg wieder

 

decade-submarginal