Autor Thema: [solved] Neues Kernel 3.18.3+ GPIO active_low geht nicht mehr  (Gelesen 1995 mal)

1wire

  • Gast
Hallo,

falls jemand genauso wie ich seit über 6 Stunden im Internet nach einer Lösung sucht (oder vielleicht vieeeeel früher hier landet) schreibe ich mal meine Lösung die ich gerade erfolgreich umgesetzt habe auf.

Problem:
Nach einem neuen Raspi-Image haben unter FHEM meine China Relais invertiert geschaltet. Dafür gibts ja eigentlich active_low. ABER genau das hat nicht mehr funktioniert.
sudo adduser fhem gpio
ist gemacht, war aber nicht alles, was fehlte.

Grund:
Ab dem neuen Kernel 3.18.3+ ist das /sys/devices/virtual/gpio
Umgezogen nach /sys/class/gpio/gpioXX
und wird verlinkt nach ../devices/soc/platform/soc/20200000.gpio/gpio/gpioXX

Lösung:
Neue Datei erstellen in
  sudo nano /lib/udev/rules.d/10-gpio.rulesin diese 2 Zeilen einfügen:
   KERNEL=="spidev*", GROUP="spi", MODE="0660"und
   SUBSYSTEM=="gpio*", PROGRAM="/bin/sh -c 'chown -R root:gpio /sys/class/gpio && chmod -R 770 /sys/class/gpio; chown -R root:gpio /sys/devices/virtual/gpio && chmod -R 770 /sys/devices/virtual/gpio; chown -R root:gpio /sys/devices/platform/soc/*.gpio/gpio && chmod -R 770 /sys/devices/platform/soc/*.gpio/gpio'"
SUBSYSTEM=="gpio*", PROGRAM…… usw. muss alles in eine Zeile
Also insgesamt sind es dann nur 2 Zeilen.
sudo reboot
Das ist meine Lösung, es gibt im Internet sehr viele *.rules Varianten, aber diese hat bei mir mit meinem neuen FHEM-System sofort funktioniert.

Wenn dann in FHEM active_low gesetzt wurde, sieht mein Verzeichnis so aus.
(http://forum.fhem.de/index.php?action=dlattach;topic=41214.0;attach=37384;image)
Hoffe das funktioniert auch bei euch.

Grüße 1wire
« Letzte Änderung: 18 September 2015, 22:07:34 von 1wire »

gui2180

  • Gast
Antw:[solved] Neues Kernel 3.18.3+ GPIO active_low geht nicht mehr
« Antwort #1 am: 20 September 2015, 22:09:18 »
 ;D Tausend Dank. Funktioniert perfekt. Hatte eigentlich schon aufgegeben ...

1wire

  • Gast
Antw:[solved] Neues Kernel 3.18.3+ GPIO active_low geht nicht mehr
« Antwort #2 am: 21 September 2015, 09:10:46 »
Hallo gui2180,

schön das dir mein Beitrag geholfen hat, somit hat sich der Aufwand alles aufzuschreiben schon gelohnt. Es ist ein tolles Gefühl wenn man dem Forum auch mal was zurück geben kann und anderen damit hilft.

Danke dir für deine Rückmeldung.

VG
1wire

Offline Thorsten15

  • New Member
  • *
  • Beiträge: 11
Antw:[solved] Neues Kernel 3.18.3+ GPIO active_low geht nicht mehr
« Antwort #3 am: 22 Oktober 2015, 20:24:55 »
Danke 1wire,
mit deiner Anleitung konnte ich das Problem schnell beheben.

Gruß,
Thorsten

Offline cremofix

  • New Member
  • *
  • Beiträge: 25
Antw:[solved] Neues Kernel 3.18.3+ GPIO active_low geht nicht mehr
« Antwort #4 am: 29 Oktober 2015, 17:17:05 »
Super Tip,

hätte ich eher lesen müssen  :)
habe heute jessie aufgespielt. Dadurch funktioniert es auch wieder, war aber definitiv mehr Aufwand

Offline bismosa

  • Developer
  • Full Member
  • ****
  • Beiträge: 307
Antw:[solved] Neues Kernel 3.18.3+ GPIO active_low geht nicht mehr
« Antwort #5 am: 16 August 2017, 21:11:20 »
Hallo,

auch von mir ein Danke! Ich habe jetzt auch ewig gesucht...
Wäre das nicht etwas fürs Wiki? Und ggf. einen Hinweis in der Commandref wert?

Danke!

Gruß
Bismosa
FHEM 14873 auf einem Raspberry PI 2 (B) Wheezy
1x nanoCUL 433MHz (SlowRF Intertechno) für Fenstersensoren
1x nanoCUL 868Mhz für MAX (9x HT 1xWT)
1x 433MHz Sender an ESP (Jarolift Rolläden)
Weiteres: Squeezebox server, Kindle Display, ESP8266, Löterfahrung, ...

Offline klausw

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1881
Antw:[solved] Neues Kernel 3.18.3+ GPIO active_low geht nicht mehr
« Antwort #6 am: 24 August 2017, 18:03:48 »
auch von mir ein Danke! Ich habe jetzt auch ewig gesucht...
Wäre das nicht etwas fürs Wiki? Und ggf. einen Hinweis in der Commandref wert?

Die Wiki kann/darf jeder gern erweitern.
In der Commandref ist der Ansatz mit über die /etc/rc.local beschrieben, der zum gleichen Ergebnis führt.

Allerdings gilt nach wie vor:
auf einem frischen jungfräulichen Image für das Raspberry Pi sollte das nicht notwendig sein (nur nach einem Kernelupdate kann es Probleme geben )
nach:sudo adduser fhem gpio
sudo reboot
müsste der User fhem Zugriff auf die GPIOs haben.
RasPi B v2 mit FHEM 18B20 über 1Wire, LED PWM Treiber über I2C, Luchtdruck-, Feuchtesensor und ein paar Schalter/LED\'s zum testen
Module: RPI_GPIO, RPII2C, I2C_EEPROM, I2C_MCP23008, I2C_MCP23017, I2C_MCP342x, I2C_PCA9532, I2C_PCF8574, I2C_SHT21, I2C_BME280

 

decade-submarginal