Autor Thema: Alexa Problem bei KNX Komponenten seit Update  (Gelesen 243 mal)

Offline SeppiDeluxe

  • New Member
  • *
  • Beiträge: 8
Alexa Problem bei KNX Komponenten seit Update
« am: 13 Juni 2018, 15:47:34 »
Hi,

seit dem letzten Update, unter anderem KNX, lassen sich keine KNX Komponenten mehr in meiner Konfiguration durch Alexa ansteuern.

Das Alexa Debugging ergibt die folgenden Hinweise:

Jun 13 15:30:19 raspberrypi alexa[548]: [2018-6-13 15:30:19] [FHEM] Deckenleuchte sending command undefined with value 1
Jun 13 15:30:19 raspberrypi alexa[548]: **** Error: {}
Jun 13 15:30:19 raspberrypi alexa[548]: response :null

Ich beginne in diesem Unterforum, da sonst die anderen nicht-KNX Komponenten ihren Dienst wie erwartet tun. Habt ihr schon ähnliche Erfahrungen bzw. lässt es sich nachstellen?

Danke für Hinweise
Sebastian


Offline SeppiDeluxe

  • New Member
  • *
  • Beiträge: 8
Antw:Alexa Problem bei KNX Komponenten seit Update
« Antwort #1 am: 13 Juni 2018, 16:22:07 »
Der Workaround ist hier beschrieben.

@Andy291 kannst du erklären welche Änderungen dazu geführt haben, das die wesentlichen Eigenschaften wie z.B. on/off der KNX Devices verloren gegangen sind. Hast du ein bessere Idee als den WA mit den Mappings durchzuführen?

Danke Sebastian

Offline Andi291

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1088
Antw:Alexa Problem bei KNX Komponenten seit Update
« Antwort #2 am: 13 Juni 2018, 17:31:49 »
Moin!

Ja, an der Schnittstelle hat sich einiges geändert. Ich habe jedoch mit ganz wenigen Ausnahmen den alten Ballast mitgeführt, um die Devices rückwärtskompatibel zu halten.
Nur zum Verständnis: keine wesentliche Eigenschaft eines Devices ist verloren gegangen, im Gegenteil. Fälschlicherweise wurden bisher immer bei allen GAD on/off angeboten, unabhängig welcher DPT angezogen war.
Auch wurden, im Gegensatz zu anderen Devices, immer Schlüsselworte wie "value" gebraucht.
Das ist nun anders...
Das alles wirkt aus meiner Sicht primär auf die Drop-Down-Boxen bei SET/GET in der Detailansicht der Geräte sowie anteilig aufs Webfrontend aus. Die Schnittstelle zu Alexa kenne ich nicht.

Jetzt zu Deinem Problem:
Wie gesagt kenne ich mich mit Alexa 0 aus, kann also mit Deinen Ausgaben wenig anfangen...

1. Welche Version nutzt Du? Aktuell ist die 16858. In der 16817 waren noch Probleme bei den DPT1 vorhanden...
2. Bitte poste ein Listing eines Deiner KNX-Devices.
3. Bitte poste ein Level-5-Log eines NIO-Sprachkommandos.

Grüße, Andi