Autor Thema: Devstate icon vom HUEDevice wird schwarz wenn die Lampe leuchtet  (Gelesen 323 mal)

Offline maddinthebrain

  • Full Member
  • ***
  • Beiträge: 215
Hallo,

Ich habe mehrere Zigbee Schalter über ein ConBee Gateway als HUEDevice eingebunden. Diese HUEDevices haben jeweils {(HUEDevice_devStateIcon($name),"toggle") in den Attributen stehen. Das soll ja ja die Licht Farbe  zeigen. Das macht halt bei einem Relais wenig Sinn. So wird auch das Glühlampensymbol nicht von 0% weiß zu 100% weiß sondern 100% schwarz. Das ist nun nicht gerade toll. Wie bekomme ich das weiß oder Orange wie andere Schalter die nicht als HUEDevice eingebunden sind? Dieses erwähnte Attribut lässt weder ändern noch löschen. Wenn man es versucht taucht sofort im der ursprünglichen Form wieder auf.

Grüße Martin
« Letzte Änderung: 28 Januar 2019, 10:20:24 von maddinthebrain »
Viele Grüße

Martin

3x RP3 mit Raspian stretch, FHEM5.9, Signalduino 433MHz, Signalduino 868MHz, MAX!, HM_RPI_PCB, Homematic-Aktoren, Mysensors Ethernet Gateway und Mysensors Sensoren & Aktoren, CumulusMX, FHEM2FHEM, ConBee mit deCONZ und Phoscon für ZigBee Aktoren und Sensoren

Offline Paul

  • Sr. Member
  • ****
  • Beiträge: 919
Antw:Devstate icon vom HUEDevice wird schwarz wenn die Lampe leuchtet
« Antwort #1 am: 28 Januar 2019, 16:09:33 »
Indem du das devStateIcon veränderst.

Z.B.

on:FS20.on@orange:off off:FS20.off@green:one
Cubietruck, HM-USB, CUL, FS20, FHT, HUE, Keymatic

Offline maddinthebrain

  • Full Member
  • ***
  • Beiträge: 215
Antw:Devstate icon vom HUEDevice wird schwarz wenn die Lampe leuchtet
« Antwort #2 am: 28 Januar 2019, 22:43:24 »
Ja, das ist ja genau das Problem! Das Attribut devStateIcon das ich erwähnt habe, lässt nicht ändern. Wie gesagt, wenn ich es lösche oder ändere, ist es 2 Sekunden später wie vorher. Das ist so einfach Mist! Aber das ist offensichtlich aber so gewollt, denn in der Hilfe zum HUEDevice steht auch, dass devStateIcon diese Definition hat.

Grüße Martin

Siehe das Listing:
CHANGED   
   DEF        1  IODev=deCONZ
   ID         1
   INTERVAL   
   IODev      deCONZ
   NAME       Vitrinenlicht_WZ
   NR         185
   STATE      off
   TYPE       HUEDevice
   desired    1
   manufacturername SZ
   modelid    Lamp_01
   name       Vitrine
   type       On/Off light
   uniqueid   bleibt privat
   Helper:
     DBLOG:
       alert:
         logmysql:
           TIME       1548584373.05049
           VALUE      none
       onoff:
         logmysql:
           TIME       1548659329.37985
           VALUE      0
       pct:
         logmysql:
           TIME       1548659329.37985
           VALUE      0
       reachable:
         logmysql:
           TIME       1548595062.92154
           VALUE      1
       state:
         logmysql:
           TIME       1548659329.37985
           VALUE      off
   READINGS:
     2019-01-27 11:19:33   alert           none
     2019-01-28 08:08:49   onoff           0
     2019-01-28 08:08:49   pct             0
     2019-01-27 14:17:42   reachable       1
     2019-01-28 08:08:49   state           off
   helper:
     alert      none
     bri        -1
     colormode 
     ct         -1
     devtype   
     effect     
     hue        -1
     on         0
     pct        0
     reachable  1
     rgb       
     sat        -1
     update_timeout 1
     xy         
Attributes:
   IODev      deCONZ
   color-icons 2
   devStateIcon {(HUEDevice_devStateIcon($name),"toggle")}
   model      Lamp_01
   room       Wohnzimmer
   subType    switch
   webCmd     toggle:on:off
Viele Grüße

Martin

3x RP3 mit Raspian stretch, FHEM5.9, Signalduino 433MHz, Signalduino 868MHz, MAX!, HM_RPI_PCB, Homematic-Aktoren, Mysensors Ethernet Gateway und Mysensors Sensoren & Aktoren, CumulusMX, FHEM2FHEM, ConBee mit deCONZ und Phoscon für ZigBee Aktoren und Sensoren

Offline Paul

  • Sr. Member
  • ****
  • Beiträge: 919
Antw:Devstate icon vom HUEDevice wird schwarz wenn die Lampe leuchtet
« Antwort #3 am: 28 Januar 2019, 23:29:38 »
Bei mir klappt es

CHANGED   
   DEF        14  IODev=HUE
   FUUID      5c42d7cc-f33f-7531-25a3-869a91ce18fc1d7f
   ID         14
   INTERVAL   
   IODev      HUE
   NAME       FlurKeller1
   NR         443
   STATE      off
   TYPE       HUEDevice
   desired    0
   manufacturername IKEA of Sweden
   modelid    TRADFRI bulb GU10 W 400lm
   name       FlurKeller1
   swversion  1.2.214
   type       Dimmable light
   uniqueid   90:fd:9f:ff:fe:11:31:26-01
   READINGS:
     2019-01-28 13:37:03   alert           none
     2019-01-28 23:22:36   bri             254
     2019-01-28 23:27:24   onoff           0
     2019-01-28 23:27:24   pct             0
     2019-01-28 13:37:03   reachable       1
     2019-01-28 23:27:24   state           off
   helper:
     alert      none
     bri        254
     colormode 
     ct         -1
     devtype   
     effect     
     hue        -1
     on         0
     pct        0
     reachable  1
     rgb       
     sat        -1
     update_timeout -1
     xy         
Attributes:
   IODev      HUE
   alias      FlurKeller1
   color-icons 2
   devStateIcon on:FS20.on@orange:off off:FS20.off@green:on
   model      TRADFRI bulb GU10 W 400lm
   room       HUEDevice
   subType    dimmer
   webCmd     pct:toggle:on:off
Cubietruck, HM-USB, CUL, FS20, FHT, HUE, Keymatic

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 18644
Antw:Devstate icon vom HUEDevice wird schwarz wenn die Lampe leuchtet
« Antwort #4 am: 29 Januar 2019, 08:06:36 »
natürlich kann man devStateIcon ändern. wenn das nicht so wäre bitte melden. das ist ein bug.

ansonsten: für die ein und aus zustände eines schalters kommt dir farbe nicht aus dem hue modul sondern wird vom style bestimmt den du verwendest.

welcher ist das?
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline maddinthebrain

  • Full Member
  • ***
  • Beiträge: 215
Antw:Devstate icon vom HUEDevice wird schwarz wenn die Lampe leuchtet
« Antwort #5 am: 29 Januar 2019, 14:46:11 »
@justme1968: Das ist der "dark" Style. Was anderes reinschreiben geht. Das ursprünglichen löschen geht nicht.
@ Paul: Das funktioniert so erst mal. Ist vielleicht nicht so, wie sich das der Autor mal gedacht hat. Evtl. ist da ein Punkt im "dark" Style nicht richtig bedacht worden.

Grüße Martin
Viele Grüße

Martin

3x RP3 mit Raspian stretch, FHEM5.9, Signalduino 433MHz, Signalduino 868MHz, MAX!, HM_RPI_PCB, Homematic-Aktoren, Mysensors Ethernet Gateway und Mysensors Sensoren & Aktoren, CumulusMX, FHEM2FHEM, ConBee mit deCONZ und Phoscon für ZigBee Aktoren und Sensoren

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 18644
Devstate icon vom HUEDevice wird schwarz wenn die Lampe leuchtet
« Antwort #6 am: 29 Januar 2019, 16:57:42 »
ich kann das problem nicht reporduzieren. ich verwende auch den dark style und das icon schaut bei mir so aus wenn die lampe an ist.

und die färbe kommt direkt aus dem fhemweb style.

irgendetwas ist also komisch bei dir.

was bekommst du wenn du {HUEDevice_devStateIcon('Vitrinenlicht_WZ')} in der command box eingibst?
« Letzte Änderung: 30 Januar 2019, 10:21:20 von justme1968 »
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline maddinthebrain

  • Full Member
  • ***
  • Beiträge: 215
Antw:Devstate icon vom HUEDevice wird schwarz wenn die Lampe leuchtet
« Antwort #7 am: 30 Januar 2019, 10:10:58 »
Hier kommt

syntax error at (eval 2475836) line 1, at EOF
Sicher dass das so richtig war?
Viele Grüße

Martin

3x RP3 mit Raspian stretch, FHEM5.9, Signalduino 433MHz, Signalduino 868MHz, MAX!, HM_RPI_PCB, Homematic-Aktoren, Mysensors Ethernet Gateway und Mysensors Sensoren & Aktoren, CumulusMX, FHEM2FHEM, ConBee mit deCONZ und Phoscon für ZigBee Aktoren und Sensoren

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 18644
Antw:Devstate icon vom HUEDevice wird schwarz wenn die Lampe leuchtet
« Antwort #8 am: 30 Januar 2019, 10:21:32 »
sorry. da war eine klammer zu viel
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline maddinthebrain

  • Full Member
  • ***
  • Beiträge: 215
Antw:Devstate icon vom HUEDevice wird schwarz wenn die Lampe leuchtet
« Antwort #9 am: 30 Januar 2019, 13:56:26 »
Da hätte ich ja selber drauf kommen können...  :-\

Ergebnis wenn die Lampe ein ist:
.*:on@#000000:toggle

Bei aus:.
*:off:toggle

Ich gehe mal davon, dass #000000 das Problem ist. Nur wo kommt das her.
Viele Grüße

Martin

3x RP3 mit Raspian stretch, FHEM5.9, Signalduino 433MHz, Signalduino 868MHz, MAX!, HM_RPI_PCB, Homematic-Aktoren, Mysensors Ethernet Gateway und Mysensors Sensoren & Aktoren, CumulusMX, FHEM2FHEM, ConBee mit deCONZ und Phoscon für ZigBee Aktoren und Sensoren

Offline tomster

  • Sr. Member
  • ****
  • Beiträge: 893
Antw:Devstate icon vom HUEDevice wird schwarz wenn die Lampe leuchtet
« Antwort #10 am: 30 Januar 2019, 14:05:06 »
Ich kann das Problem nachstellen. Habe über einen ConBee-Stick eine Osram Steckdose eingebunden und verwende ebenfalls den "dark" style. Anstatt in orange leuchtet das Lampensymbol in schwarz.
« Letzte Änderung: 30 Januar 2019, 14:14:12 von tomster »

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 18644
Antw:Devstate icon vom HUEDevice wird schwarz wenn die Lampe leuchtet
« Antwort #11 am: 30 Januar 2019, 14:11:47 »
ja. das #000000 ist das problem. das sollte da nicht sein.

ich muss schauen warum es bei euch eingefügt wird.
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 18644
Antw:Devstate icon vom HUEDevice wird schwarz wenn die Lampe leuchtet
« Antwort #12 am: 30 Januar 2019, 14:34:38 »
ich denke ich habe es behoben. ab morgen im update.
FHEM5.4,DS1512+,2xCULv3,DS9490R,HMLAN,2xRasPi
CUL_HM:HM-LC-Bl1PBU-FM,HM-LC-Sw1PBU-FM,HM-SEC-MDIR,HM-SEC-RHS
HUEBridge,HUEDevice:LCT001,LLC001,LLC006,LWL001
OWDevice:DS1420,DS18B20,DS2406,DS2423
FS20:fs20as4,fs20bs,fs20di
AKCP:THS01,WS15
CUL_WS:S300TH
Gefällt mir Gefällt mir x 2 Liste anzeigen