Autor Thema: Neues Modul: Signalbot (Integration für den Signal Messenger) via signal-cli  (Gelesen 72178 mal)

Offline Gisbert

  • Hero Member
  • *****
  • Beiträge: 2564
  • Das Ziel ist das Ziel !
Hallo Jörg,

ich hab Debian 11 und Signal läuft bei mir, auch das gestrige Update. Wenn du sagst wo, was und wie ich nachschauen soll, dann mach ich das gerne.

Viele​ Grüße​ Gisbert​
Aktuelles FHEM | HP ThinClient T610 | Debian11 | UniFi-Controller, AP, USG-3 | Homematic, VCCU, HMUART | ESP8266, Eigenbau | Gas-, Wasser-, Stromzähler | Sonoff | 1-Wire-Temperatursensoren | Wlan-Kamera | SIGNALduino, Flamingo Rauchmelder FA21/22RF |  Heizungssteuerung komplett in FHEM

Offline Adimarantis

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 699
ich hab Debian 11 und Signal läuft bei mir, auch das gestrige Update. Wenn du sagst wo, was und wie ich nachschauen soll, dann mach ich das gerne.
Debian 11 auf Intel Architektur geht (das ist sogar die Standard Version die bei signal-cli dabei ist) - das Problem von Volker ist Raspian "Bullseye" (abgeleitet von Debian 11) auf dem Raspberry mit ARM Architektur.

Aber Danke für das Angebot.
Raspberry 4 + HM-MOD-RPI-PCB (pivCCU) + RfxTrx433XL + 2xRaspberry 1
Module: 50_Signalbot, 52_I2C_ADS1x1x , 58_RPI_1Wire, (50_SPI_MAX31865)

Online Jamo

  • Hero Member
  • *****
  • Beiträge: 1589
Update signal-cli 0.9.2

...
@Jamo: Ich denke ich habe den richtigen Branch dafür gefunden um die Debian 10 libs zu übersetzen, hab diese aber nicht getestet. Wäre schön wenn du das überprüfen könntest.

Jörg
Hallo Jörg,
ja Du hast den richtigen Branch für die Debian 10 libs gefunden, es funktioniert. DANKE! !  !
Intel NUC mit Linux Debian 10, Homematic (UART/HMUSB), Debmatic, HUEBridge, Zigbee, FB, Alexa (fhem-lazy), livetracking, LaCrosse JeeLink, fhemApp Frontend für FHEM

Offline vaulie

  • New Member
  • *
  • Beiträge: 11
Hallo Jörg,
danke für die Info. Im wiki klingt der Prozess zum Übersetzen der Libraries ganz einfach ;-) Daher habe ich es mal versucht, bin aber grandios gescheitert...
Rust hat noch geklappt, aber beim Clonen des Codes von github fingen die Probleme mit "Permission denied (publickey)" an. Muss man da zwingend ein Account anlegen? Naja, ich habe mir dann das zip-file runtergeladen und auf den Raspberry (entpackt) kopiert. Leider meldete dann das make zwischendurch ein paarmal "thread 'rustc' panicked at ...", "note: the compiler unexpectedly panicked. this is a bug." und endete mit
query stack during panic:
end of query stack
error: could not compile `cfg-if`
warning: build failed, waiting for other jobs to finish...
error: build failed
make: *** [Makefile:7: native_library] Fehler 101
Eine library wurde dann leider auch nicht erzeugt.

Habe dann fertige libraries gesucht und wohl auch gefunden, jedenfalls lief schließlich das install-script ohne Fehler durch, das Captcha ließ sich mit den Anweisungen in fhem besiegen und ich habe dann meine erste Nachricht auf meinem Handy empfangen :)

Den Rest probiere ich in den nächsten Tagen weiter - Danke und Gute Nacht für heute!

Offline Adimarantis

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 699
Das Übersetzen der libs kann manchmal problematisch sein.
Das Projekt setzt auf pre-releases des rust compilers und ich hatte das Problem auch schon mal, weil der Compiler für ARM kaputt war.
Außerdem muss man noch aufpassen, dass man nicht mehr die neusten Versionen übersetzen darf, sondern auf ältere Tags zurückgehen muss.

Wo hast du die übersetzten libs für ARM Bullseye gefunden? Sofern diese sicher funktionieren kann ich die in den Installer aufnehmen.

Um einen besseren Überblick über die verwendeten Linux Distros zu bekommen, habe ich eine neue Version 3.2 von Signalbot released, die in das interne reading "model" eben diese Info schreibt (z.B. Raspbian GNU/Linux 10 (buster) ).
Damit taucht das dann in https://fhem.de/stats/statistics.html auf.
Um das Reading nach dem update zu füllen ist ein "shutdown restart" nötig.
Um es zu senden ein "fheminfo send".
Um es dann regelmässig bei Updates zu senden, wäre "attr global sendStatistics onUpdate" zu setzen. Wäre schön wenn das jeder aktivieren könnte um einen besseren Überblick zu bekommen.
Jörg
Raspberry 4 + HM-MOD-RPI-PCB (pivCCU) + RfxTrx433XL + 2xRaspberry 1
Module: 50_Signalbot, 52_I2C_ADS1x1x , 58_RPI_1Wire, (50_SPI_MAX31865)

Offline Kohle77

  • Full Member
  • ***
  • Beiträge: 161
Hallo,
mal also Hinweis. Der Link https://svn.fhem.de/fhem/trunk/fhem/thirdparty/signal-cli-packages in diesem Text:
Zitat
Alternatively go to FHEM SVN thirdparty and download the matching Debian package
Install with e.g. sudo apt install ./signal-cli-dbus_0.9.0-1_buster_armhf.deb (./ is important to tell apt this is a file)
funktioniert nicht.

Gruß
Christian

Offline Kohle77

  • Full Member
  • ***
  • Beiträge: 161
Hallo,
ich have eine Rapi mitOperating System: Raspbian GNU/Linux 10 (buster)
            Kernel: Linux 5.10.63-v7+
      Architecture: armv71

Ich habe mit wget https://svn.fhem.de/fhem/trunk/fhem/contrib/signal/signal_install.sh das install script herunter geladen.
Mit chmod a+x signal_install das script ausführbar gemacht und mit den default Einstellungen gestartet.
Also mit sudo ./signal_install

Ja ich hatte ursprünglich mal SiSi am laufen.

Als Fehler bekomme ich:
This script will help you to install signal-cli as system dbus service
and prepare the use of the FHEM Signalbot module

Please verify that these settings are correct:
Signal-cli User:              signal-cli
Signal-cli Install directory: /opt
Signal config storage:        /var/lib/signal-cli
Signal version:               0.9.2
System library path:          /usr/lib
System architecture:          armhf
System GLIBC version:         2.28
This will update system packages, install or uninstall signal-cli

<----snipped---->

Start signal-cli service
Job for signal.service failed because a timeout was exceeded.
See "systemctl status signal.service" and "journalctl -xe" for details.
Checking installation via dbus-send command...Error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
unexpected reply

Sending a message via perl Protocol::DBus...Error getting reply

output von systemctl zeigt aber an das Signal wohl läuft:
pi@FHEM:~ $ systemctl status signal.service
? signal.service - Send secure messages to Signal clients
   Loaded: loaded (/etc/systemd/system/signal.service; enabled; vendor preset: enabled)
   Active: active (running) since Tue 2021-12-07 12:39:42 CET; 3min 18s ago
 Main PID: 13495 (java)
    Tasks: 15 (limit: 2059)
   CGroup: /system.slice/signal.service
           +-13495 java -Xms2m -classpath /opt/signal/lib/signal-cli-0.9.2.jar:/opt/signal/lib/lib.jar:/opt/signal/lib/bcprov-jdk15on-1.69.jar:/opt/signal/lib/argparse4j-0.9.0.jar:/opt/signal/lib/dbus-java-3.3.1.jar:/opt/signal/lib/slf4j

Dez 07 12:38:36 FHEM2021 systemd[1]: Starting Send secure messages to Signal clients...
Dez 07 12:39:42 FHEM2021 systemd[1]: Started Send secure messages to Signal clients.

Was muss ich den genau entfernen von der alten SiSi installation?

Gruß
Christian

Offline Adimarantis

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 699
Hi Christian,

Möglicherweise hat der Start von signal-cli einfach nur zu lange gedauert (und daher schlägt der Selbsttest fehl). Das hatten wir gerade auf Raspberrys teilweise schon.
Wenn du mit
ps -ef | grep signal-cliden entsprechenden Java Prozess findest, sollte eigentlich alles ok sein.
Du kannst auch den Test vom Script einfach mal manuell durchführen
dbus-send --system --type=method_call --print-reply --dest="org.asamk.Signal" /org/asamk/Signal org.asamk.Signal.versionWenn alles klappt sollte er die signal-cli version zurückliefern.

Dann sollte es unter FHEM eigentlich auch funktionieren.

Möglicherweise macht es doch Sinn den service timeout generell (auf einen Wert höher als der default) zu setzen.

Ein vorherige SiSi Installation sollte eigentlich nicht stören.

Jörg
Raspberry 4 + HM-MOD-RPI-PCB (pivCCU) + RfxTrx433XL + 2xRaspberry 1
Module: 50_Signalbot, 52_I2C_ADS1x1x , 58_RPI_1Wire, (50_SPI_MAX31865)

Offline Kohle77

  • Full Member
  • ***
  • Beiträge: 161
Hallo,
als erstes habe ich mal nach dem wicki https://wiki.fhem.de/wiki/Signalbot#Registrierung

sudo find / -name libzkgroup.so 2>/dev/null
sudo find / -name zkgroup-java-*.jar 2>/dev/null
sudo find / -name libsignal_jni.so 2>/dev/null
sudo find / -name signal-client-java-*.jar 2>/dev/null
gemacht und alle files die ich gefunden habe mit sudo rm /path/to/file/name diese gelöscht.

Danach das ./signal_install.sh ausgeführt.
Das device in FHEM angelegt und die nummer registriert.
Hab dann sogar nochmal cpan install -f Protocol::DBus gemacht

pi@FHEM2021:~ $ systemctl status signal.service
? signal.service - Send secure messages to Signal clients
   Loaded: loaded (/etc/systemd/system/signal.service; enabled; vendor preset: enabled)
   Active: active (running) since Tue 2021-12-07 14:25:54 CET; 26s ago
 Main PID: 3498 (java)
    Tasks: 32 (limit: 2059)
   CGroup: /system.slice/signal.service
           +-3498 java -Xms2m -classpath /opt/signal/lib/signal-cli-0.9.2.jar:/opt/signal/lib/lib.jar:/opt/signal/lib/bcprov-jdk15on-1.69.jar:/opt/signal/lib/argparse4j-0.9.0.jar:/opt/signal/lib/dbus-java-3.3.1.jar:/opt/signal/lib/slf4j-

Dez 07 14:25:04 FHEM2021 systemd[1]: Starting Send secure messages to Signal clients...
Dez 07 14:25:54 FHEM2021 signal-cli[3498]: INFO DaemonCommand - Exported dbus object: /org/asamk/Signal/_4960.......

auch der dbus scheint zu laufen
pi@FHEM2021:~ $ systemctl status dbus-org.asamk.Signal.service
? signal.service - Send secure messages to Signal clients
   Loaded: loaded (/etc/systemd/system/signal.service; enabled; vendor preset: enabled)
   Active: active (running) since Tue 2021-12-07 14:25:54 CET; 5min ago
 Main PID: 3498 (java)
    Tasks: 32 (limit: 2059)
   CGroup: /system.slice/signal.service
           +-3498 java -Xms2m -classpath /opt/signal/lib/signal-cli-0.9.2.jar:/opt/signal/lib/lib.jar:/opt/signal/lib/bcprov-jdk15on-1.69.jar:/opt/signal/lib/argparse4j-0.9.0.jar:/opt/signal/lib/dbus-java-3.3.1.jar:/opt/signal/lib/slf4j-

Dez 07 14:25:04 FHEM2021 systemd[1]: Starting Send secure messages to Signal clients...
Dez 07 14:25:54 FHEM2021 signal-cli[3498]: INFO DaemonCommand - Exported dbus object: /org/asamk/Signal/_4960.......

Das Ergebniss vom Test:
dbus-send --system --type=method_call --print-reply --dest="org.asamk.Signal" /org/asamk/Signal org.asamk.Signal.version
method return time=1638884204.249008 sender=:1.82 -> destination=:1.85 serial=6 reply_serial=2
   string "0.9.2"

Auch dieser Test läuft:
sudo ./signal_install.sh test
You chose the following option: test

Start signal-cli service
Checking installation via dbus-send command...success
Sending a message via perl Protocol::DBus...reply received

Versuche ich nun aus der FHEM GUI eine Nachricht zu schicken mit set SigBot send @+4916....... Das ist ein Test um 14:40Sehe ich in der GUI lastError
   
lastError Error in sendMessage:Message recipient disconnected from message bus without replyingNatürlich war Verbose auf 5 gesetzt und im log finde ich
2021.12.07 14:41:09 3: SigBot: Before parse:@+4916...... Das ist ein Test um 14:41:
2021.12.07 14:41:09 4: SigBot: sendMessage called for +4916.......::Das ist ein Test um 14:41
2021.12.07 14:41:09 5: SigBot: ASync Dbus Call: sendMessage Args:Das ist ein Test um 14:41,ARRAY(0x7efcf38),ARRAY(0x8d5f840)
2021.12.07 14:41:09 5: msgConfig globalMsg: called function msgConfig_Set()
2021.12.07 14:41:11 4: SigBot: ASync Error for: sendMessage

Offline Adimarantis

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 699
lastError Error in sendMessage:Message recipient disconnected from message bus without replying
Den Fehler hatte ich heute auch mit 0.9.2 direkt nach einem FHEM Restart - nach einem reinit gings dann wieder. Probier das mal.
Hab vorher noch nie gesehen.
Raspberry 4 + HM-MOD-RPI-PCB (pivCCU) + RfxTrx433XL + 2xRaspberry 1
Module: 50_Signalbot, 52_I2C_ADS1x1x , 58_RPI_1Wire, (50_SPI_MAX31865)

Offline Kohle77

  • Full Member
  • ***
  • Beiträge: 161
Hi,
ich habe mal einen reboot gemacht. Ergebnis:
sudo systemctl status signal.service
? signal.service - Send secure messages to Signal clients
   Loaded: loaded (/etc/systemd/system/signal.service; enabled; vendor preset: enabled)
   Active: failed (Result: signal) since Tue 2021-12-07 15:14:16 CET; 19s ago
  Process: 530 ExecStart=/opt/signal/bin/signal-cli --config /var/lib/signal-cli daemon --system (code=killed, signal=ABRT)
 Main PID: 530 (code=killed, signal=ABRT)

Dez 07 15:14:16 FHEM2021 signal-cli[530]: # No core dump will be written. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
Dez 07 15:14:16 FHEM2021 signal-cli[530]: #
Dez 07 15:14:16 FHEM2021 signal-cli[530]: # An error report file with more information is saved as:
Dez 07 15:14:16 FHEM2021 signal-cli[530]: # /tmp/hs_err_pid530.log
Dez 07 15:14:16 FHEM2021 signal-cli[530]: #
Dez 07 15:14:16 FHEM2021 signal-cli[530]: # If you would like to submit a bug report, please visit:
Dez 07 15:14:16 FHEM2021 signal-cli[530]: #   Unknown
Dez 07 15:14:16 FHEM2021 signal-cli[530]: #

Gruß
Christian

Offline Adimarantis

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 699
Hmm, was sagt denn
systemctl status signal.serviceund
journalctl -xe
Raspberry 4 + HM-MOD-RPI-PCB (pivCCU) + RfxTrx433XL + 2xRaspberry 1
Module: 50_Signalbot, 52_I2C_ADS1x1x , 58_RPI_1Wire, (50_SPI_MAX31865)

Offline Kohle77

  • Full Member
  • ***
  • Beiträge: 161
Hi,
hab signal mal gestartet mit
sudo systemctl start signal.servicedanach war der service active (running)

Jetzt in FHEM in der GUI ein reinit und alles sah ok aus.
Mit set SigBot ... versucht eine message zu schicken but Fehler:
lastError Error in sendMessage:Message recipient disconnected from message bus without replying
und der Dienst läuft danach nicht mehr.
systemctl status signal.service
? signal.service - Send secure messages to Signal clients
   Loaded: loaded (/etc/systemd/system/signal.service; enabled; vendor preset: enabled)
   Active: failed (Result: signal) since Tue 2021-12-07 15:40:19 CET; 4min 38s ago
  Process: 2042 ExecStart=/opt/signal/bin/signal-cli --config /var/lib/signal-cli daemon --system (code=killed, signal=ABRT)
 Main PID: 2042 (code=killed, signal=ABRT)

Dez 07 15:40:19 FHEM2021 signal-cli[2042]: # No core dump will be written. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: #
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: # An error report file with more information is saved as:
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: # /tmp/hs_err_pid2042.log
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: #
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: # If you would like to submit a bug report, please visit:
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: #   Unknown
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: #
Dez 07 15:40:19 FHEM2021 systemd[1]: signal.service: Main process exited, code=killed, status=6/ABRT
Dez 07 15:40:19 FHEM2021 systemd[1]: signal.service: Failed with result 'signal'.

und journalctl -xe
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: #
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: # A fatal error has been detected by the Java Runtime Environment:
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: #
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: #  SIGSEGV (0xb) at pc=0x7650136c, pid=2042, tid=2162
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: #
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: # JRE version: OpenJDK Runtime Environment (11.0.12+7) (build 11.0.12+7-post-Raspbian-2deb10u1)
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: # Java VM: OpenJDK Server VM (11.0.12+7-post-Raspbian-2deb10u1, mixed mode, serial gc, linux-)
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: # Problematic frame:
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: # V  [libjvm.so+0x25a36c]
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: #
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: # No core dump will be written. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: #
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: # An error report file with more information is saved as:
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: # /tmp/hs_err_pid2042.log
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: #
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: # If you would like to submit a bug report, please visit:
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: #   Unknown
Dez 07 15:40:19 FHEM2021 signal-cli[2042]: #
Dez 07 15:40:19 FHEM2021 systemd[1]: signal.service: Main process exited, code=killed, status=6/ABRT

Gruß
Christian

Offline Adimarantis

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 699
So ein "harter" Absturz in Java kann eigentlich nur mit den native libs zusammenhängen.
Hab gerade bei mir geschaut und das hatte ich heute morgen auch - aber komischerweise nur heute morgen (dafür 4 mal innerhalb von 5 Minuten), obwohl das System schon Tage auf der 0.9.2 läuft. Seitdem wieder kein Problem obwohl diverse Messages gesendet und empfangen wurden.
Probier mal auf 0.9.0 zurückzugehen (einfach im signal_install.sh die Version editieren und drüber laufen lassen).
Raspberry 4 + HM-MOD-RPI-PCB (pivCCU) + RfxTrx433XL + 2xRaspberry 1
Module: 50_Signalbot, 52_I2C_ADS1x1x , 58_RPI_1Wire, (50_SPI_MAX31865)

Offline Kohle77

  • Full Member
  • ***
  • Beiträge: 161
Hi,
nachdem ändern der Version und einfach drüber installieren zeigt systemctl status signal.client:
Dez 07 17:53:56 FHEM2021 systemd[1]: Starting Send secure messages to Signal clients...
Dez 07 17:54:05 FHEM2021 signal-cli[7056]: OpenJDK Server VM warning: You have loaded library /tmp/resource6692934069678612009.so which might have disabled stack guard. The VM will try to fix the stack guard now.

Dies is ja schon im Wicki beschrieben.
Also habe ich ein remove mit Version 0.9.2 und zur Sicherheit 0.9.0 laufen lassen.
Das device in FHEM gelöscht.
Jetzt nochmal mit:
sudo find / -name libzkgroup.so 2>/dev/null
sudo find / -name zkgroup-java-*.jar 2>/dev/null
sudo find / -name libsignal_jni.so 2>/dev/null
sudo find / -name signal-client-java-*.jar 2>/dev/null
alles abgesucht aber nichts gefunden.
Im install script wieder die 0.9.0 eingetragen und mit


sudo ./signal_install.sh
das ganze installiert.
Aber auch da startet der signal.service nicht.

Job for signal.service failed because the control process exited with error code.
See "systemctl status signal.service" and "journalctl -xe" for details.
Checking installation via dbus-send command...Error org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.asamk.Signal': timed out (service_start_timeout=25000ms)
unexpected reply

systemctl status signal.service
? signal.service - Send secure messages to Signal clients
   Loaded: loaded (/etc/systemd/system/signal.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2021-12-07 18:05:20 CET; 1min 17s ago
  Process: 7861 ExecStart=/opt/signal/bin/signal-cli --config /var/lib/signal-cli daemon --system (code=exited, status=1/FAILURE)
 Main PID: 7861 (code=exited, status=1/FAILURE)

Dez 07 18:05:09 FHEM2021 systemd[1]: Starting Send secure messages to Signal clients...
Dez 07 18:05:18 FHEM2021 signal-cli[7861]: OpenJDK Server VM warning: You have loaded library /tmp/resource2366696904404504317.so which might have disabled stack guard. The VM will try to fix the stack guard now.
Dez 07 18:05:18 FHEM2021 signal-cli[7861]: It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
Dez 07 18:05:18 FHEM2021 signal-cli[7861]: WARN ServiceConfig - Failed to call libzkgroup: /tmp/resource2366696904404504317.so: /tmp/resource2366696904404504317.so: falsche ELF-Klasse: ELFCLASS64 (Possible cause: architecture word width
Dez 07 18:05:19 FHEM2021 signal-cli[7861]: WARN App - WARNING: Support for new group V2 is disabled, because the required native library dependency is missing: libzkgroup
Dez 07 18:05:20 FHEM2021 signal-cli[7861]: WARN ServiceConfig - Failed to call libsignal-client: /tmp/resource479949972762061985.so: /tmp/resource479949972762061985.so: falsche ELF-Klasse: ELFCLASS64 (Possible cause: architecture word wi
Dez 07 18:05:20 FHEM2021 signal-cli[7861]: Missing required native library dependency: libsignal-client
Dez 07 18:05:20 FHEM2021 systemd[1]: signal.service: Main process exited, code=exited, status=1/FAILURE
Dez 07 18:05:20 FHEM2021 systemd[1]: signal.service: Failed with result 'exit-code'.
Dez 07 18:05:20 FHEM2021 systemd[1]: Failed to start Send secure messages to Signal clients.


journalctl -xe bringt diese Fehler:
Dez 07 18:05:18 FHEM2021 signal-cli[7861]: OpenJDK Server VM warning: You have loaded library /tmp/resource2366696904404504317.so which might have disabled stack guard. The VM will try to fix the stack guard now.
Dez 07 18:05:18 FHEM2021 signal-cli[7861]: It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
Dez 07 18:05:18 FHEM2021 signal-cli[7861]: WARN ServiceConfig - Failed to call libzkgroup: /tmp/resource2366696904404504317.so: /tmp/resource2366696904404504317.so: falsche ELF-Klasse: ELFCLASS64 (Possible cause: architecture word width
Dez 07 18:05:19 FHEM2021 signal-cli[7861]: WARN App - WARNING: Support for new group V2 is disabled, because the required native library dependency is missing: libzkgroup
Dez 07 18:05:20 FHEM2021 signal-cli[7861]: WARN ServiceConfig - Failed to call libsignal-client: /tmp/resource479949972762061985.so: /tmp/resource479949972762061985.so: falsche ELF-Klasse: ELFCLASS64 (Possible cause: architecture word wi
Dez 07 18:05:20 FHEM2021 signal-cli[7861]: Missing required native library dependency: libsignal-client
Dez 07 18:05:20 FHEM2021 systemd[1]: signal.service: Main process exited, code=exited, status=1/FAILURE
-- Subject: Unit process exited
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- An ExecStart= process belonging to unit signal.service has exited.
--
-- The process' exit code is 'exited' and its exit status is 1.
Dez 07 18:05:20 FHEM2021 systemd[1]: signal.service: Failed with result 'exit-code'.
-- Subject: Unit failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- The unit signal.service has entered the 'failed' state with result 'exit-code'.
Dez 07 18:05:20 FHEM2021 systemd[1]: Failed to start Send secure messages to Signal clients.
-- Subject: A start job for unit signal.service has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- A start job for unit signal.service has finished with a failure.
--
-- The job identifier is 2493 and the job result is failed.
Dez 07 18:05:34 FHEM2021 dbus-daemon[362]: [system] Failed to activate service 'org.asamk.Signal': timed out (service_start_timeout=25000ms)
Dez 07 18:05:34 FHEM2021 sudo[7616]: pam_unix(sudo:session): session closed for user root

Gruß
Christian

 

decade-submarginal