Autor Thema: Maintainerwechsel  (Gelesen 1963 mal)

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 21153
Maintainerwechsel
« am: 01 Januar 2017, 16:15:18 »
Da Nobert (ntruchsess) seit laengerem im Forum nicht aktiv war, und auf eine direkte Email-Anfrage seit 3 Wochen nicht gemeldet hat, uebernimmt Stephan (eisler) die MQTT Module.

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 21153
Antw:Maintainerwechsel
« Antwort #1 am: 07 Januar 2017, 18:08:39 »
Bitte keine Diskussionsentfuehrung. Ich wollte diese fuer im Betreff beschriebene Angelegenheiten reservieren.

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 8277
  • eigentlich eher user wie "developer"
Antw:Maintainerwechsel
« Antwort #2 am: 15 April 2019, 15:05:45 »
Hallo zusammen,

ich hoffe, das gehört hierher...

Die MySensors-Module (00_MYSENSORS, 10_MYSENSORS, sowie die zugehörigen libs in lib/Device/MySensors) werden nun von mir weiter betreut werden, weiteres hier.

ntruchsess steht übrigens in der MAINTAINER.txt noch ein paarmal mehr drin, v.a. auch im Zusammenhang mit einigen 1wire-Dingen, die evtl. zwischenzeitlich über pah's Modul(e) anders gelöst sind.

Grüße,

Beta-User
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN
svn:MySensors, WeekdayTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline Loredo

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3659
  • ~ Challenging Innovation ~
Antw:Maintainerwechsel
« Antwort #3 am: 15 April 2019, 15:22:40 »
Ja, nicht wenige. Auch FHEM Packages:

Hat meine Arbeit dir geholfen? ⟹ https://paypal.me/pools/c/8gDLrIWrG9

Maintainer:
FHEM-Docker Image, https://github.com/fhem, Astro(Co-Maintainer), ENIGMA2, GEOFANCY, GUEST, HP1000, Installer, LaMetric2, MSG, msgConfig, npmjs, PET, PHTV, Pushover, RESIDENTS, ROOMMATE, search, THINKINGCLEANER

Offline Beta-User

  • Developer
  • Hero Member
  • ****
  • Beiträge: 8277
  • eigentlich eher user wie "developer"
Antw:Maintainerwechsel
« Antwort #4 am: 15 April 2019, 15:50:33 »
Es fehlt in dem Screenshot noch FHEM/lib/ProtoThreads.pm, das aber scheinbar nur für die 1wire-Dinge benötigt wird - da stellt sich eh' die Frage, ob man diese verbliebenen Module nicht auf deprecated stellen sollte (ich nutze das aber schon ewig nicht mehr, da müßte man vermutlich am besten pah mal fragen, was OWX jetzt eigentlich direkt abdecken kann; weiter gibt es zum Teil gleichnamige Module mit Ziffern-Präfix).

GPUtils wird von einer ganzen Reihe von Modulen verwendet, vorrangig wegen der (ersten) Import-Funktion, wenn ich das richtig sehe.
Die Übrigen Funktionen aus dieser Datei sind zumindest für die MQTT-Familie (hexenmeister) und MYSENSORS-Familie wichtig, wobei ich im Ohr habe, dass Rudi die Matching-Funktionen nicht so prickelnd fand.
Vielleicht sollte man den Teil irgendwie mittelfristig entzerren?
Server: HP-T620@Debian 10, aktuelles FHEM + ConfigDB | CUL_HM (VCCU) | MQTT2: MiLight@ESP-GW | MySensors: seriell, v.a. 2.3.1@RS485 | ZWave | ZigBee@deCONZ | SIGNALduino | MapleCUN
svn:MySensors, WeekdayTimer, AttrTemplate => {mqtt2, mysensors, httpmod}

Offline Loredo

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3659
  • ~ Challenging Innovation ~
Antw:Maintainerwechsel
« Antwort #5 am: 15 April 2019, 16:45:59 »
Es fehlt in dem Screenshot noch FHEM/lib/ProtoThreads.pm


+ FHEM/lib/LiquidCrystal.pm
+ FHEM/lib/OWNet-2.8p17.pm
+ FHEM/lib/OWNet-3.1p5.pm
« Letzte Änderung: 15 April 2019, 16:47:38 von Loredo »
Hat meine Arbeit dir geholfen? ⟹ https://paypal.me/pools/c/8gDLrIWrG9

Maintainer:
FHEM-Docker Image, https://github.com/fhem, Astro(Co-Maintainer), ENIGMA2, GEOFANCY, GUEST, HP1000, Installer, LaMetric2, MSG, msgConfig, npmjs, PET, PHTV, Pushover, RESIDENTS, ROOMMATE, search, THINKINGCLEANER

Offline Prof. Dr. Peter Henning

  • Developer
  • Hero Member
  • ****
  • Beiträge: 6903
Antw:Maintainerwechsel
« Antwort #6 am: 17 April 2019, 11:14:15 »
Betroffen ist nur das Modul OWX_ASYNC - das sollte auf deprecated stehen. Die anderen OW..-Module haben den Support für OWX_ASYNC noch drin, der ist aber bereits vor mehr als einem Jahr abgekündigt worden und fliegt beim nächsten Update raus.

LG

pah

Online CoolTux

  • Developer
  • Hero Member
  • ****
  • Beiträge: 22724
Antw:Maintainerwechsel
« Antwort #7 am: 19 Juni 2019, 10:04:52 »
Mahlzeit die Herren,

Ich würde gerne das GPUtils Modul übernehmen. Spräche etwas dagegen?


Grüße
Du musst nicht wissen wie es geht! Du musst nur wissen wo es steht, wie es geht.
Support me to buy new test hardware for development: https://paypal.me/pools/c/8gULisr9BT
FHEM GitHub: https://github.com/fhem/
kein Support für cfg Editierer
Gefällt mir Gefällt mir x 1 Liste anzeigen

Online CoolTux

  • Developer
  • Hero Member
  • ****
  • Beiträge: 22724
Antw:Maintainerwechsel
« Antwort #8 am: 19 Juni 2019, 15:21:46 »
Wenn sich niemand bis morgen meldet übernehme ich nach Rücksprache mit Jörg und Alex das maintaining von GPUtils.pm

Grüße
Du musst nicht wissen wie es geht! Du musst nur wissen wo es steht, wie es geht.
Support me to buy new test hardware for development: https://paypal.me/pools/c/8gULisr9BT
FHEM GitHub: https://github.com/fhem/
kein Support für cfg Editierer

Online CoolTux

  • Developer
  • Hero Member
  • ****
  • Beiträge: 22724
Antw:Maintainerwechsel
« Antwort #9 am: 20 Juni 2019, 08:01:59 »
Keine Gegenstimmen, dann fange ich heute an die MAINTAINER.txt an zu passen und das Modul mit einer kleinen Erweiterung ein zu checken.


Grüße
Du musst nicht wissen wie es geht! Du musst nur wissen wo es steht, wie es geht.
Support me to buy new test hardware for development: https://paypal.me/pools/c/8gULisr9BT
FHEM GitHub: https://github.com/fhem/
kein Support für cfg Editierer

 

decade-submarginal