Autor Thema: Kommunikation mit KNX ohne knxd  (Gelesen 46582 mal)

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Kommunikation mit KNX ohne knxd
« am: 29 April 2018, 15:13:03 »
Hallo liebe KNX-Gemeinde,

ich habe mich gefragt, ob es nicht möglich ist, mit dem KNX-Netztwerk ohne den knxd zu kommunizieren.
Hierzu habe ich das beigefügte Modul entwickelt, was auf dem 00_TUL Modul basiert und mit einem KNX-Router über die Multicast-Adresse 224.0.23.12 kommuniziert.
Ich bin allerdings kein Perl-Experte und dieses Modul ist sozusagen mein Perl-Erstlingswerk.
Dennoch funktioniert es bei meiner Testumgebung bis jetzt einwandfrei.
Vielleicht hat ja noch jemand Lust, diese Variante zu testen.
Ich würde mich über Rückmeldungen freuen. (Jetzt mit der aktuellen Version vom 13.03.2019)
Der Einsatz funktioniert wie folgt:
Kopieren des Moduls in den FHEM-Modulordner (Standard: /opt/fhem/FHEM)
Falls in Perl noch kein Multicast eingebunden ist:

sudo cpan IO::Socket::Multicast
sudo service fhem stop
sudo service fhem start

Einrichtung unter FHEM dann:
define TUL KNXTUL 1.1.254
define KThermo KNX 0/0/2:dpt9.001:SollTemp 0/0/3:dpt9.001:IstTemp KNXTUL

Die angegebenen Namen und Adressen sind natürlich nur beispielhaft

Gruß

Jens

PS: Update (31.12.2019) das Modul ist jetzt auch per "Update"-Befehl im Standard verfügbar.
« Letzte Änderung: 31 Dezember 2019, 12:26:03 von jewuma »
Gefällt mir Gefällt mir x 7 Liste anzeigen

Offline dinkel75

  • Jr. Member
  • **
  • Beiträge: 85
Antw:Kommunikation mit KNX ohne knxd
« Antwort #1 am: 25 Mai 2018, 08:15:21 »
Ich hab schon Sonoff Wlan mit Sonoff-Tasmota KNX geflasht, die die selbe Multicastadresse nutzen - könnte das ein Problem sein?

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #2 am: 25 Mai 2018, 10:08:08 »
Zu Sonoff-Tasmota kann ich natürlich nicht wirklich was sagen, aber wenn dort das KNX-Protokoll implementiert ist, dann ist das ja gerade der Sinn der Sache, dass die KNX-Multicast-Adresse verwendet wird. Die KNX-IP-Geräte lauschen ja alle auf dieser Adresse und prüfen, ob ein Paket, welches an diese Adresse gesendet wird, für sie bestimmt ist. Die physikalische KNX-Adresse muss sich natürlich bei allen Geräten unterscheiden.
Ansonsten: einfach mal testen.

Gruß

Jens
« Letzte Änderung: 04 Juli 2018, 15:21:28 von jewuma »

Offline JoeALLb

  • Hero Member
  • *****
  • Beiträge: 1611
Antw:Kommunikation mit KNX ohne knxd
« Antwort #3 am: 04 Juli 2018, 08:31:24 »
Supportest Du das Modul auch? Dann würde ich einen Umstieg planen!
;-)

sG
Joe
FHEM-Server auf IntelAtom+Debian (8.1 Watt), KNX,
RasPi-2 Sonos-FHEM per FHEM2FHEM,RasPi-3 Versuchs-RasPi für WLAN-Tests
Gateways: DuoFern Stick, CUL866 PCA301, CUL HM, HMLan, JeeLink, LaCrosse,VCO2
Synology. Ardurino UNO für 1-Wire Tests, FB7270

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #4 am: 04 Juli 2018, 15:24:13 »
Das würde ich nach bestem Wissen und Gewissen schon tun.
Trotzdem gilt natürlich : "THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED..." :)

Gruß
Jens

Offline Cookie

  • New Member
  • *
  • Beiträge: 29
Antw:Kommunikation mit KNX ohne knxd
« Antwort #5 am: 19 Juli 2018, 13:33:32 »
habe es mal am Laufen - wenn was nicht geht melde ich mich, bisher super Eindruck!

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #6 am: 19 Juli 2018, 16:58:19 »
Danke für die positive Rückmeldung  :)

Offline JoeALLb

  • Hero Member
  • *****
  • Beiträge: 1611
Antw:Kommunikation mit KNX ohne knxd
« Antwort #7 am: 26 Juli 2018, 09:44:52 »
Bei mir läufts nicht.
bekomme folgende Fehlermeldung direkt nach dem define.
autocreate: define KNX_2801176 KNX 28/1/176:MODEL_NOT_DEFINED
'x' outside of string in unpack at ./FHEM/00_KNXTUL.pm line 507.

(BTW: ich kenne kein Device mit der GAP 28/1/176 in meinem System)...

sG joe
FHEM-Server auf IntelAtom+Debian (8.1 Watt), KNX,
RasPi-2 Sonos-FHEM per FHEM2FHEM,RasPi-3 Versuchs-RasPi für WLAN-Tests
Gateways: DuoFern Stick, CUL866 PCA301, CUL HM, HMLan, JeeLink, LaCrosse,VCO2
Synology. Ardurino UNO für 1-Wire Tests, FB7270

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #8 am: 26 Juli 2018, 11:01:45 »
Kannst Du vielleicht mal verbose auf 5 setzen und das automatisch angelegte Gerät mal löschen und den Ausschnitt aus dem Log dann mal posten?

Ich versuche der Sache dann auf den Grund zu gehen, aber ohne Daten ist das schwierig.

Gruß

Jens

Offline abc2006

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 963
Antw:Kommunikation mit KNX ohne knxd
« Antwort #9 am: 21 Dezember 2018, 09:04:24 »
Hi, ich wäre auch umsteigewillig - aber erst, wenn ich fhem mal neu aufsetze... zur Zeit hab ich genug andere Baustellen, aber auf knxd zu verzichten hört sich sehr interessant an ...

Grüße,
Stephan
FHEM nightly auf Intel Atom (lubuntu) mit VDSL 50000 ;-)
Nutze zur Zeit OneWire und KNX

Offline mrixs

  • New Member
  • *
  • Beiträge: 13
Antw:Kommunikation mit KNX ohne knxd
« Antwort #10 am: 20 Januar 2019, 18:07:59 »
Das Modul läuft bei mir jetzt 6 Monate stabil. Danke.
Hilfreich Hilfreich x 1 Liste anzeigen

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #11 am: 21 Januar 2019, 09:51:35 »
Das freut mich sehr. Danke auch, dass Du Dir die Mühe machst, ein Feedback zu schreiben.

Offline JoeALLb

  • Hero Member
  • *****
  • Beiträge: 1611
Antw:Kommunikation mit KNX ohne knxd
« Antwort #12 am: 22 Januar 2019, 16:29:39 »
Servus,

auch von mir ein kurzes Feedback: bei mir funktioniert es auf der Baustelle im Moment nicht, aber vorallem deswegen, weil das Gateway dort keine
Broadcastadressen, sondern nur eine IP unterstützt.... Ist auch nicht schlimm, wollte es nur kurz mitteilen!


sG
Joe
FHEM-Server auf IntelAtom+Debian (8.1 Watt), KNX,
RasPi-2 Sonos-FHEM per FHEM2FHEM,RasPi-3 Versuchs-RasPi für WLAN-Tests
Gateways: DuoFern Stick, CUL866 PCA301, CUL HM, HMLan, JeeLink, LaCrosse,VCO2
Synology. Ardurino UNO für 1-Wire Tests, FB7270

Offline CQuadrat

  • Sr. Member
  • ****
  • Beiträge: 668
Antw:Kommunikation mit KNX ohne knxd
« Antwort #13 am: 23 Januar 2019, 08:59:52 »
Hallo Jens,

ich habe ein KNX-IP-Gateway das per knxd und dem "Standard"-Tul-Modul an FHEM angebunden ist.

Lässt sich denn Dein Modul parallel dazu nutzen (Testphase)?


Viele Grüße

Christoph
« Letzte Änderung: 23 Januar 2019, 09:06:37 von CQuadrat »
FHEM auf Mini-ITX-Server mit Intel Quad-Core J1900:
+ HM: HM-LAN, HM-USB, HM-MOD-UART mit div. HM-Komponenten
+ RFXtrx: Funkwetterstation Bresser mit ext. Thermometer, Regenmesser und Windmesser
+ TUL (KNX-Anbindung), KM271 (per ser2net), SONOS (div. Gimmicks), OneWire, Hue

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #14 am: 23 Januar 2019, 09:24:38 »
Gegen den testweisen parallelen Einsatz dürfte m.E. nichts sprechen.
Ich würde halt nur nicht unbedingt KNX-Steuerkommandos über beide Wege raussenden.

Gruß

Jens

Offline CQuadrat

  • Sr. Member
  • ****
  • Beiträge: 668
Antw:Kommunikation mit KNX ohne knxd
« Antwort #15 am: 23 Januar 2019, 09:29:57 »
Danke für die schnelle Antwort.

Ein erster (kurzer) Test war leider nicht erfolgreich.

Muss ich FHEM auch neustarten?

Bei den KNX-Devices sollte es doch dann genügen, das IODev auf das neue IO-Device (KNXTUL) abzuändern?


Nachtrag:
Okay, ich habe ein MDT SCN-IP000.02 (IP Interface); das kann wohl kein Multicast. Das kann nur der MDT SCN-IP100.02 (IP Router).
Schade.
« Letzte Änderung: 23 Januar 2019, 09:40:54 von CQuadrat »
FHEM auf Mini-ITX-Server mit Intel Quad-Core J1900:
+ HM: HM-LAN, HM-USB, HM-MOD-UART mit div. HM-Komponenten
+ RFXtrx: Funkwetterstation Bresser mit ext. Thermometer, Regenmesser und Windmesser
+ TUL (KNX-Anbindung), KM271 (per ser2net), SONOS (div. Gimmicks), OneWire, Hue

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #16 am: 23 Januar 2019, 11:40:14 »
Ich habe mal irgendwo gelesen, dass die meisten KNX-IP-Interfaces Multicast unterstützen. Im Handbuch von MDT habe ich leider keine eindeutige Aussage gefunden.
Der FHEM-Neustart ist jedoch auf jeden Fall nötig, da zuvor auch noch das Perl-Multicast Modul installiert werden muss.
Also:
Das KNXTUL nach /opt/fhem/FHEM  Verzeichnis kopieren (Wenn standardmäßig installiert)
sudo cpan IO::Socket::Multicast
sudo service fhem stop
sudo service fhem start

Und dann nochmal probieren.
Gruß
Jens

Jens


Offline CQuadrat

  • Sr. Member
  • ****
  • Beiträge: 668
Antw:Kommunikation mit KNX ohne knxd
« Antwort #17 am: 23 Januar 2019, 11:46:40 »
Das Perl-Modul hatte ich schon länger davor per
apt-get install libio-socket-multicast-perlinstalliert.
Am Wochenende, wenn ich mehr Zeit habe, schaue ich es mir nochmal an.

Danke und Gruß
Christoph
FHEM auf Mini-ITX-Server mit Intel Quad-Core J1900:
+ HM: HM-LAN, HM-USB, HM-MOD-UART mit div. HM-Komponenten
+ RFXtrx: Funkwetterstation Bresser mit ext. Thermometer, Regenmesser und Windmesser
+ TUL (KNX-Anbindung), KM271 (per ser2net), SONOS (div. Gimmicks), OneWire, Hue

Offline GammaTwin

  • Jr. Member
  • **
  • Beiträge: 85
Antw:Kommunikation mit KNX ohne knxd
« Antwort #18 am: 28 Januar 2019, 21:35:16 »
Grüße,

cooles Modul. Ich kann den Bus "hören", allerdings scheint da was beim übersetzen zu haken :)

Im Logfile steht:
PERL WARNING: Use of uninitialized value $str in pattern match (m//) at ./FHEM/00_KNXTUL.pm line 483.
KNXTUL opening KNX
KNXTUL device opened

und dann
RawMessage read: 2900bcd01001270b05008043c58000
Message read: 1001270b008043c58000
KNX: dispatch C01001w0470b43c58000
KNX: Unknown code C01001w0470b43c58000, help me!

Sieht schon irgendwie nach einem Telegramm aus...

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #19 am: 29 Januar 2019, 15:51:58 »
Ich denke, da ist beim "DEFINE" was schiefgegangen.
Kannst du mal kurz posten, wie du das Gerät angelegt hast?

Gruß

Jens

Offline GammaTwin

  • Jr. Member
  • **
  • Beiträge: 85
Antw:Kommunikation mit KNX ohne knxd
« Antwort #20 am: 29 Januar 2019, 16:58:58 »
Wahrscheinlich habe zu einfach gedacht :)

define KNX KNXTUL
Das war's

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #21 am: 29 Januar 2019, 18:13:39 »
Ein bisschen zu einfach, du musst dem TUL noch eine KNX-Adresse verpassen.

also z.B.  "define KNX KNXTUL 1.1.249"

Dabei eine Adresse verwenden, die noch nicht existiert.

Gruß
Jens

Offline GammaTwin

  • Jr. Member
  • **
  • Beiträge: 85
Antw:Kommunikation mit KNX ohne knxd
« Antwort #22 am: 30 Januar 2019, 10:23:17 »
Ok, habe KNX-Adresse vergeben.

Der Fehler ist damit verschunden
PERL WARNING: Use of uninitialized value $str in pattern match (m//) at ./FHEM/00_KNXTUL.pm line 483.

Der Rest ist allerdings noch vorhanden.
RawMessage read: 2900bcd01001270b05008043c58000
Message read: 1001270b008043c58000
KNX: dispatch C01001w0470b43c58000
KNX: Unknown code C01001w0470b43c58000, help me!

In der ETS sehe ich die Schnittstelle nicht. Im Produktivsystem nutze ich eibd und das sehe ich in der ETS.


Ich habe mal versucht die Telegramme übersichtlicher darzustellen. Vielleicht hilft es ja für eine Erklärung.
TextTeil1gleicher Teil
RawMessage read:
2900bcd01001270b050080
43c58000
Message read:
1001270b0080
43c58000
KNX: dispatch
C01001w0470b
43c58000
KNX: Unknown code
C01001w0470b
43c58000


Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #23 am: 30 Januar 2019, 17:08:56 »
Ich arbeite im Moment noch an einem Problem was auftritt, wenn ein ungültiges Paket ankommt. Du könntest aber schon mal versuchen eine ankommende Gruppenadresse abzufragen mit:

DEFINE Temperatur1 KNX 0/4/128:dpt9.001 KNX
oder so ähnlich, je nachdem, wie deine Gruppenadressen und Datenpunkte lauten. Dann verschwinden auch die "Hilferufe"  :)

Gruß

Jens

Offline GammaTwin

  • Jr. Member
  • **
  • Beiträge: 85
Antw:Kommunikation mit KNX ohne knxd
« Antwort #24 am: 30 Januar 2019, 20:58:55 »
Hat funktioniert :)

Ich habe einen Teil meiner Gruppenadressen aus der Produktivumgebung über include eingebunden. Diese sind dann sofort voll funktionsfähig :)

UND

ab jetzt werden alle anderen Gruppenadressen über über autocreate ordnungsgemäß angelegt.

Klingt das für Dich logisch? Es muss mindestens eine Adresse vorhanden sein, damit das (sehr geiles) Modul richtig arbeitet?
« Letzte Änderung: 30 Januar 2019, 23:28:26 von GammaTwin »

Offline GammaTwin

  • Jr. Member
  • **
  • Beiträge: 85
Antw:Kommunikation mit KNX ohne knxd
« Antwort #25 am: 31 Januar 2019, 08:08:32 »
Habe alle Device eingebaut.

Nach einer Weile steigt fhem komplett aus, ist nicht mehr erreichbar. Im Log liegt dann als letzte Meldung:
current value for KNX_0103031 (1/5/31) requested
'x' outside of string in unpack at ./FHEM/00_KNXTUL.pm line 507.

Es handelt sich um Device für eine Lampe, die ich noch nicht montiert habe und auch nicht in der ETS einem Aktor zugeordnet habe :)
Das Teil antwortet also nicht. Im fhem steht
GETSTRING g1:noArg g3:noArg g2:noArg
Könnte das mit den ungültigen Paketen zusammenhängen?
Ich arbeite im Moment noch an einem Problem was auftritt, wenn ein ungültiges Paket ankommt.


Hintergrund für die Abfrage des Wertes:
Das Device beinhalte 3 Gruppenadressen (g1: on/off, g2: dimmen relativ, g3: Dimmwert). Um die Visualisierung auf Stand zu bringen, frage ich für die Lampen die g3  ab. Daher die Anfrage auf (1/5/31) obwohl die Lampe nicht antwortet.

Edit: Ohne diese Devices läuft es :)
« Letzte Änderung: 31 Januar 2019, 08:33:22 von GammaTwin »

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #26 am: 31 Januar 2019, 09:46:21 »
Ja, genau das ist das Problem, Es tauchen selten Pakete auf, die einfach Blödsinn sind und dann das System durcheinander bringen.
Ich konnte den Fall jedoch nicht provozieren, sondern er ist bei mir gestern einmal aufgetreten und danach nicht mehr, auch ohne Änderungen in der Konfiguration oder der Hardware.
Ich werde jetzt die fehlerhaften Pakete abfangen und damit auch den Absturz vehindern.
Sobald ich fertig bin, stelle ich ein Update hier rein.

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #27 am: 31 Januar 2019, 11:15:18 »
So, hier die neue Version mit einer Gültigkeitsprüfung um Crashs zu vermeiden. Ich bitte nochmal um Feedback.


Offline GammaTwin

  • Jr. Member
  • **
  • Beiträge: 85
Antw:Kommunikation mit KNX ohne knxd
« Antwort #28 am: 31 Januar 2019, 13:08:50 »
Meine 3 "Geist-Devices" produzieren keinen Fehler mehr :)

Ich lasse es mal laufen...

Offline GammaTwin

  • Jr. Member
  • **
  • Beiträge: 85
Antw:Kommunikation mit KNX ohne knxd
« Antwort #29 am: 02 Februar 2019, 08:12:49 »
Guten Morgen,

hatte nach 3 Tage, einmalig diese Meldung.
PERL WARNING: Use of uninitialized value $state in subtraction (-) at ./FHEM/10_KNX.pm line 1922.
FHEM ist nicht hängengeblieben und es wurden auch weiterhin Telegramme empfangen. Also scheinbar keine Folgen...

Gruß

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #30 am: 02 Februar 2019, 09:50:50 »
Das sieht mir jetzt aber eher nach einem kleinen Bug im KNX-Modul aus. Wenn das öfter vorkommt, dann bitte mal den KNXTUL auf verbose 5 setzen und das entsprechende Gerät auch, anhand des Logs könnte ich nochmal forschen.

Offline JoeALLb

  • Hero Member
  • *****
  • Beiträge: 1611
Antw:Kommunikation mit KNX ohne knxd
« Antwort #31 am: 02 Februar 2019, 19:22:15 »
Servus. Damit die Version ich nur Multicast , sondern auch direkt von einer IP hören kann, ist nicht möglich, (oder angedacht), oder?
FHEM-Server auf IntelAtom+Debian (8.1 Watt), KNX,
RasPi-2 Sonos-FHEM per FHEM2FHEM,RasPi-3 Versuchs-RasPi für WLAN-Tests
Gateways: DuoFern Stick, CUL866 PCA301, CUL HM, HMLan, JeeLink, LaCrosse,VCO2
Synology. Ardurino UNO für 1-Wire Tests, FB7270

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #32 am: 03 Februar 2019, 12:33:59 »
Bisher nicht. Ich muss es mir mal ansehen. Ich bin, wie eingangs geschrieben kein Perl-Guru und habe bis auf die kleinen Debug-Geschichten in den letzten Tagen nichts mehr mit Perl gemacht, daher ist die Einarbeitung noch etwas schwieriger. Aber vielleicht ist das Problem ja nocht so groß. Ich melde mich wieder...

Offline GammaTwin

  • Jr. Member
  • **
  • Beiträge: 85
Antw:Kommunikation mit KNX ohne knxd
« Antwort #33 am: 10 März 2019, 22:27:53 »
Grüße,

nachdem das Modul jetzt über einen Monat perfekte Dienste geleistet hat, ist folgendes passiert:
Ich habe mit der ETS einige Änderungen in die Busteilnehmer programmiert. Danach hatte ich neue Devices im FHEM. Ein Blick in den Log verät, dass die Nachrichten, welche die ETS schreibt, um die Busteilnehmer zu programmieren irgendwie falsch verstanden werden.

Und so sieht das dann aus:
...
2019.03.10 17:45:17.333 2: autocreate: define KNX_0200024 KNX 2/0/24:MODEL_NOT_DEFINED
2019.03.10 17:45:17.372 2: autocreate: define FileLog_KNX_0200024 FileLog ./log/autocreate/KNX_0200024-%Y.log KNX_0200024
2019.03.10 17:45:17.514 1: Received Message too short: 2900b0501018000100c2
2019.03.10 17:45:17.517 1: Received Message too short: 2900b0600001101800c2
2019.03.10 17:45:17.519 2: autocreate: define FileLog_KNX_0200024 FileLog ./log/autocreate/KNX_0200024-%Y.log KNX_0200024
2019.03.10 17:45:17.574 1: Received Message too short: 2900b0501018000100c6
2019.03.10 17:45:17.746 1: Received Message too short: 2900b0600001101800c6
2019.03.10 17:45:17.749 2: autocreate: define FileLog_KNX_0200024 FileLog ./log/autocreate/KNX_0200024-%Y.log KNX_0200024
2019.03.10 17:45:17.779 1: Received Message too short: 2900b0501018000100ca
2019.03.10 17:45:17.895 1: Received Message too short: 2900b0600001101800ca
...
2019.03.10 19:25:08.597 2: parse device hash (wpi): HASH(0x55d501f1f130) name: KNX_0200003, message could not be decoded - see log for details
2019.03.10 19:25:08.604 3: KNX: Unknown code C00001w0200340340426342635263626372714, help me!
2019.03.10 19:25:08.735 1: Received Message too short: 2900b0501003000100e6
2019.03.10 19:25:08.824 1: Received Message too short: 2900b0501003000100ea
2019.03.10 19:25:08.898 1: Received Message too short: 2900b0600001100300ce
2019.03.10 19:25:08.975 1: Received Message too short: 2900b0501003000100ee
2019.03.10 19:25:09.052 1: Received Message too short: 2900b0600001100300d2
2019.03.10 19:25:09.203 1: Received Message too short: 2900b0501003000100f2
2019.03.10 19:25:09.267 1: Received Message too short: 2900b0501003000100f6
2019.03.10 19:25:09.338 1: Received Message too short: 2900b0600001100300d6
2019.03.10 19:25:09.415 1: Received Message too short: 2900b0501003000100fa
2019.03.10 19:25:09.488 1: Received Message too short: 2900b0600001100300da
2019.03.10 19:25:09.501 2: parse device hash (wpi): HASH(0x55d501f1f130) name: KNX_0200003, message could not be decoded - see log for details
2019.03.10 19:25:09.508 3: KNX: Unknown code C00001w02003404c33273427352736, help me!
2019.03.10 19:25:09.629 1: Received Message too short: 2900b0501003000100fe
2019.03.10 19:25:09.694 1: Received Message too short: 2900b0501003000100c2
2019.03.10 19:25:09.759 1: Received Message too short: 2900b0600001100300de
2019.03.10 19:25:09.848 1: Received Message too short: 2900b0501003000100c6
...

Teilweise werden zufällig vorhanden Gruppenadressen getroffen. Dann passiert nichts, weil die Nachricht zu kurz ist :)
Siehe: KNX_0200003

Wird keine vorhandene Gruppenadresse getroffen, werden neue Devices angelegt :(
Siehe: KNX_0200024

Irgendwie müssten die "Systemnachrichten" ignoriert werden. Vielleicht kann man da etwas von knxd abschauen...

Schönen Abend

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #34 am: 12 März 2019, 10:42:25 »
Ich habe im Moment keine laufende KNX-Installation hier, daher kann ich den Fall nicht nachstellen.
Wenn du magst, dann stell doch mal KNXTUL auf verbose 5 und schick nochmal eine Umprogrammierung.
Dann könnte ich die Sache genauer analysieren und ggf. fixen.

Das mit dem Modul ohne Multicast wird wohl demnächst nichts, mein Router wollte mit dem Modul nicht so ohne Weiteres direkt kommunzieren.

Ich hoffe aber, dass KNXTUL außerhalb der Programmierung "unauffällig" läuft und auch die Meldungen es nicht aus dem Takt gebracht haben.

Gruß

Jens

Offline GammaTwin

  • Jr. Member
  • **
  • Beiträge: 85
Antw:Kommunikation mit KNX ohne knxd
« Antwort #35 am: 12 März 2019, 20:00:57 »
Grüße,

ich habe 2 unterschiedliche Aktoren programmiert:

Der erste erzeugt die von mir verwendeten "KNX_02000xx" Adressen. Z.B: "KNX, dest: 0200a". Das führt dann zu den neuen Devices.
2019.03.12 19:30:29.551 1: Received Message too short: 2900b0600001100a00c6
2019.03.12 19:30:29.571 5: RawMessage read: 2900b0600001100a0f4a8c47e4d1db070bd3db070bd4db070b
2019.03.12 19:30:29.572 5: Message read - CtrlByte: 01100000 Source: 0001 Dest: 100a Data: 4a8c47e4d1db070bd3db070bd4db070b
2019.03.12 19:30:29.572 5: KNX: dispatch C00001w0200a47e4d1db070bd3db070bd4db070b
2019.03.12 19:30:29.572 5: enter parse: hash: HASH(0x55e1aa461b30) name: KNX, dest: 0200a, msg: C00001w0200a47e4d1db070bd3db070bd4db070b
2019.03.12 19:30:29.573 2: parse device hash (wpi): HASH(0x55e1aaa48988) name: KNX_0200010, message could not be decoded - see log for details
2019.03.12 19:30:29.573 5: exit parse
2019.03.12 19:30:29.579 3: KNX: Unknown code C00001w0200a47e4d1db070bd3db070bd4db070b, help me!
2019.03.12 19:30:29.633 1: Received Message too short: 2900b050100a000100ca
2019.03.12 19:30:29.694 5: RawMessage read: 2900b050100a00010f4a4c47e4d1db070bd3db070bd4db070b
2019.03.12 19:30:29.694 5: Message read - CtrlByte: 01010000 Source: 100a Dest: 0001 Data: 4a4c47e4d1db070bd3db070bd4db070b
2019.03.12 19:30:29.694 5: KNX: dispatch C0100ap0000147e4d1db070bd3db070bd4db070b
2019.03.12 19:30:29.695 5: enter parse: hash: HASH(0x55e1aa461b30) name: KNX, dest: 00001, msg: C0100ap0000147e4d1db070bd3db070bd4db070b
2019.03.12 19:30:29.695 5: exit parse
2019.03.12 19:30:29.756 1: Received Message too short: 2900b0600001100a00ca
2019.03.12 19:30:29.777 5: RawMessage read: 2900b0600001100a0f4e8c47f0d5db070bd6db070bd7db070b
2019.03.12 19:30:29.778 5: Message read - CtrlByte: 01100000 Source: 0001 Dest: 100a Data: 4e8c47f0d5db070bd6db070bd7db070b
2019.03.12 19:30:29.778 5: KNX: dispatch C00001w0200a47f0d5db070bd6db070bd7db070b
2019.03.12 19:30:29.778 5: enter parse: hash: HASH(0x55e1aa461b30) name: KNX, dest: 0200a, msg: C00001w0200a47f0d5db070bd6db070bd7db070b
2019.03.12 19:30:29.779 2: parse device hash (wpi): HASH(0x55e1aaa48988) name: KNX_0200010, message could not be decoded - see log for details
2019.03.12 19:30:29.779 5: exit parse
2019.03.12 19:30:29.786 3: KNX: Unknown code C00001w0200a47f0d5db070bd6db070bd7db070b, help me!
2019.03.12 19:30:29.839 1: Received Message too short: 2900b050100a000100ce
2019.03.12 19:30:29.899 5: RawMessage read: 2900b050100a00010f4e4c47f0d5db070bd6db070bd7db070b
2019.03.12 19:30:29.900 5: Message read - CtrlByte: 01010000 Source: 100a Dest: 0001 Data: 4e4c47f0d5db070bd6db070bd7db070b
2019.03.12 19:30:29.900 5: KNX: dispatch C0100ap0000147f0d5db070bd6db070bd7db070b
2019.03.12 19:30:29.900 5: enter parse: hash: HASH(0x55e1aa461b30) name: KNX, dest: 00001, msg: C0100ap0000147f0d5db070bd6db070bd7db070b
2019.03.12 19:30:29.901 5: exit parse


Der zweite Aktor erzeugt "KNX, dest: 00001".
2019.03.12 19:38:41.541 5: RawMessage read: 2900b050101800010f724c497c000000000000000000000000
2019.03.12 19:38:41.541 5: Message read - CtrlByte: 01010000 Source: 1018 Dest: 0001 Data: 724c497c000000000000000000000000
2019.03.12 19:38:41.542 5: KNX: dispatch C01018p00001497c000000000000000000000000
2019.03.12 19:38:41.542 5: enter parse: hash: HASH(0x55e1aa461b30) name: KNX, dest: 00001, msg: C01018p00001497c000000000000000000000000
2019.03.12 19:38:41.543 5: exit parse
2019.03.12 19:38:41.600 1: Received Message too short: 2900b0600001101800f2
2019.03.12 19:38:41.622 5: RawMessage read: 2900b0600001101803720c4988
2019.03.12 19:38:41.623 5: Message read - CtrlByte: 01100000 Source: 0001 Dest: 1018 Data: 720c4988
2019.03.12 19:38:41.623 5: KNX: dispatch C00001r020184988
2019.03.12 19:38:41.623 5: enter parse: hash: HASH(0x55e1aa461b30) name: KNX, dest: 02018, msg: C00001r020184988
2019.03.12 19:38:41.623 5: exit parse
2019.03.12 19:38:41.631 3: KNX: Unknown code C00001r020184988, help me!
2019.03.12 19:38:41.666 1: Received Message too short: 2900b0501018000100f2
2019.03.12 19:38:41.727 5: RawMessage read: 2900b050101800010f764c49880000ff000000000000000000
2019.03.12 19:38:41.727 5: Message read - CtrlByte: 01010000 Source: 1018 Dest: 0001 Data: 764c49880000ff000000000000000000
2019.03.12 19:38:41.728 5: KNX: dispatch C01018p0000149880000ff000000000000000000
2019.03.12 19:38:41.728 5: enter parse: hash: HASH(0x55e1aa461b30) name: KNX, dest: 00001, msg: C01018p0000149880000ff000000000000000000
2019.03.12 19:38:41.729 5: exit parse
2019.03.12 19:38:41.803 1: Received Message too short: 2900b0600001101800f6
2019.03.12 19:38:41.824 5: RawMessage read: 2900b0600001101803760c4994
2019.03.12 19:38:41.825 5: Message read - CtrlByte: 01100000 Source: 0001 Dest: 1018 Data: 760c4994
2019.03.12 19:38:41.825 5: KNX: dispatch C00001r020184994
2019.03.12 19:38:41.825 5: enter parse: hash: HASH(0x55e1aa461b30) name: KNX, dest: 02018, msg: C00001r020184994
2019.03.12 19:38:41.825 5: exit parse
2019.03.12 19:38:41.832 3: KNX: Unknown code C00001r020184994, help me!
2019.03.12 19:38:41.867 1: Received Message too short: 2900b0501018000100f6
2019.03.12 19:38:41.929 5: RawMessage read: 2900b050101800010f7a4c4994000000000000000000000000
2019.03.12 19:38:41.929 5: Message read - CtrlByte: 01010000 Source: 1018 Dest: 0001 Data: 7a4c4994000000000000000000000000
2019.03.12 19:38:41.930 5: KNX: dispatch C01018p000014994000000000000000000000000
2019.03.12 19:38:41.930 5: enter parse: hash: HASH(0x55e1aa461b30) name: KNX, dest: 00001, msg: C01018p000014994000000000000000000000000
2019.03.12 19:38:41.931 5: exit parse
2019.03.12 19:38:42.009 1: Received Message too short: 2900b0600001101800fa
2019.03.12 19:38:42.031 5: RawMessage read: 2900b06000011018037a0c49a0
2019.03.12 19:38:42.031 5: Message read - CtrlByte: 01100000 Source: 0001 Dest: 1018 Data: 7a0c49a0
2019.03.12 19:38:42.032 5: KNX: dispatch C00001r0201849a0
2019.03.12 19:38:42.032 5: enter parse: hash: HASH(0x55e1aa461b30) name: KNX, dest: 02018, msg: C00001r0201849a0
2019.03.12 19:38:42.032 5: exit parse
2019.03.12 19:38:42.039 3: KNX: Unknown code C00001r0201849a0, help me!
2019.03.12 19:38:42.074 1: Received Message too short: 2900b0501018000100fa
2019.03.12 19:38:42.136 5: RawMessage read: 2900b050101800010f7e4c49a0000000000000000000000000
2019.03.12 19:38:42.136 5: Message read - CtrlByte: 01010000 Source: 1018 Dest: 0001 Data: 7e4c49a0000000000000000000000000
2019.03.12 19:38:42.137 5: KNX: dispatch C01018p0000149a0000000000000000000000000
2019.03.12 19:38:42.137 5: enter parse: hash: HASH(0x55e1aa461b30) name: KNX, dest: 00001, msg: C01018p0000149a0000000000000000000000000
2019.03.12 19:38:42.138 5: exit parse

Genau genommen: Ich habe keine Ahnung :)

Du hattest nach sonstigen Problemen gefragt, oder ob die Meldungen irgwelche Effekte hatten. Ich habe keine Meldung im letzten Monat in den Logfiles gefunden :)
Während der Programmierung ist auch keine Jalousie verfahren, gesperrt oder irgendwie beeinträchtigt worden. (KNX_02....) ist bei mir Verschattung. Also alles gut.

Solange das Thema besteht, werde ich fhem beenden während des Programmiervorganges.

Schönes Abend

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #36 am: 13 März 2019, 14:27:22 »
Hallo und danke für die Testdaten.

Ich habe jetzt mal die nicht "normalen" Nachrichten ausgefiltert, das sollte das Anlegen von ungewollten KNX-Geräten unterbinden.

Gruß

Jens

Offline GammaTwin

  • Jr. Member
  • **
  • Beiträge: 85
Antw:Kommunikation mit KNX ohne knxd
« Antwort #37 am: 18 März 2019, 18:56:09 »
Habe es mehrere Tage ausprobiert. Lief problemlos.

Heute habe ich mit der ETS programmiert. Es ist ein einziges "help me!" aufgetaucht mit verbose 5 aufgetaucht. Kein Gerät würde angelegt, ich habe auch sonst nichts negatives bemerkt.

Daumen hoch!!


Ich habe etwas anderes endeckt. Ist aber wahrscheinlich völlig unbedeutend:
Ich habe teilweise die Definitionen set, get, listenonly im Einsatz.

Mit listenonly wollte ich verhindern, dass FHEM den Wert verändert.
defmod KNX_0407050 KNX 4/7/50:dpt9.021:listenonly
Fragt dann allerdings eine KNX-Komponente den Status ab, kommt im LOG:
KNXTUL - Read started
2019.03.18 18:32:27.698 5: RawMessage read: 2900bce000012732010000
2019.03.18 18:32:27.698 5: Message read - CtrlByte: 11100000 Source: 0001 Dest: 2732 Data: 0000
2019.03.18 18:32:27.699 5: KNX: dispatch C00001r0473200
2019.03.18 18:32:27.699 5: enter parse: hash: HASH(0x5595f6e8bf08) name: KNX, dest: 04732, msg: C00001r0473200
2019.03.18 18:32:27.699 5: exit parse
2019.03.18 18:32:27.705 3: KNX: Unknown code C00001r0473200, help me!

Ändere ich die Definition auf "get"
defmod KNX_0407050 KNX 4/7/50:dpt9.021:getkommt keine "help me!"-Meldung
2019.03.18 18:33:23.225 5: KNXTUL - Read started
2019.03.18 18:33:23.225 5: RawMessage read: 2900bce000012732010000
2019.03.18 18:33:23.225 5: Message read - CtrlByte: 11100000 Source: 0001 Dest: 2732 Data: 0000
2019.03.18 18:33:23.226 5: KNX: dispatch C00001r0473200
2019.03.18 18:33:23.226 5: enter parse: hash: HASH(0x5595f6e8bf08) name: KNX, dest: 04732, msg: C00001r0473200
2019.03.18 18:33:23.226 5: exit parse

Die Meldungen unterscheiden sich ja nur in der letzten Zeile. Wahrscheinlich ist gar kein "Bug", da bei "listenonly" kein Request erwartet wird...

Online EinEinfach

  • Full Member
  • ***
  • Beiträge: 247
Antw:Kommunikation mit KNX ohne knxd
« Antwort #38 am: 01 April 2019, 17:50:01 »
Zitat
Okay, ich habe ein MDT SCN-IP000.02 (IP Interface); das kann wohl kein Multicast. Das kann nur der MDT SCN-IP100.02 (IP Router).
Schade.

hast du es doch noch irgendwie zum Laufen bekommen? Habe die gleiche Hardware, macht es Sinn sich mit dem Modul zu beschäftigen oder ist es gleich von vorne aus aussichtslos

Gruß
fhem auf Intel NUC6CAYH mit Proxmox im LXC (Debian 10), KNX mit knxd über MDT SCN-IP000.02, Buderus GB192-15i mit KM100

Offline kasperle_1

  • New Member
  • *
  • Beiträge: 10
Antw:Kommunikation mit KNX ohne knxd
« Antwort #39 am: 03 April 2019, 11:42:54 »
Hallo,

ich habe das Modul eingebunden und erhaltet sobald ich einen AKTOR Betätige folgende Meldung:

2019.04.03 11:35:38.863 3: KNXTUL opening KNXHome
2019.04.03 11:35:38.863 3: KNXTUL device opened
2019.04.03 11:36:06.261 3: KNXHome: Unknown code C01102w0021400, help me!
2019.04.03 11:36:06.328 3: KNXHome: Unknown code C0fffaw0021400, help me!
2019.04.03 11:36:06.457 3: KNXHome: Unknown code C01202w0021300, help me!
2019.04.03 11:36:06.537 3: KNXHome: Unknown code C0fffaw0021400, help me!
2019.04.03 11:36:06.835 3: KNXHome: Unknown code C01202w0021300, help me!
2019.04.03 11:36:06.915 3: KNXHome: Unknown code C0fffaw0021400, help me!

Ich dachte erkannte Geräte werden automatisch angelegt?

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #40 am: 15 April 2019, 09:56:04 »
Ich habe das mal nachvollzogen.
Dies liegt nicht an dem KNXTUL sondern an dem KNX-Modul selbst, welches zuerst mindestens ein Gerät händisch angelegt haben will, bevor es neue Geräte automatisch anlegt.
Allerdings ist es sowieso sinnvoll, die Geräte selbst anzulegen, da die Datenpunkte angegeben werden müssen, um sinnvoll mit den Geräten zu arbeiten.

Gruß

Jens

Offline markofnoise

  • New Member
  • *
  • Beiträge: 4
Antw:Kommunikation mit KNX ohne knxd
« Antwort #41 am: 09 Juli 2019, 14:26:46 »
Hallo zusammen,

da mich mein knxd quält, würde ich sehr gerne umsteigen. Ich halte das Projekt für einen tolle Idee, die eine Menge Komplexität einsparen kann.

Selbst umfangreiche Tests (knxd stand-alone auf RPI, im Docker) konnten das Problem der doppelten Telegramme nicht lösen. Auf fhem-Seite bekomme ich sauber nur einfache Telegramme, ebenso über vbusmonitor1, aber in der ETS ist alles doppelt. Ebenso steigen bei mir nach zuschalten vom knxd KNX-Rolladen-Aktoren aus. Recherchen bzgl. Linienkoppler und Router wegen Telegramm-Bestätigung haben mich auch nicht weiter gebracht.

So, nun zu meiner Hoffnung. Da ich bereits viele Devices habe, möchte ich auf jeden Fall vorher ein bisschen genauer testen. Ich benutze fhem in erster Linie als Gateway von Homematic, ZigBee, Z-Wave nach KNX und zurück (per notify) und habe mich eher mit der Anwendungsseite beschäftigt.

Da ich bisher wenig Erfahrung mit TUL bzw. Devices im allgemeinen habe, bitte ich hier um eine etwas genauere Beschreibung der Konfiguration in fhem.

Meine Sicht
1. Schritt: Installtion (Modul und cpan), soweit ok
2. Danach fehlt mir einfach das Wissen (u.a. Syntax und Bedeutung, TUL etc.)

Könnte mich da jemand abholen?

Viele Grüße
Markus

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #42 am: 09 Juli 2019, 15:15:36 »
Hallo,
ich weiß nicht, ob ich die Wissenslücken richtig erkannt habe, aber ich versuche es einfach mal.

Für die Kommunikation mit deinen KNX-Geräten brauchst du entweder das KNX-Modul und den knxd oder das KNX-Modul und das KNXTUL-Modul.
Der knxd bzw. das KNXTUL stellen die physikalische Kommunikation mit dem KNX-Gateway her.

dazu machst du ein
define KNX KNXTUL 1.1.254, wobei die 1.1.254 eine physikalische KNX-Adresse ist, unter der die Pakete an die einzelnen Geräte geschickt werden. Eine IP-Adresse wird nicht benötigt, da das Modul immer über die KNX-Standard-Multicast-Adresse kommuniziert.

Jetzt kann das KNX-Modul (hoffentlich) mit den KNX-Geräten sprechen.
Dazu musst du dem KNX Modul nur noch mitteilen, mit welchen Gruppenadressen es kommunizieren soll, die Datenpunkte, die den Gruppenadressen entsprechen, einen Namen unter dem die erhaltenen Werte gelistet werden und schließlich, dass die Kommunikation über den KNXTUL laufen soll, der hier mit dem Namen KNX definiert wurde. Beispiel:

define KThermo KNX 0/0/2:dpt9.001:SollTemp 0/0/3:dpt9.001:IstTemp KNX
Ich hoffe, das hilft weiter.

Gruß
Jens
« Letzte Änderung: 09 Juli 2019, 15:18:01 von jewuma »

Offline markofnoise

  • New Member
  • *
  • Beiträge: 4
Antw:Kommunikation mit KNX ohne knxd
« Antwort #43 am: 15 Juli 2019, 17:57:14 »
Vielen Dank für Deine Erklärung, jetzt versuche ich es nochmal mit meinen eigenen Worten:

Ein KNX-Modul benötigt ein TUL um mit KNX (TP,IP) zu kommunizieren, im Falle des KNXTUL (als TUL) findet eine Kommunikation über Multicast statt.
 
Das Device <name> ist eine KNX-Modul-Instanz, welches ein [IODev] benötigt:
define <name> KNX <group>:<DPT>:[gadName]:[set|get|listenonly]:[nosuffix] [<group>:<DPT> ..] [IODev]
In Deinem Post definierst Du also eine KNXTUL-Instanz mit
define KNX KNXTUL 1.1.254
define KThermo KNX 0/0/2:dpt9.001:SollTemp 0/0/3:dpt9.001:IstTemp KNX

wobei das erste KNX = KNX-Modul-Instanz und das zweite KNX = [IODev] definiert wird

Damit ich das besser auseinander halten kann:
define KNXIP KNXTUL 1.1.254
define KThermo KNX 0/0/2:dpt9.001:SollTemp 0/0/3:dpt9.001:IstTemp KNXIP

Um jetzt einzelne Devices testweise auf Multicast umzulenken, müsste doch die Umdefinition des Attributes [IODev] genügen, oder?
 
VG
Markus

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #44 am: 16 Juli 2019, 10:53:46 »
Hallo,

mit meinem bescheidenen FHEM Wissen würde ich sagen, dass das so korrekt ist und funktionieren müsste.

Gruß

Jens

Offline clown

  • New Member
  • *
  • Beiträge: 13
Antw:Kommunikation mit KNX ohne knxd
« Antwort #45 am: 06 September 2019, 21:13:58 »
Klasse Idee, hab es mal ausprobiert, läuft besser als KNXD bei mir, mal schauen was die weiteren Tests bringen.

Wird das Ding irgendwann zur Standard Distribution angemeldet?

Vielen Dank dafür ...
 
« Letzte Änderung: 07 September 2019, 00:00:05 von clown »

Offline mrixs

  • New Member
  • *
  • Beiträge: 13
Antw:Kommunikation mit KNX ohne knxd
« Antwort #46 am: 10 September 2019, 23:56:55 »
Im ETS Gruppenmonitor sieht man das die Quelladresse nicht richtig angegeben ist, sondern es ist die Größe des Datanpackets als Quelladresse.


Offline danillo

  • Jr. Member
  • **
  • Beiträge: 89
Antw:Kommunikation mit KNX ohne knxd
« Antwort #47 am: 24 September 2019, 20:33:14 »
Hallo zusammen,

ich hab jetzt per define myKNX KNXTUL 1.1.254 eine KNXTUL-Instanz erzeugt.
Jetzt wollte ich per define lamp KNX 1/2/5:dpt1 myKNX eine Lampe einfügen.
1/2/5 ist die Gruppenadresse aus KNX, Passt das so?
danillo

Offline clown

  • New Member
  • *
  • Beiträge: 13
Antw:Kommunikation mit KNX ohne knxd
« Antwort #48 am: 24 September 2019, 22:34:55 »
Ich habe es so am laufen:

define KNXIP KNXTUL 1.1.110

define eg_az_Licht KNX 2/1/4:dpt1.001
attr eg_az_Licht IODev KNXIP


Offline danillo

  • Jr. Member
  • **
  • Beiträge: 89
Antw:Kommunikation mit KNX ohne knxd
« Antwort #49 am: 25 September 2019, 18:13:59 »
Ich habe mal irgendwo gelesen, dass die meisten KNX-IP-Interfaces Multicast unterstützen. Im Handbuch von MDT habe ich leider keine eindeutige Aussage gefunden.

Ich hab auch das IP-Interface von mdt. In der 02-Version. Da geht leider nichts mit Multicast. :'(  Die Version 03 unterstützt dann Multicast.

Jetzt muss ich mich wohl doch mit knxd auseinandersetzen.  :-\

Offline Porsti

  • Full Member
  • ***
  • Beiträge: 208
Antw:Kommunikation mit KNX ohne knxd
« Antwort #50 am: 02 November 2019, 16:09:39 »
Hi,

ich versuche gerade meine ersten gehversuche mit KNX zu machen. Habe einen kleine Testaufbau auf dem Schreibtisch liegen.
Dort liegt ein IP Interface SCN-IP000.03 und der MDT Glastaster.
Ich habe eine Gruppe Angegelegt 1/1/0 für Schaltbefehle und dort ein Ein/Aus (Bild)

In fhem habe ich das IP Interface mit
Internals:
   Clients    KNX
   DEF        1.1.254
   DeviceAddress 011fe
   FD         12
   FUUID      5dbd9289-f33f-75cf-2df7-caf32eff29a1a334
   HAS_IO::Socket::Multicast 1
   IPAddress  224.0.23.12
   KNXIP_MSGCNT 2
   KNXIP_TIME 2019-11-02 16:01:37
   NAME       KNXIP
   NR         701
   PARTIAL   
   Port       3671
   RAWMSG     C00005w0140000
   REFUSED   
   STATE      Initialized
   TYPE       KNXTUL
   UseDirectConnection 0
Attributes:
   icon       it_network@3399FF
   room       Gateway
   verbose    5

und mein erstes Gerät
Internals:
   DEF        1/1/0:dpt1.001:Schalten KNXIP
   DEVNAME    KNX_Flur
   FIRSTGADNAME Schalten
   FUUID      5dbd8bf8-f33f-75cf-339d-f72cdeda530d32fa
   GETSTRING  Schalten:noArg
   IODev      KNXIP
   KNXIP_MSGCNT 2
   KNXIP_RAWMSG C00005w0140000
   KNXIP_TIME 2019-11-02 16:01:37
   LASTInputDev KNXIP
   MSGCNT     2
   NAME       KNX_Flur
   NR         700
   NTFY_ORDER 50-KNX_Flur
   SETSTRING  Schalten:off,on
   STATE      off
   TYPE       KNX
   GADDETAILS:
     Schalten:
       CODE       01100
       GROUP      1/1/0
       MODEL      dpt1.001
       NO         1
       OPTION     
       RDNAMEGET  Schalten-get
       RDNAMEPUT  Schalten-put
       RDNAMESET  Schalten-set
       SETLIST    :off,on
   GADTABLE:
     01100      Schalten
   READINGS:
     2019-11-02 16:01:37   Schalten-get    off
     2019-11-02 16:01:37   Schalten-set    off
     2019-11-02 15:58:47   Zentral-get     off
     2019-11-02 15:58:47   Zentral-set     off
     2019-11-02 15:58:47   getG1           on
     2019-11-02 16:01:37   last-sender     0/0/5
     2019-11-02 15:58:47   setG1           on
     2019-11-02 16:01:37   state           off
Attributes:
   IODev      KNXIP
   room       Protokolle->KNX
   verbose    0

Ich habe mal das Inerface auf verbose 5 gesetzt aber leider kann ich nicht sehen wenn ich eine Taste betätige. Ich sehe nur das die beiden Traffic LED's am Inferface Blinken wenn ich eine Taste betätige oder den Befehl von der ETS schicke.

Gruß
Porsti
____________________________________
fhem 5.9  auf Raspberry 3
Homematic HM-CC-RT-DN / HM-TC-IT-WM-W-EU / HM-SEC-SCo / HM-LC-SW1-PL2
SIGNALduino, KNX (Merten, MDT, Siemens)

Offline clown

  • New Member
  • *
  • Beiträge: 13
Antw:Kommunikation mit KNX ohne knxd
« Antwort #51 am: 02 November 2019, 16:19:37 »
Kann der SCN-IP000.03 überhaupt Multicast, ist doch nur ein Tunnel Device, so weit ich weiss?


Offline Porsti

  • Full Member
  • ***
  • Beiträge: 208
Antw:Kommunikation mit KNX ohne knxd
« Antwort #52 am: 02 November 2019, 17:42:21 »
Kann der SCN-IP000.03 überhaupt Multicast, ist doch nur ein Tunnel Device, so weit ich weiss?

Hi, in der ETS hat er in der Konfiguration eine Multicast Adresse und wenn ich mich nicht Irre hat hier im Thema jemand geschrieben das das Interface ab der Version 3 Mulicast unterstützt.

Gruß
Porsti

Im Anhang ein Bild aus der ETS
« Letzte Änderung: 02 November 2019, 17:46:11 von Porsti »
____________________________________
fhem 5.9  auf Raspberry 3
Homematic HM-CC-RT-DN / HM-TC-IT-WM-W-EU / HM-SEC-SCo / HM-LC-SW1-PL2
SIGNALduino, KNX (Merten, MDT, Siemens)

Offline clown

  • New Member
  • *
  • Beiträge: 13
Antw:Kommunikation mit KNX ohne knxd
« Antwort #53 am: 02 November 2019, 18:14:04 »
So sieht es bei mir aus und funktioniert mit einem IP Router SCN-IP100.02, wenn ich in der Beschreibung lese, steht da nur das der Backbone Multicast spricht, die Frage ist ob Du Dich zum Multicast joinen kannst oder ob das nur via Tunnel geht. Ich nehme an das das IP Interface Modul intern zum KNX mit Multicast spricht, aber nicht mit Deinem Ethernet Device. Sonst bräuchte man ja keinen Router mehr kaufen. Sprichst Du mit der ETS über den Multicast?


Internals:
   Clients    KNX
   DEF        1.1.110
   DeviceAddress 0116e
   FD         8
   FUUID      5d72ab9d-f33f-4cb7-3e83-9fa15408017a1e5b
   HAS_IO::Socket::Multicast 1
   IPAddress  224.0.23.12
   KNXIP_MSGCNT 210338
   KNXIP_TIME 2019-11-02 18:12:55
   NAME       KNXIP
   NR         36
   PARTIAL
   Port       3671
   RAWMSG     C01114w0020018aa
   REFUSED
   STATE      Initialized
   TYPE       KNXTUL
   UseDirectConnection 0
Attributes:
   verbose    3


Internals:
   DEF        2/1/3:dpt1.001:Schalten KNXIP
   DEVNAME    eg_az_Licht_Vitrine
   FIRSTGADNAME Schalten
   FUUID      5d59aaf6-f33f-4cb7-e536-6d451f63ad46a757
   GETSTRING  Schalten:noArg
   IODev      KNXIP
   KNXIP_MSGCNT 6
   KNXIP_RAWMSG C00005w0210300
   KNXIP_TIME 2019-11-02 18:06:49
   LASTInputDev KNXIP
   MSGCNT     6
   NAME       eg_az_Licht_Vitrine
   NR         174
   NTFY_ORDER 50-eg_az_Licht_Vitrine
   SETSTRING  Schalten:off,on
« Letzte Änderung: 02 November 2019, 18:37:37 von clown »

Offline Porsti

  • Full Member
  • ***
  • Beiträge: 208
Antw:Kommunikation mit KNX ohne knxd
« Antwort #54 am: 02 November 2019, 22:43:48 »
Danke für deine Antwort,

dann habe ich es falsch verstanden und muss mir wohl den Roter holen  :'(

Gruß & THX
Porsti
____________________________________
fhem 5.9  auf Raspberry 3
Homematic HM-CC-RT-DN / HM-TC-IT-WM-W-EU / HM-SEC-SCo / HM-LC-SW1-PL2
SIGNALduino, KNX (Merten, MDT, Siemens)

Offline Porsti

  • Full Member
  • ***
  • Beiträge: 208
Antw:Kommunikation mit KNX ohne knxd
« Antwort #55 am: 27 November 2019, 10:03:44 »
Hi,

habe jetzt meinen IP-Router in Betrieb genommen und kann endlich Daten aus dem KNX Bus Empfangen und senden. :-)

Jetzt stecke ich nur an einem anderen Punkt fest.
Ich bekomme es nicht hin das das Device seinen Status als Antwort in den Bus sendet.

Wenn ich über KNX eine Befehl absetzte wird keine Rückmeldung gesendet.

Auszug Commandref:
_______________________________________________
answerReading

    If enabled, FHEM answers on read requests. The content of reading <state> is send to the bus as answer. If supplied, the content of the reading <putName> is used to supply the data for the answer.

_______________________________________________


Internals:
   CFGFN      ./FHEM/fhem_dev_knx.cfg
   DEF        1/1/0:dpt1.001:schalten 1/4/0:dpt1.001:status KNXIP
   DEVNAME    KNX_Flur
   FIRSTGADNAME schalten
   FUUID      5dbd8bf8-f33f-75cf-339d-f72cdeda530d32fa
   GETSTRING  status:noArg schalten:noArg
   IODev      KNXIP
   KNXIP_MSGCNT 26
   KNXIP_RAWMSG C00005w0110000
   KNXIP_TIME 2019-11-27 09:55:56
   LASTInputDev KNXIP
   MSGCNT     26
   NAME       KNX_Flur
   NR         576
   NTFY_ORDER 50-KNX_Flur
   SETSTRING  status:off,on schalten:off,on
   STATE      off
   TYPE       KNX
   GADDETAILS:
     schalten:
       CODE       01100
       GROUP      1/1/0
       MODEL      dpt1.001
       NO         1
       OPTION     
       RDNAMEGET  schalten-get
       RDNAMEPUT  schalten-put
       RDNAMESET  schalten-set
       SETLIST    :off,on
     status:
       CODE       01400
       GROUP      1/4/0
       MODEL      dpt1.001
       NO         2
       OPTION     
       RDNAMEGET  status-get
       RDNAMEPUT  status-put
       RDNAMESET  status-set
       SETLIST    :off,on
   GADTABLE:
     01100      schalten
     01400      status
   READINGS:
     2019-11-27 09:55:56   last-sender     0/0/5
     2019-11-27 09:55:56   schalten-get    off
     2019-11-27 09:55:56   schalten-set    off
     2019-11-27 09:55:56   state           off
Attributes:
   IODev      KNXIP
   answerReading 1
   room       Protokolle->KNX
   verbose    0
   webCmd     on:off

Gruß & Danke für die Hilfe

Porsti
____________________________________
fhem 5.9  auf Raspberry 3
Homematic HM-CC-RT-DN / HM-TC-IT-WM-W-EU / HM-SEC-SCo / HM-LC-SW1-PL2
SIGNALduino, KNX (Merten, MDT, Siemens)

Offline clown

  • New Member
  • *
  • Beiträge: 13
Antw:Kommunikation mit KNX ohne knxd
« Antwort #56 am: 27 November 2019, 10:39:33 »
Hallo Porsti,

habe mal einen kleinen Test aufgesetzt, bei mir hat das funktioniert:

fhem> list newTest
Internals:
   DEF        5/1/0:dpt9.001 KNXIP
   DEVNAME    newTest
   FIRSTGADNAME g1
   FUUID      5d5cf3bd-f33f-4cb7-f5de-44688d9fb404d296
   GETSTRING  g1:noArg
   IODev      KNXIP
   KNXIP_MSGCNT 3
   KNXIP_RAWMSG C00007p051000c1a
   KNXIP_TIME 2019-11-27 10:32:27
   LASTInputDev KNXIP
   MSGCNT     3
   NAME       newTest
   NR         141
   NTFY_ORDER 50-newTest
   SETSTRING  g1:slider,-670760,13415,670760
   STATE      21.00 &deg;C
   TYPE       KNX
   GADDETAILS:
     g1:
       CODE       05100
       GROUP      5/1/0
       MODEL      dpt9.001
       NO         1
       OPTION
       RDNAMEGET  getG1
       RDNAMEPUT  putG1
       RDNAMESET  setG1
       SETLIST    :slider,-670760,13415,670760
   GADTABLE:
     05100      g1
   Helper:
     DBLOG:
       getG1:
         logdb:
           TIME       1574847147.29554
           VALUE      21.00
       last-sender:
         logdb:
           TIME       1574847147.29554
           VALUE      0/0/7
       state:
         logdb:
           TIME       1574847147.29554
           VALUE      21.00
   READINGS:
     2019-11-27 10:32:27   getG1           21.00 &deg;C
     2019-11-27 10:32:27   last-sender     0/0/7
     2019-11-22 00:15:58   setG1           21.00 &deg;C
     2019-11-27 10:32:27   state           21.00 &deg;C
Attributes:
   IODev      KNXIP
   answerReading 1
   group      Temperatur
   room       Erdgeschoss->Arbeitszimmer
   webCmd     state
   widgetOverride state:selectnumbers,15,1,30,1,lin

fhem>

Habe dann anschließend "Lesen" in ETS probiert und habe meine Antwort bekommen.
Vielleicht hilft Dir mein Setup bei der Fehlersuche....

Gruß Michael

Offline Porsti

  • Full Member
  • ***
  • Beiträge: 208
Antw:Kommunikation mit KNX ohne knxd
« Antwort #57 am: 27 November 2019, 11:26:15 »
Hallo Clown,

ich habe einen Taster der auf der Gruppenadresse 1.1.0 den Befehl absetzt und dann eine Statusrückmeldung auf 1.4.0 erwartet.
Bei den Temperaturen bin ich leider noch nicht, das ist der nächste Schritt wenn ich diesen am laufen habe.

Mich machte es gerstern stutzig das wenn ich den taster betätige dieses auch im Gruppenmonitor sehen kann. Der Befehl kommt bei fhem an.
Fhem setzt aber keinen Anwort, die ich sehen kann, auf den Bus.

Wenn ich über fhem den on Befehl absetzte wird so abgesetzt:

2019-11-27 11:23:11 KNX KNX_Flur schalten-set: on
2019-11-27 11:23:11 KNX KNX_Flur on
2019-11-27 11:23:11 KNX KNX_Flur last-sender: fhem
2019-11-27 11:23:12 KNX KNX_Flur schalten-get: on
2019-11-27 11:23:12 KNX KNX_Flur last-sender: 0/0/5
2019-11-27 11:23:12 KNX KNX_Flur on

Dort sehe ich den status auch nicht.

Gruß Porsti
____________________________________
fhem 5.9  auf Raspberry 3
Homematic HM-CC-RT-DN / HM-TC-IT-WM-W-EU / HM-SEC-SCo / HM-LC-SW1-PL2
SIGNALduino, KNX (Merten, MDT, Siemens)

Offline clown

  • New Member
  • *
  • Beiträge: 13
Antw:Kommunikation mit KNX ohne knxd
« Antwort #58 am: 27 November 2019, 12:26:26 »
Hallo Porsti,

habe ich noch nicht selbst probiert, aber das müsste mit notify und dem set Befehl gehen, d.H. wenn Du Deinen Taster drückst, dann wird das Device im FHEM getriggert, notify löst dann einen Set Befehl auf deine Status Adresse aus.

Habe etwas ähnliches im Forum gefunden "https://forum.fhem.de/index.php?topic=69948.0"


Offline Porsti

  • Full Member
  • ***
  • Beiträge: 208
Antw:Kommunikation mit KNX ohne knxd
« Antwort #59 am: 27 November 2019, 12:56:57 »
Hallo Clown,

danke für deine Antwort. Hatte es so verstanden das das KNX Modul dieses automatisch machen kann.
Dann werde ich mal schauen ob ich eine DOIF schreiben werde das es für alle meine Rückmeldungen machen kann.
Schade, wäre für den anwender einfacher.

Gruß & THX
Porsti
____________________________________
fhem 5.9  auf Raspberry 3
Homematic HM-CC-RT-DN / HM-TC-IT-WM-W-EU / HM-SEC-SCo / HM-LC-SW1-PL2
SIGNALduino, KNX (Merten, MDT, Siemens)

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #60 am: 31 Dezember 2019, 12:24:30 »
Nur zur Info:

Inzwischen habe ich das Modul hochgeladen, so dass es via "update" in der Standard-Installation verfügbar ist.

Gruß Jens
Gefällt mir Gefällt mir x 2 Liste anzeigen

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #61 am: 14 Januar 2020, 09:10:39 »
Da ich derzeit Probleme mit knxd habe, werde ich nachher mal versuchen knxd komplett zu entfernen und deine Lösung zu testen.

Notiz für mich:
sudo systemctl disable knxd.service
sudo systemctl stop knxd.service
sudo dpkg -r knxd_*.deb knxd-tools_*.deb
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #62 am: 14 Januar 2020, 22:23:26 »
Ich habe es nun bei mir am Laufen, jedoch kann ich nur vom BUS empfangen aber nicht senden? Jemand eine Idee?
Zitat


2020.01.14 22:31:10 5: KNXTUL - Read started
2020.01.14 22:31:10 5: No useable Messageheader: 0000
2020.01.14 22:31:13 5: KNXTUL - Write started
2020.01.14 22:31:13 5: KNXTUL: sending C w0060100
2020.01.14 22:31:13 5: KNXTUL_encode_eibd: dst: 00601 apci: 2 datalen: 1 data: 0
2020.01.14 22:31:13 5: KNXTUL_sendGroup: dst: 00601, msg: 1537 1 0 128
2020.01.14 22:31:13 5: KNXTUL_sendRequest: 224.0.23.12:3671 msg: 0610053000112900bcd000050601010080
2020.01.14 22:31:13 5: KNXTUL - Read started
2020.01.14 22:31:13 5: RawMessage read: 2900bcd000050601010080
2020.01.14 22:31:13 5: Message read - CtrlByte: 11010000 Source: 0005 Dest: 0601 Data: 0080
2020.01.14 22:31:13 5: tul: dispatch C00005w0060100
2020.01.14 22:31:13 5: enter parse: hash: HASH(0x55e1af9ba810) name: tul, dest: 00601, msg: C00005w0060100
2020.01.14 22:31:13 5: exit parse
2020.01.14 22:31:13 5: KNXTUL - Read started
2020.01.14 22:31:13 5: No useable Messageheader: 0000
« Letzte Änderung: 14 Januar 2020, 22:31:59 von Hauswart »
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #63 am: 15 Januar 2020, 09:37:45 »
Eigentlich sieht es doch so aus, als ob gesendet wird. Bisher hatte ich damit auch keine Probleme. Woran machst du denn fest, dass keine Daten rausgehen?
Reagiert das Gerät nicht?

Gruß

Jens

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #64 am: 15 Januar 2020, 15:05:12 »
Eigentlich sieht es doch so aus, als ob gesendet wird. Bisher hatte ich damit auch keine Probleme. Woran machst du denn fest, dass keine Daten rausgehen?
Reagiert das Gerät nicht?

Gruß

Jens


Hallo Jens,

genau es passiert beim Gerät nichts. Mit KNXD als IO geht es... habe einfach das IODEV ausgetauscht bei den jeweiligen Test-Geräten.

Gruss und danke
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #65 am: 18 Januar 2020, 16:55:38 »
Das ist von hier aus schlecht nachzuvollziehen. Meine einzige Idee ist, dass die physikalische KNX-Adresse ( aus dem KNXTUL-Define) irgenwie kollidiert.
Kann es eventuell sein, dass sich diese mit dem knxd beisst? Probier doch mal eine freie Adresse aus.

Sonst bin ich ratlos... :-\

Gruß

Jens

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #66 am: 17 Februar 2020, 11:55:41 »
Das ist von hier aus schlecht nachzuvollziehen. Meine einzige Idee ist, dass die physikalische KNX-Adresse ( aus dem KNXTUL-Define) irgenwie kollidiert.
Kann es eventuell sein, dass sich diese mit dem knxd beisst? Probier doch mal eine freie Adresse aus.

Sonst bin ich ratlos... :-\

Gruß

Jens


So ich melde mich mal wieder, ich glaube es liegt an meinen Unifi Switches, welche out-of-the-box kein Multicast zulassen.
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #67 am: 17 Februar 2020, 12:11:42 »
Zitat
So ich melde mich mal wieder, ich glaube es liegt an meinen Unifi Switches, welche out-of-the-box kein Multicast zulassen.

Ich wundere mich dann nur, dass die Daten bei FHEM ankommen, das läuft ja auch über Multicast bei meinem Modul. Ohne Multicast dürfte das dann auch nicht funktionieren...

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #68 am: 17 Februar 2020, 12:15:05 »
Ich wundere mich dann nur, dass die Daten bei FHEM ankommen, das läuft ja auch über Multicast bei meinem Modul. Ohne Multicast dürfte das dann auch nicht funktionieren...
Guter Punkt, ich bin mir nur nicht mehr sicher, ob beim ersten Versuch KNXD deaktiviert war. Geht empfangen via KNXD, auch wenn unter Attributen das Device von dir bereits definiert ist?
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #69 am: 26 Februar 2020, 14:54:15 »
Hast du einen MDT SCN-IP100.03? Musstest du eventuell noch Filter anpassen?

Das KNXD genehmigt sich einen Tunnel. Aber Multicast wird eventuell gefiltert?
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #70 am: 26 Februar 2020, 15:50:11 »
Den habe ich selbst nicht, aber grundsätzlich kann der Multicast.

Stehen denn der MDT und der FHEM-Rechner in unterschiedlichen Netzwerken? Dann könnte es schon Probleme geben, da wohl die Router in der Grundeinstellung Multicasts nicht in andere Netzwerke weiterleiten.

Gruß

Jens

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #71 am: 28 Februar 2020, 10:52:02 »
Den habe ich selbst nicht, aber grundsätzlich kann der Multicast.

Stehen denn der MDT und der FHEM-Rechner in unterschiedlichen Netzwerken? Dann könnte es schon Probleme geben, da wohl die Router in der Grundeinstellung Multicasts nicht in andere Netzwerke weiterleiten.
Nein gleiches Netz & VLAN.
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

Offline Porsti

  • Full Member
  • ***
  • Beiträge: 208
Antw:Kommunikation mit KNX ohne knxd
« Antwort #72 am: 28 Februar 2020, 17:33:32 »
Einfach mal zum Testen alle Gruppenadressen im IP-Router für die Kommunikation zwischen KNX und IP freigeben. Standardmäßig ist dort ein Filter aktiviert der nur erlaubte Adressen durchlässt. Diese müssen aber alle einzeln freigegeben werden.

Gruß
Porsti
____________________________________
fhem 5.9  auf Raspberry 3
Homematic HM-CC-RT-DN / HM-TC-IT-WM-W-EU / HM-SEC-SCo / HM-LC-SW1-PL2
SIGNALduino, KNX (Merten, MDT, Siemens)

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #73 am: 30 März 2020, 11:17:20 »
Einfach mal zum Testen alle Gruppenadressen im IP-Router für die Kommunikation zwischen KNX und IP freigeben. Standardmäßig ist dort ein Filter aktiviert der nur erlaubte Adressen durchlässt. Diese müssen aber alle einzeln freigegeben werden.
Hat nichts gebracht. Filter sind alle deaktiviert und im Unifi habe ich auf LAN-Seite "Enable IGMP Snooping" aktiviert und im WLAN "Enable Multicast Enhancement".
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

Offline Porsti

  • Full Member
  • ***
  • Beiträge: 208
Antw:Kommunikation mit KNX ohne knxd
« Antwort #74 am: 30 März 2020, 15:50:19 »
Hi,

ist deine Installation nicht Drahtgebunden?
Versuche doch mal mit einem Patchkabel den IP-Router und fhem zu verbinden. Habe es nach dem Filter deaktivieren sofort alles angezeigt bekommen und konnte alles Steuern.
Gehe doch mal in der ETS auf Diagnose und schicke mal ein parr befehle ins Netz und schauen ob diese bei fhem ankommen und das kannst du auch umgekehrt machen und in der ETS sehen ob fhem Daten in den Bus sendet.
Mir ist es aufgefallen da am IP Router 2 LED sind die die jeweile Seite des Netztes anzeigen und damit Zeigen wenn beide gleichzeit aufleuchten der Router die daten auf das andere Netz weiterleitet.

Gruß
Porsti
____________________________________
fhem 5.9  auf Raspberry 3
Homematic HM-CC-RT-DN / HM-TC-IT-WM-W-EU / HM-SEC-SCo / HM-LC-SW1-PL2
SIGNALduino, KNX (Merten, MDT, Siemens)

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #75 am: 08 Mai 2020, 13:40:12 »
Ich habe etwas interessantes herausgefunden:

GA: 0/6/29
* MDT Schaltkanal (12/?/?)
* Shelly mit Tasmota (0/0/4)

Wenn ich nun via FHEM KNXTUL (12/0/4) die GA 0/6/29 schalte, geht der Shelly an, aber der Schaltkanal nicht.

Wenn ich nun via FHEM TUL (KNXD (0/0/2)) die GA 0/6/29 schalte, geht der Shelly nicht an, aber der Schaltkanal an.

...




Edit Zusammenfassung:
Multicast FHEM <> Tasmota - geht
Multicast FHEM <> MDT IP-Router - geht nicht
KNXD FHEM <> MDT IP-Router - geht
KNXD FHEM <> Tasmota - geht nicht
« Letzte Änderung: 12 Mai 2020, 10:10:41 von Hauswart »
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #76 am: 12 Mai 2020, 10:57:00 »
Ich habe nochmal einen Vorgang geloggt:
2020.05.12 10:53:18 5: enter get KNX_0006029: hash: HASH(0x560060d9bb38), attributes: KNX_0006029, ?
2020.05.12 10:53:28 5: enter set KNX_0006029: hash: HASH(0x560060d9bb38), attributes: KNX_0006029, on
2020.05.12 10:53:28 5: set KNX_0006029: desired target is gad schalten, command: on, args:
2020.05.12 10:53:28 5: check value: on, gadName: schalten
2020.05.12 10:53:28 5: check value: on, gadName: schalten, model: dpt1.001, pattern: (?^i:((on)|(off)|(0?1)|(0?0))$)
2020.05.12 10:53:28 5: encode value: on, gadName: schalten
2020.05.12 10:53:28 5: encode model: dpt1.001, code: dpt1, value: on
2020.05.12 10:53:28 5: encode model: dpt1.001, code: dpt1, value: on, numval: 01, hexval: 01
2020.05.12 10:53:28 5: set KNX_0006029: cmd: on, value: on, translated: 01
2020.05.12 10:53:28 5: decode value: 01, gadName: schalten
2020.05.12 10:53:28 5: decode model: dpt1.001, code: dpt1, value: 01
2020.05.12 10:53:28 5: decode model: dpt1.001, code: dpt1, value: 01, numval: on, state: on
2020.05.12 10:53:28 5: exit set
2020.05.12 10:53:28 5: parse: process message, device-name: KNX_0006029, rd-name: schalten, gadCode: 0061d, model: dpt1.001
2020.05.12 10:53:28 5: decode value: 01, gadName: schalten
2020.05.12 10:53:28 5: decode model: dpt1.001, code: dpt1, value: 01
2020.05.12 10:53:28 5: decode model: dpt1.001, code: dpt1, value: 01, numval: on, state: on
2020.05.12 10:53:28 5: received hash (wpi): HASH(0x560060d9bb38) name: KNX_0006029, STATE: on, READING: schalten, SENDER: 00005

2020.05.12 10:53:51 5: enter set KNX_0006029: hash: HASH(0x560060d9bb38), attributes: KNX_0006029, off
2020.05.12 10:53:51 5: set KNX_0006029: desired target is gad schalten, command: off, args:
2020.05.12 10:53:51 5: check value: off, gadName: schalten
2020.05.12 10:53:51 5: check value: off, gadName: schalten, model: dpt1.001, pattern: (?^i:((on)|(off)|(0?1)|(0?0))$)
2020.05.12 10:53:51 5: encode value: off, gadName: schalten
2020.05.12 10:53:51 5: encode model: dpt1.001, code: dpt1, value: off
2020.05.12 10:53:51 5: encode model: dpt1.001, code: dpt1, value: off, numval: 00, hexval: 00
2020.05.12 10:53:51 5: set KNX_0006029: cmd: off, value: off, translated: 00
2020.05.12 10:53:51 5: decode value: 00, gadName: schalten
2020.05.12 10:53:51 5: decode model: dpt1.001, code: dpt1, value: 00
2020.05.12 10:53:51 5: decode model: dpt1.001, code: dpt1, value: 00, numval: off, state: off
2020.05.12 10:53:51 5: exit set
2020.05.12 10:53:51 5: parse: process message, device-name: KNX_0006029, rd-name: schalten, gadCode: 0061d, model: dpt1.001
2020.05.12 10:53:51 5: decode value: 00, gadName: schalten
2020.05.12 10:53:51 5: decode model: dpt1.001, code: dpt1, value: 00
2020.05.12 10:53:51 5: decode model: dpt1.001, code: dpt1, value: 00, numval: off, state: off
2020.05.12 10:53:51 5: received hash (wpi): HASH(0x560060d9bb38) name: KNX_0006029, STATE: off, READING: schalten, SENDER: 00005

Woher kommt Sender 00005= 0/0/5...

defmod KNX_0006029 KNX 0/6/29:dpt1.001:schalten 0/6/30:dpt1.001:status\
attr KNX_0006029 IODev knxtul

defmod knxtul KNXTUL 12.0.99
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #77 am: 12 Mai 2020, 11:26:33 »
Das Gerät muss doch irgendwo in deiner KNX-Installation existieren.

Du hattest ja schon mal einen Log gepostet wo KNXTUL auch von 0005 empfangen hat:
2020.01.14 22:31:13 5: Message read - CtrlByte: 11010000 Source: 0005 Dest: 0601 Data: 0080
2020.01.14 22:31:13 5: tul: dispatch C00005w0060100

Was sagt denn Deine Projektdoku?

Gruß

Jens

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #78 am: 12 Mai 2020, 20:38:37 »
Physikalische Adressen beginnen bei mir bei 12.0.0 (ETS Inside).
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #79 am: 12 Mai 2020, 21:20:11 »
Das sieht ja auch nach einer Gruppenadresse aus. Hast Du die nicht "schalten" benannt?

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #80 am: 13 Mai 2020, 10:13:33 »
Korrekt die GA heisst "schalten".

FHEM-Definition:
defmod KNX_0006029 KNX 0/6/29:dpt1.001:schalten 0/6/30:dpt1.001:status\Mit KNXD als IO geht es auch damit problemlos.

Leider habe ich in der ETS Inside keine gute Übersicht über alle GAs die meisten beginnen mit 12/6/*, eine fand ich mit 0/6/0.
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

Offline vw80

  • New Member
  • *
  • Beiträge: 26
  • vw80
Antw:Kommunikation mit KNX ohne knxd
« Antwort #81 am: 22 Mai 2020, 19:35:18 »
Hallo.
Sollte von Merten der MEG6500-013 gehen? Bekomme keine Verbindung hin. Mit Easy KNX geht es wiederrum zu schalten.

Gesendet von meinem SM-G935F mit Tapatalk


Offline Will

  • Full Member
  • ***
  • Beiträge: 160
Antw:Kommunikation mit KNX ohne knxd
« Antwort #82 am: 26 Oktober 2020, 14:07:40 »
Hallo zusammen,

habe nun meine KNX Installation am laufen, nun will ich mich mit FHEM aufschalten.

Setup:
FHem läuft auf einem PC mit Ubuntu
IP Router MDT .03

Multicast funktioniert (habe ich über eine APP getestet, mit der ich GAs ansteuern kann)

TUL
KNXIP
Initialized
Internals
Clients
KNX
DEF
1.0.190
DeviceAddress
010be
FD
7
FUUID
5f7b6fc8-f33f-6f25-cede-d2c6e57ed92e4b27
HAS_IO::Socket::Multicast
1
IPAddress
224.0.23.12
KNXIP_MSGCNT
1
KNXIP_TIME
2020-10-26 13:54:03
NAME
KNXIP
NR
14
PARTIAL
Port
3671
RAWMSG
C00005w011aa00
REFUSED
STATE
Initialized
TYPE
KNXTUL
UseDirectConnection
0


DEF
1/1/170:dpt1.001:steuern KNXIP
DEVNAME
DeckeAZ
FIRSTGADNAME
steuern
FUUID
5f7b706a-f33f-6f25-9055-6f77ded2147ca365
GETSTRING
steuern:noArg
IODev
KNXIP
KNXIP_MSGCNT
1
KNXIP_RAWMSG
C00005w011aa00
KNXIP_TIME
2020-10-26 13:54:03
LASTInputDev
KNXIP
MSGCNT
1
NAME
DeckeAZ
NR
15
NTFY_ORDER
50-DeckeAZ
SETSTRING
steuern:off,on
STATE
off
TYPE
KNX

Leider kann ich die GAs so nicht ansteuern.

Hier ein Auszug aus dem Logfile
2020.10.26 13:54:03 5: KNXTUL_sendRequest: 224.0.23.12:3671 msg: 0610053000112900bcd0000509aa010080

2020.10.26 13:54:03 5: set DeckeAZ: cmd: off, value: off, translated: 00
2020.10.26 13:54:03 5: decode value: 00, gadName: steuern
2020.10.26 13:54:03 5: decode model: dpt1.001, code: dpt1, value: 00
2020.10.26 13:54:03 5: decode model: dpt1.001, code: dpt1, value: 00, numval: off, state: off
2020.10.26 13:54:03 5: exit set
2020.10.26 13:54:03 5: KNXTUL - Read started
2020.10.26 13:54:03 5: RawMessage read: 2900bcd0000509aa010080
2020.10.26 13:54:03 5: Message read - CtrlByte: 11010000 Source: 0005 Dest: 09aa Data: 0080
2020.10.26 13:54:03 5: KNXIP: dispatch C00005w011aa00
2020.10.26 13:54:03 5: enter parse: hash: HASH(0x56411326a410) name: KNXIP, dest: 011aa, msg: C00005w011aa00
2020.10.26 13:54:03 5: parse: process message, device-name: DeckeAZ, rd-name: steuern, gadCode: 011aa, model: dpt1.001
2020.10.26 13:54:03 5: decode value: 00, gadName: steuern
2020.10.26 13:54:03 5: decode model: dpt1.001, code: dpt1, value: 00
2020.10.26 13:54:03 5: decode model: dpt1.001, code: dpt1, value: 00, numval: off, state: off
2020.10.26 13:54:03 5: received hash (wpi): HASH(0x5641132ea918) name: DeckeAZ, STATE: off, READING: steuern, SENDER: 00005
2020.10.26 13:54:03 5: exit parse
2020.10.26 13:54:03 5: enter get DeckeAZ: hash: HASH(0x5641132ea918), attributes: DeckeAZ, ?
2020.10.26 13:56:41 5: enter get DeckeAZ: hash: HASH(0x5641132ea918), attributes: DeckeAZ, ?
2020.10.26 14:06:00 5: enter get DeckeAZ: hash: HASH(0x5641132ea918), attributes: DeckeAZ, ?

Hat da irgendjemand eine Idee?

Danke schon mal vorab.

W

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #83 am: 26 Oktober 2020, 14:53:15 »
Leider noch keine konkrete Idee, aber die Kommunikation sieht eigentlich gut aus.
Kannst du mal versuchen, irgendein Gerät einfach ein oder aus zu schalten?

Offline Will

  • Full Member
  • ***
  • Beiträge: 160
Antw:Kommunikation mit KNX ohne knxd
« Antwort #84 am: 26 Oktober 2020, 20:35:30 »
Habe ich ja versucht (GA 1/1/170). Aber es kommt nichts an. In der ETS wird kein Telegramm angezeigt.

Offline Porsti

  • Full Member
  • ***
  • Beiträge: 208
Antw:Kommunikation mit KNX ohne knxd
« Antwort #85 am: 28 Oktober 2020, 15:25:20 »
Hi,

ich meine das es nur über diese Multicast Adresse mit dem MDT funktioniert: 1.1.249

Habe es so bei mir und es läuft ohne Probleme:
Internals:
   CFGFN      ./FHEM/fhem_dev_knx.cfg
   Clients    KNX
   DEF        1.1.249
   DeviceAddress 011f9
   FD         12
   FUUID      5dbd9289-f33f-75cf-2df7-caf32eff29a1a334
   HAS_IO::Socket::Multicast 1
   IPAddress  224.0.23.12
   KNXIP_MSGCNT 36171
   KNXIP_TIME 2020-10-28 15:24:19
   NAME       KNXIP
   NR         52
   PARTIAL   
   Port       3671
   RAWMSG     C00007w0220204b0
   REFUSED   
   STATE      Initialized
   TYPE       KNXTUL
   UseDirectConnection 0
Attributes:
   group      KNX
   icon       it_network@3399FF
   room       Gateway
   verbose    0
____________________________________
fhem 5.9  auf Raspberry 3
Homematic HM-CC-RT-DN / HM-TC-IT-WM-W-EU / HM-SEC-SCo / HM-LC-SW1-PL2
SIGNALduino, KNX (Merten, MDT, Siemens)

Offline Will

  • Full Member
  • ***
  • Beiträge: 160
Antw:Kommunikation mit KNX ohne knxd
« Antwort #86 am: 29 Oktober 2020, 14:51:50 »
die 1.1.249 ist die Physische ADresse.
Bei mir funktioniert das immer noch nicht.
:-(

Offline Amenophis86

  • Hero Member
  • *****
  • Beiträge: 2754
  • Anti-Statement befreite Zone ;)
Antw:Kommunikation mit KNX ohne knxd
« Antwort #87 am: 11 November 2020, 10:20:04 »
Ist hier DPT 20 eingebunden? Habe bei mir die Tage KNXD aufgesetzt und mit FHEM verbunden. Dabei habe ich festgestellt, dass DPT 20 nicht eingebunden ist. Dann bin ich durch Zufall hier gelandet und sehe, dass es eine Alternative zu KNXD ist. Jetzt frage ich mich, ob ich lieber wechseln soll :)
Aktuell dabei unser neues Haus mit KNX am einrichten. Im nächsten Schritt dann KNX mit FHEM verbinden. Allein zwei Dinge sind dabei selten: Zeit und Geld...

Offline Will

  • Full Member
  • ***
  • Beiträge: 160
Antw:Kommunikation mit KNX ohne knxd
« Antwort #88 am: 07 Dezember 2020, 10:47:27 »
Habe bei mir jetzt mal auf die Schnelle einen anderen IP Router mit dran gehängt (Siemens 5WG1 146) - funktioniert auf Anhieb.

Scheint bei mir zumindest irgendein Bug in den MDT IP Router Settings zu sein.

Gruss
W

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #89 am: 10 Dezember 2020, 09:30:14 »
Ich glaube mein Problem gefunden zu haben und zwar habe ich meinen MDT Router als Secure eingebunden... ich werde demnächst den Router nochmal neu einbinden ohne Secure.
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

Offline anatius

  • New Member
  • *
  • Beiträge: 8
Antw:Kommunikation mit KNX ohne knxd
« Antwort #90 am: 11 Dezember 2020, 23:16:25 »
Sehr cooles Paket! Und ich werde (hoffentlich) endlich den KNXD los - der benimmt sich wie eine Diva bei mir...

Problem ist allerdings, dass KNXTUL laufend FHEM zum Absturz bringt mit:

'x' outside of string in unpack at ./FHEM/00_KNXTUL.pm line 181.

Was kann ich an Infos bereitstellen, um das Problem einzugrenzen?

Danke und Grüße aus Hamburg!
Christian

Online erwin

  • Full Member
  • ***
  • Beiträge: 417
Antw:Kommunikation mit KNX ohne knxd
« Antwort #91 am: 20 Dezember 2020, 18:55:55 »
HI Anatius,
bin jetzt nicht der experte für den KNXTUL,
evtl. könntest du folgende Änderung an der KNXTUL versuchen:
statt bisher:
ab Zeile 175:                my $header_size=unpack("C",$buf);
                if (length($buf)<$header_size)
                {
                        $hash->{CHUNK}=$buf;
                        return "";
                }
soll dann so aussehen:
                my $header_size=unpack("C",$buf);
                return if ($header_size < 6); # discard chunk -  must be invalid frame   
                if (length($buf)<$header_size)
                {
                        $hash->{CHUNK}=$buf;
                        return "";
                }
danach ein shutdown restart... und warten.... Der Fehler tritt nur auf, wenn die Kommunikation mit dem KNX-Router nicht ganz rund läuft....
l.g. erwin
FHEM 5.7 auf RaspberryPI mit Busware ROT
CUNO2 V 1.44 CUNO868 SLOWRF - HMS100xx, FS20, FHT
1-Wire über ROT - 2401(iButton), 18x20, 2406, 2413 (AVR), 2450,...
MQTT-DEVICES, KNX - EIBD

Offline jw9

  • New Member
  • *
  • Beiträge: 20
Antw:Kommunikation mit KNX ohne knxd
« Antwort #92 am: 15 Januar 2021, 01:07:22 »
Hallo,

ich versuche KNXTUL einzubinden, komme aber nicht so richtig weiter. Für der ersten Test habe ich folgendes definiert:

define KNXIP KNXTUL 1.1.249
setuuid KNXIP 6000d69f-f33f-4bd1-4fe9-9d08f13388479817
attr KNXIP room KNX
attr KNXIP verbose 5

define Roll_EZ KNX 3/1/14:dpt1.008:Roll_EZ KNXIP
setuuid Roll_EZ 6000d69f-f33f-4bd1-1b50-3af1e2b1737f14f5
attr Roll_EZ IODev KNXIP
attr Roll_EZ room KNX
attr Roll_EZ webCmd on:off

Nach dem Start von FHEM steht im Logfile lediglich:

2021.01.15 00:46:34 5: KNXTUL - Read started
2021.01.15 00:46:34 5: No useable Messageheader: 0002

Wenn ich ein "set" mache, passiert rein gar nichts. Auch die LEDs am Router reagieren nicht. Im Logfile erscheint dann lediglich:
2021.01.15 00:51:13 5: No useable Messageheader: 0002
2021.01.15 00:51:17 5: KNXTUL - Write started
2021.01.15 00:51:17 5: KNXTUL: sending C w0310e00
2021.01.15 00:51:17 5: KNXTUL_encode_eibd: dst: 0310e apci: 2 datalen: 1 data: 0
2021.01.15 00:51:17 5: KNXTUL_sendGroup: dst: 0310e, msg: 6414 1 0 128

2021.01.15 00:51:17 5: KNXTUL_sendRequest: 224.0.23.12:3671 msg: 0610053000112900bcd00005190e010080

2021.01.15 00:51:17 5: KNXTUL - Read started
2021.01.15 00:51:17 5: RawMessage read: 2900bcd00005190e010080
2021.01.15 00:51:17 5: Message read - CtrlByte: 11010000 Source: 0005 Dest: 190e Data: 0080
2021.01.15 00:51:17 5: KNXIP: dispatch C00005w0310e00
2021.01.15 00:51:17 5: enter parse: hash: HASH(0x563e0cedcf78) name: KNXIP, dest: 0310e, msg: C00005w0310e00
2021.01.15 00:51:17 5: exit parse

Als Router verwende ich einen MDT SCN-IP100.03

Kann mal jemand schreiben, wie der Router konfiguriert werden muss, damit er die Pakete auch annimmt und durchreicht?

Im ETS habe ich bei Allgemein "Alle Telegramme weiterleiten" und bei Hauptlinie(IP) sowie bei Linie(KNX TP) "Gruppen weiterleiten, Physikalische filtern" eingestellt.

Wer hat eine Idee, woran es hier scheitert?

Offline jw9

  • New Member
  • *
  • Beiträge: 20
Antw:Kommunikation mit KNX ohne knxd
« Antwort #93 am: 15 Januar 2021, 22:55:51 »
Hallo nochmal,

ich habe jetzt mal in die Funktion KNXTUL_Read eine zusätzliche Debug-Zeile eingebaut. Es scheint so, dass da tatsächlich Telegramme übermittelt werden, allerdings in einem anderen Format als KNXTUL diese erwartet

Im Ruhezustand empfängt KNXTUL im Abstand von 10 Sekunden (evtl Zeitstempel?) folgende Telegramme:
2021.01.15 22:15:33 3: KNXTUL hexmessage:000274ed2a170083714009243f3e999b3332fadce3233f858c4aefdac039
2021.01.15 22:15:43 3: KNXTUL hexmessage:000274ed520d00837140092452ec5d1f5573aec6b4c13f1f2224fe231c03
2021.01.15 22:15:53 3: KNXTUL hexmessage:000274ed79ef008371400924114a34bcee6771646cbdcc40ca2e5ac33e3f
2021.01.15 22:16:03 3: KNXTUL hexmessage:000274eda177008371400924b1d827a55ee2bd1b22df22d36add20bbc6ed
2021.01.15 22:16:28 3: KNXTUL hexmessage:000274ee00f90083714009247fa2bbe56c62edf9c1c4ec1687e3f1f52534
                             061009550024000274ee00f90083714009247fa2bbe56c62edf9c1c4ec1687e3f1f52534
Die letzte Zeile zeigt, wie Wireshark die Nutzdaten anzeigt. Da hat KNXTUL offensichtlich schon 6 Bytes Header entfernt. Ausserdem kann auch Wireshark das nicht dekodieren, denn es zeigt die Nutzdaten lediglich als Raw-Data an.

Wenn KNXTUL was sendet (GA 3/1/14, wie in obigem Beispiel), dann sieht das so aus:
2021.01.15 22:15:49 5: KNXTUL - Write started
2021.01.15 22:15:49 5: KNXTUL: sending C w0310e01
2021.01.15 22:15:49 5: KNXTUL_encode_eibd: dst: 0310e apci: 2 datalen: 1 data: 1
2021.01.15 22:15:49 5: KNXTUL_sendGroup: dst: 0310e, msg: 6414 1 0 129
2021.01.15 22:15:49 5: KNXTUL_sendRequest: 224.0.23.12:3671 msg: 0610053000112900bcd00005190e010081
2021.01.15 22:15:49 5: KNXTUL - Read started
2021.01.15 22:15:49 3: KNXTUL hexmessage:2900bcd00005190e010081
2021.01.15 22:15:49 5: RawMessage read: 2900bcd00005190e010081
2021.01.15 22:15:49 5: Message read - CtrlByte: 11010000 Source: 0005 Dest: 190e Data: 0081
2021.01.15 22:15:49 5: KNXIP: dispatch C00005w0310e01
2021.01.15 22:15:49 5: enter parse: hash: HASH(0x55d844bc89c8) name: KNXIP, dest: 0310e, msg: C00005w0310e01
Dieses Telegramm kann Wireshark dekodieren und zeigt es brav als KNXnet/IP an.

Wenn ich eine Taste drücke (gleiche GA, 3/1/14), dann schaut es so aus:
2021.01.15 22:16:09 3: KNXTUL hexmessage:0000000274edb69b0083714009240000393f8377df07eab2646ce3e9880644577fa10bbdf074be1b396fef6ca479cb9636bf
2021.01.15 22:16:12 3: KNXTUL hexmessage:0000000274edc370008371400924000055f8289a40cb89724cf1b2d533021bdcab681b10953ea4229bfdc82f64a96fb1abe5
2021.01.15 22:16:15 3: KNXTUL hexmessage:0000000274edce9d0083714009240000364acc809b186a0c226b444885a06a6bbedac2c473694f272cbd475fdd9776b1970a
2021.01.15 22:16:18 3: KNXTUL hexmessage:0000000274edd92c0083714009240000e0cc35221f62f253c2accc88b5d501bd8cc6824bc3194a3aaa34ebe9a108b0586f82
                             0610095000380000000274edd92c0083714009240000e0cc35221f62f253c2accc88b5d501bd8cc6824bc3194a3aaa34ebe9a108b0586f82
Auch das kann Wireshark nicht dekodieren und stellt es als Raw-Data dar (letzte Zeile)

Auffällig ist, dass die Daten doch sehr unterschiedlich ausschauen, obwohl es in allen drei Telegrammen die gleich GA ist (abwechselnt on und off)

Sieht also ganz danach aus, als ob der Router die Telegramme ganz anders kodiert als KNXTUL. Da in den Telegrammen die GA nicht zu erkennen ist, könnte das sogar (teilweise) verschlüsselt sein.

Ideen?

Offline GammaTwin

  • Jr. Member
  • **
  • Beiträge: 85
Antw:Kommunikation mit KNX ohne knxd
« Antwort #94 am: 16 Januar 2021, 11:35:51 »
Grüße,

der Router hat in der Beschreibung folgede Begriffe "Mit IP Secure und KNX Data Secure". Ich denke, Du kannst in der ETS das Secure deaktivieren und dann mal probieren. Wenn es dann klappt, würde es an diesem Feature liegen.

Ein Versuch ist es Wert...

Offline jw9

  • New Member
  • *
  • Beiträge: 20
Antw:Kommunikation mit KNX ohne knxd
« Antwort #95 am: 19 Januar 2021, 12:34:44 »
In der Tat lag das Problem am "KNX IP Secure"

Habe jetzt die Anbindung über ein TPUART-Modul gemacht. Damit hat fhem eine direkte Anbindung an KNX, ohne dass die Pakete über LAN/WLAN gehen müssen..

 

decade-submarginal