Autor Thema: Kommunikation mit KNX ohne knxd  (Gelesen 46524 mal)

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #75 am: 08 Mai 2020, 13:40:12 »
Ich habe etwas interessantes herausgefunden:

GA: 0/6/29
* MDT Schaltkanal (12/?/?)
* Shelly mit Tasmota (0/0/4)

Wenn ich nun via FHEM KNXTUL (12/0/4) die GA 0/6/29 schalte, geht der Shelly an, aber der Schaltkanal nicht.

Wenn ich nun via FHEM TUL (KNXD (0/0/2)) die GA 0/6/29 schalte, geht der Shelly nicht an, aber der Schaltkanal an.

...




Edit Zusammenfassung:
Multicast FHEM <> Tasmota - geht
Multicast FHEM <> MDT IP-Router - geht nicht
KNXD FHEM <> MDT IP-Router - geht
KNXD FHEM <> Tasmota - geht nicht
« Letzte Änderung: 12 Mai 2020, 10:10:41 von Hauswart »
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #76 am: 12 Mai 2020, 10:57:00 »
Ich habe nochmal einen Vorgang geloggt:
2020.05.12 10:53:18 5: enter get KNX_0006029: hash: HASH(0x560060d9bb38), attributes: KNX_0006029, ?
2020.05.12 10:53:28 5: enter set KNX_0006029: hash: HASH(0x560060d9bb38), attributes: KNX_0006029, on
2020.05.12 10:53:28 5: set KNX_0006029: desired target is gad schalten, command: on, args:
2020.05.12 10:53:28 5: check value: on, gadName: schalten
2020.05.12 10:53:28 5: check value: on, gadName: schalten, model: dpt1.001, pattern: (?^i:((on)|(off)|(0?1)|(0?0))$)
2020.05.12 10:53:28 5: encode value: on, gadName: schalten
2020.05.12 10:53:28 5: encode model: dpt1.001, code: dpt1, value: on
2020.05.12 10:53:28 5: encode model: dpt1.001, code: dpt1, value: on, numval: 01, hexval: 01
2020.05.12 10:53:28 5: set KNX_0006029: cmd: on, value: on, translated: 01
2020.05.12 10:53:28 5: decode value: 01, gadName: schalten
2020.05.12 10:53:28 5: decode model: dpt1.001, code: dpt1, value: 01
2020.05.12 10:53:28 5: decode model: dpt1.001, code: dpt1, value: 01, numval: on, state: on
2020.05.12 10:53:28 5: exit set
2020.05.12 10:53:28 5: parse: process message, device-name: KNX_0006029, rd-name: schalten, gadCode: 0061d, model: dpt1.001
2020.05.12 10:53:28 5: decode value: 01, gadName: schalten
2020.05.12 10:53:28 5: decode model: dpt1.001, code: dpt1, value: 01
2020.05.12 10:53:28 5: decode model: dpt1.001, code: dpt1, value: 01, numval: on, state: on
2020.05.12 10:53:28 5: received hash (wpi): HASH(0x560060d9bb38) name: KNX_0006029, STATE: on, READING: schalten, SENDER: 00005

2020.05.12 10:53:51 5: enter set KNX_0006029: hash: HASH(0x560060d9bb38), attributes: KNX_0006029, off
2020.05.12 10:53:51 5: set KNX_0006029: desired target is gad schalten, command: off, args:
2020.05.12 10:53:51 5: check value: off, gadName: schalten
2020.05.12 10:53:51 5: check value: off, gadName: schalten, model: dpt1.001, pattern: (?^i:((on)|(off)|(0?1)|(0?0))$)
2020.05.12 10:53:51 5: encode value: off, gadName: schalten
2020.05.12 10:53:51 5: encode model: dpt1.001, code: dpt1, value: off
2020.05.12 10:53:51 5: encode model: dpt1.001, code: dpt1, value: off, numval: 00, hexval: 00
2020.05.12 10:53:51 5: set KNX_0006029: cmd: off, value: off, translated: 00
2020.05.12 10:53:51 5: decode value: 00, gadName: schalten
2020.05.12 10:53:51 5: decode model: dpt1.001, code: dpt1, value: 00
2020.05.12 10:53:51 5: decode model: dpt1.001, code: dpt1, value: 00, numval: off, state: off
2020.05.12 10:53:51 5: exit set
2020.05.12 10:53:51 5: parse: process message, device-name: KNX_0006029, rd-name: schalten, gadCode: 0061d, model: dpt1.001
2020.05.12 10:53:51 5: decode value: 00, gadName: schalten
2020.05.12 10:53:51 5: decode model: dpt1.001, code: dpt1, value: 00
2020.05.12 10:53:51 5: decode model: dpt1.001, code: dpt1, value: 00, numval: off, state: off
2020.05.12 10:53:51 5: received hash (wpi): HASH(0x560060d9bb38) name: KNX_0006029, STATE: off, READING: schalten, SENDER: 00005

Woher kommt Sender 00005= 0/0/5...

defmod KNX_0006029 KNX 0/6/29:dpt1.001:schalten 0/6/30:dpt1.001:status\
attr KNX_0006029 IODev knxtul

defmod knxtul KNXTUL 12.0.99
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #77 am: 12 Mai 2020, 11:26:33 »
Das Gerät muss doch irgendwo in deiner KNX-Installation existieren.

Du hattest ja schon mal einen Log gepostet wo KNXTUL auch von 0005 empfangen hat:
2020.01.14 22:31:13 5: Message read - CtrlByte: 11010000 Source: 0005 Dest: 0601 Data: 0080
2020.01.14 22:31:13 5: tul: dispatch C00005w0060100

Was sagt denn Deine Projektdoku?

Gruß

Jens

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #78 am: 12 Mai 2020, 20:38:37 »
Physikalische Adressen beginnen bei mir bei 12.0.0 (ETS Inside).
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #79 am: 12 Mai 2020, 21:20:11 »
Das sieht ja auch nach einer Gruppenadresse aus. Hast Du die nicht "schalten" benannt?

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #80 am: 13 Mai 2020, 10:13:33 »
Korrekt die GA heisst "schalten".

FHEM-Definition:
defmod KNX_0006029 KNX 0/6/29:dpt1.001:schalten 0/6/30:dpt1.001:status\Mit KNXD als IO geht es auch damit problemlos.

Leider habe ich in der ETS Inside keine gute Übersicht über alle GAs die meisten beginnen mit 12/6/*, eine fand ich mit 0/6/0.
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

Offline vw80

  • New Member
  • *
  • Beiträge: 26
  • vw80
Antw:Kommunikation mit KNX ohne knxd
« Antwort #81 am: 22 Mai 2020, 19:35:18 »
Hallo.
Sollte von Merten der MEG6500-013 gehen? Bekomme keine Verbindung hin. Mit Easy KNX geht es wiederrum zu schalten.

Gesendet von meinem SM-G935F mit Tapatalk


Offline Will

  • Full Member
  • ***
  • Beiträge: 160
Antw:Kommunikation mit KNX ohne knxd
« Antwort #82 am: 26 Oktober 2020, 14:07:40 »
Hallo zusammen,

habe nun meine KNX Installation am laufen, nun will ich mich mit FHEM aufschalten.

Setup:
FHem läuft auf einem PC mit Ubuntu
IP Router MDT .03

Multicast funktioniert (habe ich über eine APP getestet, mit der ich GAs ansteuern kann)

TUL
KNXIP
Initialized
Internals
Clients
KNX
DEF
1.0.190
DeviceAddress
010be
FD
7
FUUID
5f7b6fc8-f33f-6f25-cede-d2c6e57ed92e4b27
HAS_IO::Socket::Multicast
1
IPAddress
224.0.23.12
KNXIP_MSGCNT
1
KNXIP_TIME
2020-10-26 13:54:03
NAME
KNXIP
NR
14
PARTIAL
Port
3671
RAWMSG
C00005w011aa00
REFUSED
STATE
Initialized
TYPE
KNXTUL
UseDirectConnection
0


DEF
1/1/170:dpt1.001:steuern KNXIP
DEVNAME
DeckeAZ
FIRSTGADNAME
steuern
FUUID
5f7b706a-f33f-6f25-9055-6f77ded2147ca365
GETSTRING
steuern:noArg
IODev
KNXIP
KNXIP_MSGCNT
1
KNXIP_RAWMSG
C00005w011aa00
KNXIP_TIME
2020-10-26 13:54:03
LASTInputDev
KNXIP
MSGCNT
1
NAME
DeckeAZ
NR
15
NTFY_ORDER
50-DeckeAZ
SETSTRING
steuern:off,on
STATE
off
TYPE
KNX

Leider kann ich die GAs so nicht ansteuern.

Hier ein Auszug aus dem Logfile
2020.10.26 13:54:03 5: KNXTUL_sendRequest: 224.0.23.12:3671 msg: 0610053000112900bcd0000509aa010080

2020.10.26 13:54:03 5: set DeckeAZ: cmd: off, value: off, translated: 00
2020.10.26 13:54:03 5: decode value: 00, gadName: steuern
2020.10.26 13:54:03 5: decode model: dpt1.001, code: dpt1, value: 00
2020.10.26 13:54:03 5: decode model: dpt1.001, code: dpt1, value: 00, numval: off, state: off
2020.10.26 13:54:03 5: exit set
2020.10.26 13:54:03 5: KNXTUL - Read started
2020.10.26 13:54:03 5: RawMessage read: 2900bcd0000509aa010080
2020.10.26 13:54:03 5: Message read - CtrlByte: 11010000 Source: 0005 Dest: 09aa Data: 0080
2020.10.26 13:54:03 5: KNXIP: dispatch C00005w011aa00
2020.10.26 13:54:03 5: enter parse: hash: HASH(0x56411326a410) name: KNXIP, dest: 011aa, msg: C00005w011aa00
2020.10.26 13:54:03 5: parse: process message, device-name: DeckeAZ, rd-name: steuern, gadCode: 011aa, model: dpt1.001
2020.10.26 13:54:03 5: decode value: 00, gadName: steuern
2020.10.26 13:54:03 5: decode model: dpt1.001, code: dpt1, value: 00
2020.10.26 13:54:03 5: decode model: dpt1.001, code: dpt1, value: 00, numval: off, state: off
2020.10.26 13:54:03 5: received hash (wpi): HASH(0x5641132ea918) name: DeckeAZ, STATE: off, READING: steuern, SENDER: 00005
2020.10.26 13:54:03 5: exit parse
2020.10.26 13:54:03 5: enter get DeckeAZ: hash: HASH(0x5641132ea918), attributes: DeckeAZ, ?
2020.10.26 13:56:41 5: enter get DeckeAZ: hash: HASH(0x5641132ea918), attributes: DeckeAZ, ?
2020.10.26 14:06:00 5: enter get DeckeAZ: hash: HASH(0x5641132ea918), attributes: DeckeAZ, ?

Hat da irgendjemand eine Idee?

Danke schon mal vorab.

W

Offline jewuma

  • New Member
  • *
  • Beiträge: 44
Antw:Kommunikation mit KNX ohne knxd
« Antwort #83 am: 26 Oktober 2020, 14:53:15 »
Leider noch keine konkrete Idee, aber die Kommunikation sieht eigentlich gut aus.
Kannst du mal versuchen, irgendein Gerät einfach ein oder aus zu schalten?

Offline Will

  • Full Member
  • ***
  • Beiträge: 160
Antw:Kommunikation mit KNX ohne knxd
« Antwort #84 am: 26 Oktober 2020, 20:35:30 »
Habe ich ja versucht (GA 1/1/170). Aber es kommt nichts an. In der ETS wird kein Telegramm angezeigt.

Offline Porsti

  • Full Member
  • ***
  • Beiträge: 208
Antw:Kommunikation mit KNX ohne knxd
« Antwort #85 am: 28 Oktober 2020, 15:25:20 »
Hi,

ich meine das es nur über diese Multicast Adresse mit dem MDT funktioniert: 1.1.249

Habe es so bei mir und es läuft ohne Probleme:
Internals:
   CFGFN      ./FHEM/fhem_dev_knx.cfg
   Clients    KNX
   DEF        1.1.249
   DeviceAddress 011f9
   FD         12
   FUUID      5dbd9289-f33f-75cf-2df7-caf32eff29a1a334
   HAS_IO::Socket::Multicast 1
   IPAddress  224.0.23.12
   KNXIP_MSGCNT 36171
   KNXIP_TIME 2020-10-28 15:24:19
   NAME       KNXIP
   NR         52
   PARTIAL   
   Port       3671
   RAWMSG     C00007w0220204b0
   REFUSED   
   STATE      Initialized
   TYPE       KNXTUL
   UseDirectConnection 0
Attributes:
   group      KNX
   icon       it_network@3399FF
   room       Gateway
   verbose    0
____________________________________
fhem 5.9  auf Raspberry 3
Homematic HM-CC-RT-DN / HM-TC-IT-WM-W-EU / HM-SEC-SCo / HM-LC-SW1-PL2
SIGNALduino, KNX (Merten, MDT, Siemens)

Offline Will

  • Full Member
  • ***
  • Beiträge: 160
Antw:Kommunikation mit KNX ohne knxd
« Antwort #86 am: 29 Oktober 2020, 14:51:50 »
die 1.1.249 ist die Physische ADresse.
Bei mir funktioniert das immer noch nicht.
:-(

Offline Amenophis86

  • Hero Member
  • *****
  • Beiträge: 2753
  • Anti-Statement befreite Zone ;)
Antw:Kommunikation mit KNX ohne knxd
« Antwort #87 am: 11 November 2020, 10:20:04 »
Ist hier DPT 20 eingebunden? Habe bei mir die Tage KNXD aufgesetzt und mit FHEM verbunden. Dabei habe ich festgestellt, dass DPT 20 nicht eingebunden ist. Dann bin ich durch Zufall hier gelandet und sehe, dass es eine Alternative zu KNXD ist. Jetzt frage ich mich, ob ich lieber wechseln soll :)
Aktuell dabei unser neues Haus mit KNX am einrichten. Im nächsten Schritt dann KNX mit FHEM verbinden. Allein zwei Dinge sind dabei selten: Zeit und Geld...

Offline Will

  • Full Member
  • ***
  • Beiträge: 160
Antw:Kommunikation mit KNX ohne knxd
« Antwort #88 am: 07 Dezember 2020, 10:47:27 »
Habe bei mir jetzt mal auf die Schnelle einen anderen IP Router mit dran gehängt (Siemens 5WG1 146) - funktioniert auf Anhieb.

Scheint bei mir zumindest irgendein Bug in den MDT IP Router Settings zu sein.

Gruss
W

Offline Hauswart

  • Developer
  • Sr. Member
  • ****
  • Beiträge: 850
Antw:Kommunikation mit KNX ohne knxd
« Antwort #89 am: 10 Dezember 2020, 09:30:14 »
Ich glaube mein Problem gefunden zu haben und zwar habe ich meinen MDT Router als Secure eingebunden... ich werde demnächst den Router nochmal neu einbinden ohne Secure.
1. Installation:
KNX, Tasmota (KNX), Sonos, Unifi

2. Installation:
HM-CFG-USB, Unifi (, SIGNALduino 868, MySensors, SIGNALduino 433)

 

decade-submarginal