Autor Thema: Anfängerhilfe für Oregon-Sensoren via RFXTRXUSB  (Gelesen 2236 mal)

Offline hixhupf

  • New Member
  • *
  • Beiträge: 29
Anfängerhilfe für Oregon-Sensoren via RFXTRXUSB
« am: 05 März 2013, 21:18:24 »
Ich bin etwas verloren. Ich habe einen RFXTRXUSB erfolgreich in Betrieb genommen und sehe auch die Daten meiner Sensoren im FHEM:

(siehe Anhang / see attachement)


Ich kann die einzelnen Sensoren anklicken und sehe auch entsprechende Details, welche Werte er liefert usw:

(siehe Anhang / see attachement)


Aber wie kann ich nun
a) die Daten loggen und
b) per plot darstellen?

Ich habe mit FileLog rumgespielt, aber es tauchen keine Daten in den Log-Dateien auf, sie bleiben leer. Und ich finde auch keine hilfreiche Doku dazu :( Ich wäre euch dankbar, wenn mich jemand "aufs Pferd setzt".

Danke!
Sascha

Offline Willi

  • Sr. Member
  • ****
  • Beiträge: 594
Aw: Anfängerhilfe für Oregon-Sensoren via RFXTRXUSB
« Antwort #1 am: 06 März 2013, 06:44:59 »
Hallo,

Du hast zwei Möglichkeiten:
-1- Nutzung von autocreate. Dann werden die Geräte von FHEM selbständig angelegt, die Filelog erstellt und auch die Weblinks (sofern für die Geräte vorgesehen).
-2- Du schaust Dir commandref.html an und machst alles selbst.

Ich bevorzuge generell -1-. Da geht fast alles automatisch. Das klappt bei meinen Modules insbesondere bei den meisten Oregon-Sensoren gut.

Wenn bei Dir schon autocreate eingeschaltet war (ist default), dann ist bei Dir etwas schief gelaufen.
Evtl. hast Du du die Geräte nach dem autocreate nicht per "rename" umbenannt? rename berücksichtigt auch die Umbenennung der Filelogs sowie Weblinks.

Lösche Deine Geräte aus der Konfiguration uns starte FHEM neu. Dann sollte alles automatisch gehen.
Vorher aber am besten ein update.

Welche FHEM-Version hast Du? Sieht Du aus der Log, z.B:
2013.03.06 06:51:07 0: Server started with 271 defined entities (version Fhem 5.3 (DEVELOPMENT), $Id: fhem.pl 2852 2013-03-04 19:58:34Z rudolfkoenig $, pid 30037)

Etwas anderes: Der Battery-Status bei Deinem Sensor Aussen ist nicht richtig. Entweder ein Bug oder Du hast eine alter FHEM-Version. Wenn dies nach dem update noch auftaucht, bitte die Details zu dem Sensor, z.B. ein "list Aussen" in der Kommandozeile.

Grüße

Willi

@Alle: Bitte beim Posten eines Problems generell die Version von FHEM aus der Log angeben. Das macht es einfacher das Problem nachzuvollziehen.
FHEM@Q600(debian) mit DS9490R (1Wire) | FHEM@Sheevaplug(debian) mit RFXCOM-Receiver(80002), CULv3 & USB-WDE1 | FHEM@odroid mit CULv2 & RFXtrx433

Offline hixhupf

  • New Member
  • *
  • Beiträge: 29
Aw: Anfängerhilfe für Oregon-Sensoren via RFXTRXUSB
« Antwort #2 am: 06 März 2013, 07:28:13 »
Hallo Willi,

danke für den Tipp, ich hatte keinen autocreate-Eintrag für FileLog mehr. Hab das wieder eingefügt, die Devices rausgelöscht und neu gestartet. Sie wurden wieder erkannt und loggen jetzt brav in ihre Dateien.

FHEM ist bei mir übrigens 5.3, die Batterieanzeige vom Außensensor wird auch dargestellt:

(siehe Anhang / see attachement)


Du hast mir damit sehr geholfen, vielen Dank!

Gruß,
Sascha