Autor Thema: [gelöst] Probleme bei Wertvorgabe eines S_HEATER Nodes  (Gelesen 1431 mal)

Offline uwetaz

  • New Member
  • *
  • Beiträge: 14
Hallo,

ich habe bisher mysensor nodes u.a. mit Beispielen aus mysensors 2.3.2 gebaut. DimmableLight als Aktor funktioniert z.B. prima. Ich konnte Sollwerte von FHEM in 0-100% vorgeben. Jetzt wollte ich mal einen Node mit S_HEATER realisieren. Der Node wird von FHEM erkannt. Ähnlich wie beim DimmableLight habe ich vom Node ein V_HVAC_SETPOINT_HEAT senden lassen. Dann erschien in FHEM ähnlich wie bei DimmableLight unter readings ein Wert; hier halt hvacsetpointheat1.
Wenn ich aber einen Wert vorgeben will, gibt es Probleme:
gesendet in FHEM:
set MYSENSOR_12 hvacsetpointheat1 25
Fehlermeldung:
Unknown argument hvacsetpointheat1, choose one of clear flash fwType reboot time attrTemplate

So richtig schlau werde ich aus dieser Meldung nicht.
Habe ich was übersehen was ich im Sketch von DimmableLight noch machen muss, damit von FHEM ein Wert vorgegeben werden kann? Oder funktioniert die Vorgabe hier anders?

Ich habe auch mal versucht in die Innereien von FHEM abzutauchen, obwohl ich mich nicht wirklich auskenne und auch keine Perl Erfahrung habe:
In 10_MYSENSORS_DEVICE.pm ist mir aufgefallen, dass bei type => "hvacsetpointheat" kein val definiert ist wie bei percentage.

Vielleicht hat jemand einen Tipp?

Danke für eine Antwort.

Grüße
Uwe
« Letzte Änderung: 18 April 2021, 21:09:38 von uwetaz »

Offline frober

  • Sr. Member
  • ****
  • Beiträge: 901
  • Was man nicht kann, kann man lernen...
Antw:Probleme bei Wertvorgabe eines S_HEATER Nodes
« Antwort #1 am: 17 April 2021, 22:19:05 »
Wenn das ein "freier" Wert ist, den du senden kannst, wird das Set nicht automatisch angelegt.

Du musst das per attr definieren.

Oben im Eingabefeld von Fhem.

Als Bsp.:
attr MYSENSOR_X setReading_hvacsetpointheat1 textField

Dann kannst du es auch unter Set auswählen.
Raspi 3b mit Raspbian Stretch und relativ aktuellem Fhem,  FS20, LGW, PCA301, MySensors mit RS485(CAN-Receiver), etc.,
einiges umgesetzt, vieles in Planung :-)

********************************************
...man wächst mit der Herausforderung...

Offline uwetaz

  • New Member
  • *
  • Beiträge: 14
Antw:Probleme bei Wertvorgabe eines S_HEATER Nodes
« Antwort #2 am: 18 April 2021, 21:02:04 »
Hallo frober,

das hat geholfen. Vielen Dank!
Jetzt kommt der setpoint auch im Sketch/Node an.

Nur zum Verständnis: Heißt "freier Wert" dass in 10_MYSENSORS_DEVICE.pm unter "my %static_types"/ "S_HEATER" / receives => [] leer ist?

« Letzte Änderung: 18 April 2021, 21:04:52 von uwetaz »

Offline frober

  • Sr. Member
  • ****
  • Beiträge: 901
  • Was man nicht kann, kann man lernen...
Antw:Probleme bei Wertvorgabe eines S_HEATER Nodes
« Antwort #3 am: 18 April 2021, 21:55:59 »

Nur zum Verständnis: Heißt "freier Wert" dass in 10_MYSENSORS_DEVICE.pm unter "my %static_types"/ "S_HEATER" / receives => [] leer ist?

Nein, wenn receives leer ist, kannst du mWn nichts an die Node senden.

Etwas weiter unten
my %static_mappings = (
  V_TEMP        => { type => "temperature" },
  V_HUM         => { type => "humidity" },
  V_STATUS      => { type => "status", val => { 0 => 'off', 1 => 'on' }},
  V_PERCENTAGE  => { type => "percentage", range => { min => 0, step => 1, max => 100 }},

Hier siehst du, dass manche mappings vordefiniert sind -> on|off, 0 - 100

D.h. wenn in receives etwas steht und hier nichts vordefiniert ist, kannst du "alles" senden.

Raspi 3b mit Raspbian Stretch und relativ aktuellem Fhem,  FS20, LGW, PCA301, MySensors mit RS485(CAN-Receiver), etc.,
einiges umgesetzt, vieles in Planung :-)

********************************************
...man wächst mit der Herausforderung...

 

decade-submarginal