Autor Thema: PanStamp: Start mit Problemen  (Gelesen 8400 mal)

Offline TeeVau

  • Developer
  • Full Member
  • ****
  • Beiträge: 452
PanStamp: Start mit Problemen
« am: 25 Oktober 2013, 16:12:00 »
Hallo,

meine PanStamps sind angekommen und diese wollte ich mit FHEM benutzen. Nach einem etwas holprigen Start bin ich jetzt an einer Stelle, an der ich nicht weiter komme.
Bis lang erfolgreich gemacht:
  • PanStamp mit PanStick an FBF angeschlossen. Funktion des Modem sketch vorher am PC per Terminamprog. geprüft (Modem ready!)
  • PanStick an FHEM eingebunden nach der Anleitung im Wiki. Hat geklappt.
  • 2. PanStamp mit dem Sketch bininps programmiert, keine Fehlermeldung
  • bininps PanStamp wurde auch bei FHEM erkannt. Zuerst hatte ich Autocreate disabled, deshalb gab es Probleme.
  • Autocreate aktiviert, das Device SWAP_F0 wurde angelegt.
  • Ich sehe wie im Device SWAP_F0 jede Sekunde die Readings 0C und 0D neu beschrieben werden

Meine Probleme sind jetzt noch:
  • Im Log sieht es so aus, als würde ständig versucht werden per Autocreate das Device neu anzulegen.
  • Ich kann das Sendeintervall im Register 0A nicht ändern, generell sieht aus so aus, dass der 2. PanStamp keine Befehle annimmt

Log:
2013.10.25 14:59:23 3: SWAP Unknown device FF, please define it
2013.10.25 14:59:23 2: autocreate: define SWAP_F0 SWAP FF
2013.10.25 14:59:23 3: SWAP_F0: I/O device is panStick
2013.10.25 14:59:23 2: autocreate: define FileLog_SWAP_F0 FileLog ./log/SWAP_F0-%Y.log SWAP_F0
2013.10.25 15:35:23 2: no device xml found for productcode
2013.10.25 15:35:34 3: SWAP Unknown device 00, please define it
2013.10.25 15:35:46 3: SWAP Unknown device 00, please define it
2013.10.25 15:35:55 2: no device xml found for productcode 0
2013.10.25 15:35:55 2: no device xml found for productcode 0
2013.10.25 15:36:38 3: SWAP Unknown device 00, please define it
2013.10.25 15:36:49 3: SWAP Unknown device 00, please define it
2013.10.25 15:37:11 3: SWAP Unknown device F0, please define it
2013.10.25 15:37:11 2: autocreate: define FileLog_SWAP_F0 FileLog ./log/SWAP_F0-%Y.log SWAP_F0
2013.10.25 15:38:24 3: SWAP Unknown device 00, please define it
2013.10.25 15:38:34 3: SWAP Unknown device 00, please define it
2013.10.25 15:38:55 3: SWAP Unknown device 00, please define it
2013.10.25 15:39:05 3: SWAP Unknown device 00, please define it
2013.10.25 15:39:37 3: SWAP Unknown device 0F, please define it
2013.10.25 15:39:37 2: autocreate: define SWAP_0F SWAP 0F
2013.10.25 15:39:37 3: SWAP_0F: I/O device is panStick
2013.10.25 15:39:37 2: autocreate: define FileLog_SWAP_0F FileLog ./log/SWAP_0F-%Y.log SWAP_0F
2013.10.25 15:40:52 3: SWAP Unknown device 00, please define it
2013.10.25 15:41:02 2: no device xml found for productcode A100FF0C0000
2013.10.25 15:41:02 2: no device xml found for productcode A100FF0C0000
2013.10.25 15:43:00 3: SWAP Unknown device 00, please define it
2013.10.25 15:43:10 3: SWAP Unknown device 00, please define it
2013.10.25 15:43:22 2: no device xml found for productcode
2013.10.25 15:43:43 3: SWAP Unknown device 00, please define it
2013.10.25 15:45:54 3: SWAP Unknown device 00, please define it
2013.10.25 15:47:41 3: SWAP Unknown device F0, please define it
2013.10.25 15:47:41 2: autocreate: define FileLog_SWAP_F0 FileLog ./log/SWAP_F0-%Y.log SWAP_F0
2013.10.25 15:48:13 3: SWAP Unknown device F0, please define it
2013.10.25 15:48:13 2: autocreate: define FileLog_SWAP_F0 FileLog ./log/SWAP_F0-%Y.log SWAP_F0
2013.10.25 15:48:49 3: SWAP Unknown device 00, please define it
2013.10.25 15:48:59 3: SWAP Unknown device 00, please define it
2013.10.25 15:53:05 3: SWAP Unknown device 00, please define it
2013.10.25 15:53:15 3: SWAP Unknown device 00, please define it
2013.10.25 15:54:50 3: SWAP Unknown device 79, please define it
2013.10.25 15:54:50 2: autocreate: define SWAP_79 SWAP 79 FF0C0000
2013.10.25 15:54:50 3: SWAP_79: I/O device is panStick
2013.10.25 15:54:50 2: no device xml found for productcode FF0C0000
2013.10.25 15:54:50 2: no device xml found for productcode FF0C0000
2013.10.25 15:54:50 2: autocreate: define FileLog_SWAP_79 FileLog ./log/SWAP_79-%Y.log SWAP_79
2013.10.25 15:55:50 2: no device xml found for productcode 600FF0D00000000000000000000000000000000
2013.10.25 15:55:50 2: no device xml found for productcode 600FF0D00000000000000000000000000000000
2013.10.25 15:56:37 3: SWAP Unknown device 00, please define it
2013.10.25 15:57:59 3: SWAP Unknown device F0, please define it
2013.10.25 15:57:59 2: autocreate: define FileLog_SWAP_F0 FileLog ./log/SWAP_F0-%Y.log SWAP_F0
2013.10.25 15:58:10 3: SWAP Unknown device 00, please define it
2013.10.25 15:59:20 3: SWAP Unknown device 00, please define it
2013.10.25 16:01:05 3: SWAP Unknown device 00, please define it
FHEM 5.8 dev (virtualisiert) / FBF 7390 (CUL 868MHz V 1.51 / panStick (AVR1))
FS20: fs20di,fs20pira,fs20sm8,fs20st2,fs20tfk,fs20ue1,fs20ws1
panStamp (AVR1): RGB Multi von ext23, 1W-DSxxxx, I/O Sketch, Spritzpumpe
Multimedia: Panasonic TV (VIERA), Kodi, Yamaha RX-V781, LMS
Sonstiges: XiaomiFlowerSen

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 21283
Antw:PanStamp: Start mit Problemen
« Antwort #1 am: 25 Oktober 2013, 17:25:33 »
es gibt mit bestimmten panstamp lib versionen das problem das ein wert von FFFF in 0A zum überlauf führt und dann ununterbrochen gesendet wird. ich habe im fhem modul versucht das abzufangen. das funktioniert aber leider auf manchen langsamen host systemen nicht weil der panstamp so schnell sendet das fhem so mit dem abarbeiten beschäftigt ist das es selber nicht zum senden kommt.

zur abhilfe kannst du in deinem sketch in setup ganz am anfang  ein EEPROM.write(EEPROM_TX_INTERVAL, 0x55);
EEPROM.write(EEPROM_TX_INTERVAL+1, 0x55);
einfügen und noch mal flashen.

wenn der sketch damit ein mal durchgelaufen ist kannst du diese beiden zeilen wieder entfernen und noch mal flashen.

gruss
  andre

edit: die aktuelle panstamp lib aus dem svn repository sollte das problem eigentlich nicht mehr haben. ich kann aber gerade nicht nachschauen.
« Letzte Änderung: 25 Oktober 2013, 18:06:53 von justme1968 »
hue, tradfri, alexa-fhem, homebridge-fhem, LightScene, readingsGroup, …

https://github.com/sponsors/justme-1968

Offline TeeVau

  • Developer
  • Full Member
  • ****
  • Beiträge: 452
Antw:PanStamp: Start mit Problemen
« Antwort #2 am: 28 Oktober 2013, 07:43:44 »
Hallo André,

danke für den Tipp mit dem Bug, das scheint bei mir das Problem gewesen zu sein. Habe deinen Tipp erfolgreich ausprobiert und im Wiki dokumentiert. Habe auch einen Hinweis auf aktiviertem autocreate dazu gemacht, das hat mich selber noch mal 10 Minuten gekostet. Aber ich hatte vom überfliegen der Threads im Kopf, dass da was mit autocreate war.
Ich habe die Lib von der Webseite runterladen, dass es einen svn gibt wusste ich gar nicht. Gucke ich mir mal an.
Kann ich den Bug immer nur mit einem ganz frischen Panstamp provozieren? Ich kann mal testen ob das mit der Lib aus dem Svn behoben ist.
Wird allerdings etwas dauern, bin diese Woche geschäftlich unterwegs und danach 6 Tage im Urlaub.

Danke für Hilfe, Tobias
FHEM 5.8 dev (virtualisiert) / FBF 7390 (CUL 868MHz V 1.51 / panStick (AVR1))
FS20: fs20di,fs20pira,fs20sm8,fs20st2,fs20tfk,fs20ue1,fs20ws1
panStamp (AVR1): RGB Multi von ext23, 1W-DSxxxx, I/O Sketch, Spritzpumpe
Multimedia: Panasonic TV (VIERA), Kodi, Yamaha RX-V781, LMS
Sonstiges: XiaomiFlowerSen

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 21283
Antw:PanStamp: Start mit Problemen
« Antwort #3 am: 28 Oktober 2013, 08:54:10 »
hallo tobias,

das problem tritt immer dann auf wenn das eeprom auf FFFF initialisiert ist. das ist normalerweise nur bei neuen panstamps so so lange das register nicht ein mal gesetzt wurde.

im prinzip geht auch alles ohne autocreate aber gerade bei den batterie betriebenen sensoren gibt es im default sketch nach dem start jeweils nur 3 sekunden in denen der panstamp auf kommandos hört. das von hand zu machen ist dann nicht ganz einfach als einsteiger. autocreate ist also auf jeden fall zu empfehlen.

danke für die wiki ergänzung.

gruss
  andre
hue, tradfri, alexa-fhem, homebridge-fhem, LightScene, readingsGroup, …

https://github.com/sponsors/justme-1968

Offline fidel

  • Full Member
  • ***
  • Beiträge: 289
Antw:PanStamp: Start mit Problemen
« Antwort #4 am: 29 Oktober 2013, 23:42:57 »
Hallo,

könntet ihr die Links für alle Arduino Librarys die man für den Panstamp benötigt vielleicht auch im Wiki zusammenfassen?
Ich habe mir alles einzeln zusammen gesucht und ich denke es wäre gerade für Einsteiger sehr hilfreich.

Beschreibung Panstamp über Arduino flashen: https://code.google.com/p/panstamp/wiki/firststeps
Panstamp-Library: http://www.panstamp.com/downloads
IR Lib: https://github.com/shirriff/Arduino-IRremote
DMX Lib: ???

Wo ich die DMX Lib finde ist mir leider immer noch ein Rätsel^^

Grüße
Steven

Fhem 5.6 auf Cubietruck,CUL,CUL_TCM97001,FritzBox7390,HMLAN,CUL_HM_HM_OU-16LED,CUL_HM_HM_SEC_SC,CUL_HM_HM_LC_SW4,CUL_HM_HM_RT_DN,HUEBridge,HUEDevice,Panstick,Panstamp (binouts,rgddriver mit dht22),PHTV,Yamaha-AVR,Withings,ELV-IPS, etc...

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 21283
Antw:PanStamp: Start mit Problemen
« Antwort #5 am: 29 Oktober 2013, 23:52:54 »
die dmx lib findest du hier: http://www.mathertel.de/Arduino/DMXSerial.aspx.

den wiki artikel wollte ich aktualisieren wenn das irboard und der sketch endgültig so weit sind.

wie wäre es wenn du das was du zusammengesucht hast direkt auch ins wiki schreibst :)

gruss
  andre
hue, tradfri, alexa-fhem, homebridge-fhem, LightScene, readingsGroup, …

https://github.com/sponsors/justme-1968

Offline fidel

  • Full Member
  • ***
  • Beiträge: 289
Antw:PanStamp: Start mit Problemen
« Antwort #6 am: 30 Oktober 2013, 00:25:38 »
Ahh Super... Danke

Ja kann ich machen. Ich benötige nur noch nen Wiki Accout.
Ich hatte mal einen beantragt. Es kam aber leider nie eine Rückmeldung.

Ich habe zur Zeit auch Probleme mit meinen Panstamps. Irgendwie wird ein rgb-driver Board nicht erkannt. Das vermeintlich defekte habe ich dann mit dem Modem Sketch geflasht und an die Fritze gesteckt und es läuft und den ehemaligen Panstick mit dem rgbdriver, also sollte es wahrscheinlich nicht am Board liegen.
Autocreate ist aktiviert. Und in fhem passiert gar nichts.

Daher will ich Arduino nocheinmal neu installieren und ihn nochmal neu flashen.
Oder kann es etwas anderes sein als du oben schon geschrieben hast?

Fhem 5.6 auf Cubietruck,CUL,CUL_TCM97001,FritzBox7390,HMLAN,CUL_HM_HM_OU-16LED,CUL_HM_HM_SEC_SC,CUL_HM_HM_LC_SW4,CUL_HM_HM_RT_DN,HUEBridge,HUEDevice,Panstick,Panstamp (binouts,rgddriver mit dht22),PHTV,Yamaha-AVR,Withings,ELV-IPS, etc...

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 21283
Antw:PanStamp: Start mit Problemen
« Antwort #7 am: 30 Oktober 2013, 07:49:37 »
wieviele panstamps hast du?

gibt es welche die erkannt und angelegt werden?

mach mal bitte ein list auf das panstick device.

was steht im log bei verbose 5 wenn fhem startet oder der panstick abgezogen und eingesteckt wird?

gruss
  andre
hue, tradfri, alexa-fhem, homebridge-fhem, LightScene, readingsGroup, …

https://github.com/sponsors/justme-1968

Offline ph1959de

  • Hero Member
  • *****
  • Beiträge: 1074
Antw:PanStamp: Start mit Problemen
« Antwort #8 am: 30 Oktober 2013, 08:27:58 »
Ja kann ich machen. Ich benötige nur noch nen Wiki Accout.
Ich hatte mal einen beantragt. Es kam aber leider nie eine Rückmeldung.
Schreib mal Soulman an (Details hier: http://www.fhemwiki.de/wiki/Benutzer:Soulman). Ich vermute mal, Du hattest Dich an  Arno gewendet - der ist aber wohl in letzter Zeit nicht mehr sehr aktiv im Wiki.

Gruß, Peter
Aktives Mitglied des FHEM e.V. | Moderator im Forenbereich "Wiki"
[Fhem auf BeagleBone Black (Debian) | FS20, FHT (CUL) | HomeMatic (HMLAN+HMUART) | PCA301 (JeeLink)...]

Offline fidel

  • Full Member
  • ***
  • Beiträge: 289
Antw:PanStamp: Start mit Problemen
« Antwort #9 am: 30 Oktober 2013, 18:10:27 »
Hallo Andre,

ich habe 3 PanStamps, einen als Stick(Modem) und 2x das RGB-Driver Board.

Es war auch schonmal alles angelegt und lief. Irgendwann konnte ich eines der Boards nicht mehr richtig steuern und der LED Streifen leuchtete immer rot, ging hin und wieder für kurze Zeit aus und leuchtete dann weiter rot.

Wenn ich meinen vorhandenes noch funktionierendes RGB Board auskommentiere, wird es auch gleich wieder von autocreate angelegt.

Im Anhang erstmal das list auf den Panstick

Der Rest kommt gleich...



Fhem 5.6 auf Cubietruck,CUL,CUL_TCM97001,FritzBox7390,HMLAN,CUL_HM_HM_OU-16LED,CUL_HM_HM_SEC_SC,CUL_HM_HM_LC_SW4,CUL_HM_HM_RT_DN,HUEBridge,HUEDevice,Panstick,Panstamp (binouts,rgddriver mit dht22),PHTV,Yamaha-AVR,Withings,ELV-IPS, etc...

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 21283
Antw:PanStamp: Start mit Problemen
« Antwort #10 am: 30 Oktober 2013, 18:22:41 »
wenn das andere board geht dann ist auch der stick und die fhem seite ok.

eine erste vermutung: irgendetwas ist mit den adress registern durcheinander und die einstellungen passen nicht mehr zum panstick.

um alles auf default zurück zu setzen in setup() am anfang ein eepromToFactoryDefaults() einfügen, sketch kompilieren, flashen und ein mal laufen lassen. dann die zeile wieder entfernen und noch mal flashen. dann den panstamp wie einen neuen in betrieb nemen.

gruss
  andre
hue, tradfri, alexa-fhem, homebridge-fhem, LightScene, readingsGroup, …

https://github.com/sponsors/justme-1968

Offline fidel

  • Full Member
  • ***
  • Beiträge: 289
Antw:PanStamp: Start mit Problemen
« Antwort #11 am: 30 Oktober 2013, 18:47:07 »
Volltreffer...
Funzt wieder  ;D Vielen vielen Dank

Einen Wiki Account habe ich jetzt auch und werde es demnächst alles mal zusammen fassen.

Ansonsten brennt mir schon seit langem die Frage wann die Erweiterung auf 4 oder 5 Kanäle kommt, mit der zum Beispiel auch die Farbe bei einschalten eingestellt werden kann (ich meine nicht stromlos machen).

Viele Grüße
Steven

Fhem 5.6 auf Cubietruck,CUL,CUL_TCM97001,FritzBox7390,HMLAN,CUL_HM_HM_OU-16LED,CUL_HM_HM_SEC_SC,CUL_HM_HM_LC_SW4,CUL_HM_HM_RT_DN,HUEBridge,HUEDevice,Panstick,Panstamp (binouts,rgddriver mit dht22),PHTV,Yamaha-AVR,Withings,ELV-IPS, etc...

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 21283
Antw:PanStamp: Start mit Problemen
« Antwort #12 am: 30 Oktober 2013, 18:54:28 »
das mit der farbe bei soft on ist im prinzip fertig.

die 4/5 kanäle sind angefangen aber das ist zum teil blöd zum testen ohne das board. mein letzter stand war das die boards letzte woche endlich beim zoll waren. mehr weiss ich leider auch nicht.

gruss
  andre
hue, tradfri, alexa-fhem, homebridge-fhem, LightScene, readingsGroup, …

https://github.com/sponsors/justme-1968

Offline fidel

  • Full Member
  • ***
  • Beiträge: 289
Antw:PanStamp: Start mit Problemen
« Antwort #13 am: 30 Oktober 2013, 19:06:02 »
Soll ich dir meins zur Verfügung stellen?
Fhem 5.6 auf Cubietruck,CUL,CUL_TCM97001,FritzBox7390,HMLAN,CUL_HM_HM_OU-16LED,CUL_HM_HM_SEC_SC,CUL_HM_HM_LC_SW4,CUL_HM_HM_RT_DN,HUEBridge,HUEDevice,Panstick,Panstamp (binouts,rgddriver mit dht22),PHTV,Yamaha-AVR,Withings,ELV-IPS, etc...

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 21283
Antw:PanStamp: Start mit Problemen
« Antwort #14 am: 30 Oktober 2013, 19:26:42 »
ein board zum testen zu haben würde das ganze tatsächlich beschleunigen.

gruss
  andre
hue, tradfri, alexa-fhem, homebridge-fhem, LightScene, readingsGroup, …

https://github.com/sponsors/justme-1968