Autor Thema: [patch] ZWave - Logging when no parse matches  (Gelesen 1627 mal)

hschmitt

  • Gast
[patch] ZWave - Logging when no parse matches
« am: 16 Mai 2014, 10:51:11 »
Hallo,

wenn eine ZWave Nachricht eingeht, wird nur ein log generiert, falls gar kein parse für die Command Klasse existiert.
Mit diesem patch wird ebenfalls geloggt, falls parse existieren, aber keiner matched.

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25487
Antw:[patch] ZWave - Logging when no parse matches
« Antwort #1 am: 16 Mai 2014, 11:31:29 »
Ich bin z.Zt. der Ansicht, dass nicht jeder "Mist" was per ZWave gemeldet wird, als Event von FHEM bereitgestellt werden muss. Ich schlage also vor, diese Meldung auf verbose 4 zu protokollieren, da koennen geneigte Entwickler es sehen, der normale Anwender kriegt es aber nicht mit.

hschmitt

  • Gast
Antw:[patch] ZWave - Logging when no parse matches
« Antwort #2 am: 16 Mai 2014, 16:43:57 »
Da stimme ich voll zu. Ich hatte zum Testen den Loglevel auf 3 gesetzt und vergessen es wieder auf 4 zu ändern. Danke für die Korrektur.
Zu den Logleveln habe ich nun diese Auflistung gefunden:
http://www.fhemwiki.de/wiki/FHEM_Command_Beispiele#attr_global_verbose_X
Ich werde es von der Seite http://www.fhemwiki.de/wiki/How_to_write_a_patch verlinken.

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25487
Antw:[patch] ZWave - Logging when no parse matches
« Antwort #3 am: 16 Mai 2014, 18:49:32 »
Die verbose Werte sind natuerlich in http://fhem.de/commandref.html#verbose dokumentiert.
Die wiki Seite entspricht mehr oder weniger einer Uebersetzung.

 

decade-submarginal