Autor Thema: Log: 2: Attempt to write to disconnected device.  (Gelesen 2590 mal)

Offline Markus M.

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2903
Log: 2: Attempt to write to disconnected device.
« am: 07 September 2014, 19:34:35 »
Mein Logfile füllt sich aktuell hiermit:

2014.09.07 19:06:51 2: Attempt to write to disconnected device.
2014.09.07 19:08:54 2: Attempt to write to disconnected device.
2014.09.07 19:10:57 2: Attempt to write to disconnected device.
2014.09.07 19:13:00 2: Attempt to write to disconnected device.
2014.09.07 19:15:03 2: Attempt to write to disconnected device.
2014.09.07 19:17:06 2: Attempt to write to disconnected device.
2014.09.07 19:19:09 2: Attempt to write to disconnected device.

Der Fehler entsteht wohl in DevIo.pm (DevIo_Expect, zumindest habe ich den Schnipsel dort gefunden), was mich aber irritiert ist, dass erst gar kein Device Name mitgegeben wird.
Wie finde ich ohne diesen kleinen aber entscheidenden Hinweis raus, woher der Fehler kommt?

Viele Grüsse,
Markus
FHEM dev + HomeBridge + Lenovo Flex15 + HM-CFG-USB + RFXtrx433 + Fritz!Box 7590/7580/546E

HM Aktor/Sensor/Winmatic/Keymatic/Thermostat, HUE, Netatmo Weather/Security/Heating, Xiaomi AirPurifier/Vacuum, Withings Aura/BPM/Cardio/Go/Pulse/Thermo, VSX828, Harmony, Siro ERB15LE
https://paypal.me/mm0

Offline Icinger

  • Developer
  • Hero Member
  • ****
  • Beiträge: 1356
Antw:Log: 2: Attempt to write to disconnected device.
« Antwort #1 am: 07 September 2014, 19:43:40 »
Welches Gerät auch immer das ist, es hat mit ziemlicher Sicherheit den STATE "disconnected" oder "closed".

Mach mal ein
list STATE=[Dd]isconnectedDas sollte die alle Devices anzeigen, die das im STATE stehn haben.
Evt. auch mit
list STATE=[Cc]losedprobieren, ECMD hat zB opened/closed, statt connected/disconnected.
Verwende deine Zeit nicht mit Erklärungen. Die Menschen hören (lesen) nur, was sie hören (lesen) wollen. (c) Paulo Coelho

Offline Markus M.

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2903
Antw:Log: 2: Attempt to write to disconnected device.
« Antwort #2 am: 07 September 2014, 20:53:36 »
Aha! Danke für den Befehl.
Scheint mein Receiver zu sein der gerade vom Strom getrennt ist.
PIONEERAVR_checkConnection() versucht in der Standardeinstellung alle 2 Minuten, die Verbindung herzustellen.
Die Frage ist dann allerdings noch, wieso der Name nicht mit $hash durchgeht.
FHEM dev + HomeBridge + Lenovo Flex15 + HM-CFG-USB + RFXtrx433 + Fritz!Box 7590/7580/546E

HM Aktor/Sensor/Winmatic/Keymatic/Thermostat, HUE, Netatmo Weather/Security/Heating, Xiaomi AirPurifier/Vacuum, Withings Aura/BPM/Cardio/Go/Pulse/Thermo, VSX828, Harmony, Siro ERB15LE
https://paypal.me/mm0