Netatmo Modul - 38_netatmo.pm (Support)

Begonnen von Markus M., 17 Mai 2016, 12:37:34

Vorheriges Thema - Nächstes Thema

stebar_

Zitat von: Migul47 am 09 Dezember 2023, 14:18:43Hallo,

kann es sein, das es noch immer nicht richtig läuft?
Bei mir läuft es seit gestern Abend ohne Probleme.

Markus M.

Sollte wieder laufen.
 
Link ist auch angepasst.

Und hat zufällig noch jemand bei dem FHEM ohne Token blockiert einen Logauszug mit Einträgen ws dabei passiert ist?
FHEM dev + HomeBridge + Lenovo Flex15 + HM-CFG-USB + RFXtrx433 + Fritz!Box 7590/7580/546E

HM Aktor/Sensor/Winmatic/Keymatic/Thermostat, HUE, Netatmo Weather/Security/Heating, Xiaomi AirPurifier/Vacuum, Withings Aura/BPM/Cardio/Go/Pulse/Thermo, VSX828, Harmony, Siro ERB15LE
https://paypal.me/mm0

m.zielinski

Ich habe noch so ein Log welches Fhem um ca 7:20 blockiert hatte - das dürfte sich sogar nachstellen lassen wenn du beim Token-Generator einfach deutlich zu wenig anhakst.

Das Log ist natürlich noch länger aber ich habe keine anderen relevanten Zeilen gesehen - nur dass die Meldungen nachher im Sekundentakt kommen, so dass fhem ansonsten nicht mehr nutzbar ist...

Nachdem ich aber die Tokens neu generiert habe und neu in die Definition gegeben läuft es jetzt.


2023.12.10 07:21:42 2: Netatmo: json message error: invalid_grant
2023.12.10 07:21:43 2: Netatmo: json message error: invalid_grant
2023.12.10 07:21:43 1: Netatmo: No access token was found! (getDevices)
2023.12.10 07:21:43 2: Netatmo: json message error: invalid_grant
2023.12.10 07:21:43 1: Netatmo: No access token was found! (getHomecoachs)
2023.12.10 07:21:43 2: Netatmo: json message error: invalid_grant
2023.12.10 07:21:43 2: Netatmo: json message error: invalid_grant
2023.12.10 07:21:43 1: Netatmo: No access token was found! (getDevices)
2023.12.10 07:21:44 2: Netatmo: json message error: invalid_grant
2023.12.10 07:21:44 1: Netatmo: No access token was found! (getHomecoachs)
2023.12.10 07:21:44 2: Netatmo: json message error: invalid_grant
2023.12.10 07:21:44 2: Netatmo: json message error: invalid_grant
2023.12.10 07:21:44 1: Netatmo: No access token was found! (getDevices)
2023.12.10 07:21:44 2: Netatmo: json message error: invalid_grant
2023.12.10 07:21:44 1: Netatmo: No access token was found! (getHomecoachs)
2023.12.10 07:21:45 2: Netatmo: json message error: invalid_grant
2023.12.10 07:21:45 2: Netatmo: json message error: invalid_grant
2023.12.10 07:21:45 1: Netatmo: No access token was found! (getDevices)
2023.12.10 07:21:45 2: Netatmo: json message error: invalid_grant
2023.12.10 07:21:45 1: Netatmo: No access token was found! (getHomecoachs)
2023.12.10 07:21:45 2: Netatmo: json message error: invalid_grant
2023.12.10 07:21:46 2: Netatmo: json message error: invalid_grant
2023.12.10 07:21:46 1: Netatmo: No access token was found! (getDevices)
2023.12.10 07:21:46 2: Netatmo: json message error: invalid_grant
2023.12.10 07:21:46 1: Netatmo: No access token was found! (getHomecoachs)

Markus M.

Zitat von: m.zielinski am 10 Dezember 2023, 10:31:07Ich habe noch so ein Log welches Fhem um ca 7:20 blockiert hatte - das dürfte sich sogar nachstellen lassen wenn du beim Token-Generator einfach deutlich zu wenig anhakst.
Bei mir blockiert hiermit nichts merkbar, hat es aber ehrlich gesagt auch vorher nicht.
Kannst du den Anhang mal bei dir ausprobieren?
Damit sollte bei invalid_grant recht schnell alles länger pausieren
FHEM dev + HomeBridge + Lenovo Flex15 + HM-CFG-USB + RFXtrx433 + Fritz!Box 7590/7580/546E

HM Aktor/Sensor/Winmatic/Keymatic/Thermostat, HUE, Netatmo Weather/Security/Heating, Xiaomi AirPurifier/Vacuum, Withings Aura/BPM/Cardio/Go/Pulse/Thermo, VSX828, Harmony, Siro ERB15LE
https://paypal.me/mm0

Dirk070

Hallo zusammen,

zurück aus dem Urlaub und selbes Problem. Vielen Dank für die neue Version, läuft jetzt mit neuem Token.
Aber meine 3 Sensoren liefern die aktuelle Temperatur nicht, das Reading wird nicht aktualisert.

Genauer, hier aus der Basisstation:
Aktuell sind: IODev, active, pressure_abs, pressure_trend, temp_max, temp_min und temp_trend
Alter Timestamp bei: co2, humidity, noise, pressure und temperature

Im Token hatte ich alle READ's markiert.

Hat jemand eine Idee?

Danke und schöne Grüße
Dirk


tomcat.x

@ Dirk070: Der Status der Station ist aber "ok"? Ich hatte auch einen komischen Effekt. Nach dem Update des Moduls habe ich zuerst das Account-Gerät wieder "enabled", Token eingetragen und erfolgreich verbunden (STATE "Connected"). Danach dann die Geräte der Stationen wieder enabled. 2-3 Tage später ist mir dann aufgefallen, dass Werte nicht aktuell waren. Ich kann nur noch behaupten, dass das direkt nach dem Aktivieren funktioniert hat. Das Reading "active" stand bei den Sensoren dann auf "delayed update", verzögert aber für mehr als einen Tag. Account war immer noch "Connected". Dann habe ich beim Account und allen Sensoren nacheinander manuell ein "Update" gemacht. Seitdem funktioniert alles.
FHEM: 6.1 auf Raspi 3, Raspbian (Buster), Perl v5.28.1
Sender/Empfänger: 2 x CULv3, Duofern Stick, HM-MOD-RPI-PCB
Gateways: FRITZ!Box 6591 (OS: 7.57), Trädfri, ConBee 2,  piVCCU, OpenMQTTGateway
Sensoren/Aktoren: FRITZ!DECT, FS20, FHT, HMS, HomeMatic, Trädfri, DuoFern, NetAtmo

Dirk070

#1431
Danke für den Tipp, ich habe bei allen Sensoren ein GET UPDATE durchgeführt, leider hat sich nichts geändert.

Merkwürdig, dass nur einige Readings nicht aktualisiert werden.

ACTIVE steht bei der Innenstation auf OK. Bei den anderen Sensoren (Temperatur mit Batterie) jedoch auf DEAD.

Markus M.

Was sagen denn die Internals status und im Account Device network?
FHEM dev + HomeBridge + Lenovo Flex15 + HM-CFG-USB + RFXtrx433 + Fritz!Box 7590/7580/546E

HM Aktor/Sensor/Winmatic/Keymatic/Thermostat, HUE, Netatmo Weather/Security/Heating, Xiaomi AirPurifier/Vacuum, Withings Aura/BPM/Cardio/Go/Pulse/Thermo, VSX828, Harmony, Siro ERB15LE
https://paypal.me/mm0

Dirk070

#1433
Zitat von: Markus M. am 13 Dezember 2023, 19:15:14Was sagen denn die Internals status und im Account Device network?

Network im Account ist ,,ok" und Status auch ,,ok".
Status bei allen anderen ebenfalls ,,ok".

UPDATE: Im Log habe ich Fehlermeldungen "Cannot fork: Cannot allocate memory" gefunden. Daher habe ich FHEM per Shutdown beendet und auch den Docker-Container im Anschluss gestoppt.
Nach dem Start gab es auf den "Problem"-Readings Werte, die mehrere Jahre zurücklagen. Nach 1-2 Stunden habe ich erneut kontrolliert und jetzt sind die Readings alle aktuell.

maci

Habe eine Nachricht per Mail von Netatmo bekommen mit folgenden Inhalt:
Lieber Netatmo-Entwickler,
wenn Sie heute ein Access Token über den zugehörigen Endpunkt https://api.netatmo.com/oauth2/token aktualisieren, antworten die Netatmo-Server mit einem Token-Paar: einem Access Token und einem Refresh Token.

Wenn das vorherige Zugriffstoken noch gültig ist, ist das neu zurückgegebene Zugriffstoken identisch, hat aber eine um 3 Stunden verlängerte Ablaufzeit.

Das Refresh Token wird nicht erneuert.

Ab dem 29. Mai 2024 wird sich dieses Verhalten ändern, um den Empfehlungen des OAuth2 Authorization Framework RFC (Abschnitt 10.4) zu entsprechen und die Sicherheit der Daten unserer Nutzer zu verbessern.

Bei der Aktualisierung der Token werden sich das Zugriffstoken und das Aktualisierungs-Token von den vorherigen unterscheiden und die alten Token werden ungültig.

 

Was bedeutet das für Sie?

Wenn Sie die von der API bei der Aktualisierung Ihrer Token zurückgegebenen Token bereits speichern, hat diese Änderung keine Auswirkungen auf Sie.

Wenn Sie die Token bei der Aktualisierung nicht aktualisieren, werden Ihre Benutzer abgemeldet, da die alten Token ungültig werden.

Wenn Sie für einen bestimmten Benutzer dasselbe Token an verschiedenen Stellen gespeichert haben (z. B. in einer Anwendung und ihrem Widget), müssen Sie über eine Möglichkeit verfügen, diese zu synchronisieren, da das neue Token für die gesamte Anwendung gilt.

Übersetzt mit DeepL.com (kostenlose Version)

Ich frage mich nun was das künftig für die Abfrage heisst?
Fhem auf Dell Thinclient, Fhem auf Raspebrry Pi4,
UniPi Vers. 1.1 mit Raspberry Pi3, 1wire USB Adapter mit OWX
Netatmo Wetterstation + Regenmesser + Netatmo Thermostat
Homematic mit HMLan

Markus M.

Zitat von: maci am 02 März 2024, 12:48:04Ich frage mich nun was das künftig für die Abfrage heisst?

Wenn im Modul alles so funktioniert wie schon seit der letzten Login-Änderung vorgesehen: gar nichts ;)
FHEM dev + HomeBridge + Lenovo Flex15 + HM-CFG-USB + RFXtrx433 + Fritz!Box 7590/7580/546E

HM Aktor/Sensor/Winmatic/Keymatic/Thermostat, HUE, Netatmo Weather/Security/Heating, Xiaomi AirPurifier/Vacuum, Withings Aura/BPM/Cardio/Go/Pulse/Thermo, VSX828, Harmony, Siro ERB15LE
https://paypal.me/mm0

maci

Fhem auf Dell Thinclient, Fhem auf Raspebrry Pi4,
UniPi Vers. 1.1 mit Raspberry Pi3, 1wire USB Adapter mit OWX
Netatmo Wetterstation + Regenmesser + Netatmo Thermostat
Homematic mit HMLan

Rainer H.

Hallo

mir ist aufgefallen das seit ein paar Tagen? Die Daten nie älter als 3-5sec. sind - mit der Netatmo App. Fhem ruft aber nur alle x Minuten ab. Könnte man das nicht auch auf die 3-5 sec bringen? Um das z.B für die Windgeschindigkeit zum einfahren einer Markise zu nutzen.

Wie seht ihr das?

Grüße Rainer

tomcat.x

Zitat von: Rainer H. am 12 März 2024, 19:32:01Fhem ruft aber nur alle x Minuten ab.

Es gibt doch das Attribut "interval", hast Du damit schon experimentiert? Oder geht Deine Frage in Richtung Erfahrungen damit? Ich habe das nicht geändert. In der Commandref habe ich nicht gefunden, wie es dann gesetzt ist. Aber wie Du schreibst, sind es ein paar Minuten. Nach aktuellen Prüfungen der Geräte wohl mehr als 10 oder es gab keine Änderungen. Auch ist mir nicht klar, ob das Attribut im Account Gerät auf alle anderen wirkt oder nur dort.

Zitat von: Rainer H. am 12 März 2024, 19:32:01Um das z.B für die Windgeschindigkeit zum einfahren einer Markise zu nutzen.

Ich mache das. Aber es hängt natürlich davon ab, wie kritisch die Position der Markise ist bzw. wie empfindlich sie ist, ob man da sehr schnell auf den Wind reagieren muss.

Viele Grüße
Thomas
FHEM: 6.1 auf Raspi 3, Raspbian (Buster), Perl v5.28.1
Sender/Empfänger: 2 x CULv3, Duofern Stick, HM-MOD-RPI-PCB
Gateways: FRITZ!Box 6591 (OS: 7.57), Trädfri, ConBee 2,  piVCCU, OpenMQTTGateway
Sensoren/Aktoren: FRITZ!DECT, FS20, FHT, HMS, HomeMatic, Trädfri, DuoFern, NetAtmo

tomcat.x

Wo ich jetzt mal mit dem "interval" rumgespielt habe: Man kann es minimal auf 300 setzen ....
FHEM: 6.1 auf Raspi 3, Raspbian (Buster), Perl v5.28.1
Sender/Empfänger: 2 x CULv3, Duofern Stick, HM-MOD-RPI-PCB
Gateways: FRITZ!Box 6591 (OS: 7.57), Trädfri, ConBee 2,  piVCCU, OpenMQTTGateway
Sensoren/Aktoren: FRITZ!DECT, FS20, FHT, HMS, HomeMatic, Trädfri, DuoFern, NetAtmo