Autor Thema: Zwei CULs  (Gelesen 10563 mal)

Offline Zrrronggg!

  • Hero Member
  • *****
  • Beiträge: 2362
    • www.fresse.de
Zwei CULs
« am: 01 Februar 2013, 15:34:51 »
Muss selber auch mal was fragen.

Betreibe bisher einen CUL V2 868 für FHT, Fs20 etc.

sieht in conf, so aus:

define CUL1 CUL /dev/ttyUSB0 2234

Will jetzt einen weitern CUL (V3 mit 433) für Intertechno zusätzlich anschliessen (die Umschaltnummer geht nicht, weil mien CULV2 nicht genug Mem für Intertechno hat und auch weil die Rechweite vermutlich nicht hinkommt)

Folgende Fragen:

1.  wie sage ich FHEM, das es da ein weiters CUL am USB gibt?
Ich würde ja denken:

  define CUL2 CUL /dev/ttyUSB1

Aber wie unterscheidet dann FHEM, welches CUL welches ist.  Also ich meine:
Angenommen ich habe das so konfiguriert und ziehe dann beide CULs ab und stecke sie wieder an, was hindert dann den HOST bzw FHEM z.b. das 433 CUL
als CUL1 zu verwenden?

2.  Das Intertechnomodul schaltet ja normal einen CUL kurz vor'm Senden auf 433 Mhz und danach wieder auf 868 Mhz. Da ich aber ein CUL 433 verwende, ist die Umschaltung auf 868 gar nicht nötig. Wie verhindere ich das? Oder schaltet wird durch das FHEM Intertechnomodul das CUL auf 433 geschaltet und danach wider auf das was immer eigentlich eingestellt ist?
FHEM auf Linkstation Mini, CUL 868 SlowRF, 2xCUL 868 RFR, CUL 433 für IT, 2xHMLAN-Configurator mit VCCU, ITV-100 Repeater, Sender und Aktoren von FHT, FS20, S300, HM, IT, RSL

Offline Martin Fischer

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 2130
    • www.fischer-net.de/
Aw: Zwei CULs
« Antwort #1 am: 01 Februar 2013, 16:03:32 »
> Aber wie unterscheidet dann FHEM, welches CUL welches ist.  Also ich meine:
> Angenommen ich habe das so konfiguriert und ziehe dann beide CULs ab und stecke
> sie wieder an, was hindert dann den HOST bzw FHEM z.b. das 433 CUL
> als CUL1 zu verwenden?

normalerweise steuert man das via udev regeln. das problem dabei ist aber das dirk (busware.de) dem CUL keine serial mit auf den weg gibt, so dass man seitens des OS schon nicht unterscheiden kann.

ein CUL v3.2 sowie ein CUL v2.1 liefern via 'lsusb' vollkommen identische ausgaben. einzig die bus und device nummer unterscheiden sich:
root@matrix:~# lsusb -s 002:005 -vv > foo1
root@matrix:~# lsusb -s 002:006 -vv > foo2
root@matrix:~# diff foo1 foo2
2c2
< Bus 002 Device 005: ID 03eb:204b Atmel Corp. LUFA USB to Serial Adapter Project
---
> Bus 002 Device 006: ID 03eb:204b Atmel Corp. LUFA USB to Serial Adapter Project

so wie ich das im moment sehe, gibt es keine möglichkeit, es sei denn FHEM kann über die firmware was "drehen". wobei das dann ja eigentlich auch schon zu spät ist, da das device ja schon an einen usb-port gebunden ist.

hier hilft aus meiner sicht nur, dirk darum zu bitten, CULs eine "serial" zu spendieren. keine ahnung ob man das auch nachträglich flashen kann.

oder es gibt eine andere möglichkeit, die selbst mir nicht bekannt ist.

martin
--
Admin, Developer, Gründungsmitglied des FHEM e.V.

Offline Zrrronggg!

  • Hero Member
  • *****
  • Beiträge: 2362
    • www.fresse.de
Aw: Zwei CULs
« Antwort #2 am: 01 Februar 2013, 16:11:20 »
THX...


Es bleibt so gesehen vermutlich nur, das irgendwie mit zeitlicher Staffelung bzw. "rumprobieren" beim Einstecken zu erledigen. Seufz.
FHEM auf Linkstation Mini, CUL 868 SlowRF, 2xCUL 868 RFR, CUL 433 für IT, 2xHMLAN-Configurator mit VCCU, ITV-100 Repeater, Sender und Aktoren von FHT, FS20, S300, HM, IT, RSL

Offline Martin Fischer

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 2130
    • www.fischer-net.de/
Aw: Zwei CULs
« Antwort #3 am: 01 Februar 2013, 16:17:55 »
oder halt mal dirk tostmann ansprechen (ist auch hier im forum) ob man da irgendwie (nachträglich) was zur unterscheidung "drehen" kann.

sonst hätte ich auch keine idee, ausser CUL und CUNO oder CUL an zwei rechnern.. aber das steht alles kostenmäßig nicht in relation zu einer simplen serial id. :-(

martin
--
Admin, Developer, Gründungsmitglied des FHEM e.V.

Offline tostmann

  • Developer
  • Full Member
  • ****
  • Beiträge: 291
Aw: Zwei CULs
« Antwort #4 am: 01 Februar 2013, 17:09:01 »
Das geht mit udev-Rules, aka:

cat /etc/udev/rules.d/85-cul.rules
KERNEL=="ttyACM*", ATTRS{product}=="CUL868", SYMLINK+="cul868-%b"

Bitte mal im Forum suchen da das schon oft besprochen wurde ...

Offline Martin Fischer

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 2130
    • www.fischer-net.de/
Aw: Zwei CULs
« Antwort #5 am: 01 Februar 2013, 18:34:51 »
danke dirk. sowas hatte ich zwar auch im kopf, denn ich mache das mit meinem smargo triple reader mit 3 ftdi schnittstellen ebenfalls so, bzw. so ähnlich. '%b' setzt in diesem fall die bus-id.

die frage von zrrronggg war:

> Angenommen ich habe das so konfiguriert und ziehe dann beide CULs ab und stecke
> sie wieder an, was hindert dann den HOST bzw FHEM z.b. das 433 CUL
> als CUL1 zu verwenden?

und das ist mit '%b' meiner meinung nach nicht möglich.

gruss martin
--
Admin, Developer, Gründungsmitglied des FHEM e.V.

Offline Zrrronggg!

  • Hero Member
  • *****
  • Beiträge: 2362
    • www.fresse.de
Aw: Zwei CULs
« Antwort #6 am: 01 Februar 2013, 21:12:14 »
Rein praktisch kann ich folgendes berichten, weil eben ausprobiert.

2 CULS (1x V2 mit 1.44  868 Mhz und 1x V3 mit 1.51 43 Mhz) an einen USB Hub.
V2 steckte schon und der neue 433 nachgesteckt, in cfg definiert und cfg save... passt.

Beide haben bisher auch nach 2-3 Reboots immer die "richtige" Reihenfolge.

D.H. ich befasse mich mit dem Problem erstmal nicht, weil es bisher im normalen Betrieb nicht auftritt. Kann Zufall sein.
Und so oft richtig an und abstecken oder HOST rebooten mach ich ja nicht.
FHEM auf Linkstation Mini, CUL 868 SlowRF, 2xCUL 868 RFR, CUL 433 für IT, 2xHMLAN-Configurator mit VCCU, ITV-100 Repeater, Sender und Aktoren von FHT, FS20, S300, HM, IT, RSL

Offline Zrrronggg!

  • Hero Member
  • *****
  • Beiträge: 2362
    • www.fresse.de
Aw: Zwei CULs
« Antwort #7 am: 01 Februar 2013, 21:15:58 »
Zitat
sonst hätte ich auch keine idee, ausser CUL und CUNO oder CUL an zwei rechnern.. aber das steht alles kostenmäßig nicht in relation zu einer simplen serial id. :-(


Da hatte ich auch schon dran gedacht, weil ich meine LinkStation sogar 2x habe und auch beide laufen (Die Dinger ksoten ja nix, weder beim grbraucht auf ebay schiessen noch die 9 Watt Strom). Ich lege mir blöderweise nur mit dem USB Treiber bei der 2ten die Karten. Und fhem2fehm nur dafür wollte ich mir auch nicht geben.

Aber wie gesagt: Erstmal gehts auch so.




FHEM auf Linkstation Mini, CUL 868 SlowRF, 2xCUL 868 RFR, CUL 433 für IT, 2xHMLAN-Configurator mit VCCU, ITV-100 Repeater, Sender und Aktoren von FHT, FS20, S300, HM, IT, RSL

Offline Martin Fischer

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 2130
    • www.fischer-net.de/
Aw: Zwei CULs
« Antwort #8 am: 01 Februar 2013, 21:20:42 »
> Beide haben bisher auch nach 2-3 Reboots immer die "richtige" Reihenfolge.

danke für die test..

aber dennoch würde es mich interessieren ob ich mit meiner theorie mit "%b" zu deiner ursprünglichen frage richtig liege..

also wenn du noch ein paar testreihen fahren willst...

gruss martin
--
Admin, Developer, Gründungsmitglied des FHEM e.V.

Offline Reinerlein

  • Developer
  • Hero Member
  • ****
  • Beiträge: 2134
Aw: Zwei CULs
« Antwort #9 am: 04 Februar 2013, 08:37:22 »
Hallo,

ich hatte das bei mir über die folgende udev-Regeln gelöst, da sich die Produktkennungen unterscheiden:
pi@raspberrypi /etc/udev/rules.d $ cat 10-cul.rules
ATTRS{product}=="CUL868",KERNEL=="ttyACM*",SYMLINK +="cul868"
ATTRS{product}=="CUL433",KERNEL=="ttyACM*",SYMLINK +="cul433"


Damit werden dann zusätzliche symlinks unter /dev angelegt, die "cul868" oder eben "cul433" heißen...

Grüße Reinerlein

Offline Tobias

  • Developer
  • Hero Member
  • ****
  • Beiträge: 3958
Aw: Zwei CULs
« Antwort #10 am: 04 Februar 2013, 10:20:19 »
ich hänge am selben Problem, ich habe 3 CUL´s V3 mit 868Mhz (FS20, MAX, HM) und kann die per udev nicht auseinanderhalten :(

bekommt man die Serial auch über CULFW rein? oder nur Hardwareseitig?
FHEM auf ASRock J3455-ITX im 19" Rack mit Homematic, MAX, PCA301, Panstamps, RPi für BLE Bodenfeuchtesenoren, Text2Speech.
Maintainer der Module: Text2Speech, TrashCal, MediaList

Meine Projekte auf https://github.com/tobiasfaust
u.a. PumpControl v2: allround Bewässerungssteuerung mit ESP und FHEM

Offline rudolfkoenig

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 25412
Aw: Zwei CULs
« Antwort #11 am: 04 Februar 2013, 11:43:28 »
Ein Seriennummer muss ueber USB mitgeteilt werden, sowas muss also in der USB-Bibliothek (culfw verwendet lufa) implementiert sein. MWn gibt es entsprechende Funktionalitaet in lufa, aber nicht jeder der in den unterschiedlichen CULs verwendeten Chips hat einen eindeutigen Seriennummer.
Ich habe diesen Seriennummer mal versucht fuer die MAC-Adresse der CUN zu verwenden, bin aber nicht mehr sicher, ob erfolgreich oder nicht.

Eine Alternative waere einen Nummer/Namen im EEPROM abzulegen, und diesen in der lufa Bibliothek zu verwenden.

Offline matze1986

  • Jr. Member
  • **
  • Beiträge: 58
Aw: Zwei CULs
« Antwort #12 am: 15 April 2013, 20:25:48 »
hat schon jemand ein Lösung gefunden?
habe auch 2 CULS mit 868MHz und bekomme beide nicht voneinander unterschieden.

Offline justme1968

  • Developer
  • Hero Member
  • ****
  • Beiträge: 21283
Aw: Zwei CULs
« Antwort #13 am: 15 April 2013, 20:30:44 »
vielleicht ist es ja eine dumme frage... aber warum muss man sie auseinanderhalten wenn sie doch gleich sind ?

gruss
  andre
hue, tradfri, alexa-fhem, homebridge-fhem, LightScene, readingsGroup, …

https://github.com/sponsors/justme-1968

Offline matze1986

  • Jr. Member
  • **
  • Beiträge: 58
Aw: Zwei CULs
« Antwort #14 am: 15 April 2013, 20:35:56 »
Da ich mir derzeit nicht sicher bin, welcher nun welcher ist.
An dem einen habe ich noch keine Antenne, (der soll rfmode MAX haben)

Der andere hat eine Antenne und ist der bisherige im SlowRF Mode.

Ich habe beide wie folgt in der fhem.cfg wie folgt definiert

define CUL_0 CUL /dev/ttyACM0@9600 1034
attr CUL_0 rfmode SlowRF

define CUL_1 CUL /dev/ttyACM0@9600 1234
attr CUL_1 rfmode MAX


Jedoch empfange ich keine Daten mehr. Egal welchen ich jetzt SlowRF setze, (auch wenn beide SlowRF sind geht es nicht)



Der Log schreibt je nach dem in welchen mode ich sie habe mal

2013.04.15 20:23:34 0: Server shutdown
2013.04.15 20:23:36 1: Including fhem.cfg
2013.04.15 20:23:37 3: telnetPort: port 7073 opened
2013.04.15 20:23:38 3: WEB: port 8083 opened
2013.04.15 20:23:38 3: WEBphone: port 8084 opened
2013.04.15 20:23:38 3: WEBtablet: port 8085 opened
2013.04.15 20:23:39 1: Including fhem.cfg
2013.04.15 20:23:39 3: Opening CUL_0 device /dev/ttyACM0
2013.04.15 20:23:40 3: Setting CUL_0 baudrate to 9600
2013.04.15 20:23:40 3: CUL_0 device opened
2013.04.15 20:23:40 3: CUL_0: Possible commands: BCFiAZEGMRTVWXefmltux
2013.04.15 20:23:40 2: Setting CUL fhtid from 1234 to 1034
2013.04.15 20:23:40 3: Opening CUL_1 device /dev/ttyACM0
2013.04.15 20:23:40 3: Setting CUL_1 baudrate to 9600
2013.04.15 20:23:40 3: CUL_1 device opened
2013.04.15 20:23:40 1: telnetPort: Can't open server port at 7073: Address already in use. Exiting.
2013.04.15 20:23:40 3: CUL_1: Possible commands: BCFiAZEGMRTVWXefmltux
2013.04.15 20:23:40 2: Setting CUL fhtid from 1034 to 1234
2013.04.15 20:23:41 1: Including ./log/fhem.save
2013.04.15 20:23:41 1: usb create starting
2013.04.15 20:23:43 3: Opening CUL device /dev/ttyACM1
2013.04.15 20:23:43 3: Setting CUL baudrate to 9600
2013.04.15 20:23:43 3: CUL device opened
2013.04.15 20:23:43 1: define CUL_1 CUL /dev/ttyACM1@9600 1134
2013.04.15 20:23:43 3: Opening CUL device /dev/ttyAMA0
2013.04.15 20:23:43 3: Can't open /dev/ttyAMA0: Permission denied
2013.04.15 20:23:43 1: usb create end




oder
2013.04.15 20:25:00 1: /dev/ttyACM0 disconnected, waiting to reappear
2013.04.15 20:25:05 3: Setting CUL_1 baudrate to 9600
2013.04.15 20:25:05 1: /dev/ttyACM0 reappeared (CUL_1)
2013.04.15 20:25:05 3: CUL_1: Possible commands: BCFiAZEGMRTVWXefmltux
2013.04.15 20:25:06 1: /dev/ttyACM0 disconnected, waiting to reappear
2013.04.15 20:25:11 3: Setting CUL_1 baudrate to 9600
2013.04.15 20:25:11 1: /dev/ttyACM0 reappeared (CUL_1)
2013.04.15 20:25:11 3: CUL_1: Possible commands: BCFiAZEGMRTVWXefmltux
2013.04.15 20:25:37 1: /dev/ttyACM0 disconnected, waiting to reappear
2013.04.15 20:25:42 3: Setting CUL_1 baudrate to 9600
2013.04.15 20:25:42 1: /dev/ttyACM0 reappeared (CUL_1)
2013.04.15 20:25:42 3: CUL_1: Possible commands: BCFiAZEGMRTVWXefmltux
2013.04.15 20:27:27 1: /dev/ttyACM0 disconnected, waiting to reappear
2013.04.15 20:27:32 3: Setting CUL_1 baudrate to 9600
2013.04.15 20:27:33 1: /dev/ttyACM0 reappeared (CUL_1)
2013.04.15 20:27:33 3: CUL_1: Possible commands: BCFiAZEGMRTVWXefmltux
2013.04.15 20:27:48 1: /dev/ttyACM0 disconnected, waiting to reappear
2013.04.15 20:27:53 3: Setting CUL_1 baudrate to 9600
2013.04.15 20:27:53 1: /dev/ttyACM0 reappeared (CUL_1)




 

decade-submarginal