Autor Thema: Selbstbau nanoCUL für 433 und 868MHz für Raspberry Pi 2 Model B SBC  (Gelesen 11694 mal)

Offline Burny4600

  • Hero Member
  • *****
  • Beiträge: 1912
Habe zwei Mini USB Nano V3.0 und zwei CC1101 Wireless Transceiver Module with SMA Antenna die ich am Raspberry Pi 2 Model B SBC betreiben möchte.

Der Zusammenbau war kein Problem.
Nur wie bekomme ich die richtig Software auf die beien nanoCUL's.
Einer soll für 433Mhz und der andere für 868Mhz konfiguriert werden.

Egal welche Anleitung ich befolge läuft die Vorbereitung der Konfiguration mit Fehlern ab, wo ich schon die Vorbereitung nicht abschließen kann.
http://blog.steveundkristin.de/2015/01/08/fhem-ein-selbstbau-cul-868/

http://raspberry.tips/raspberrypi-tutorials/hausautomatisierung-mit-fhem-teil-1-cul-stick-selbstbau-868mhz-cul-am-raspberry-pi/

pi@ccs-ht-rasp /nanoCUL $ sudo apt-get install make gcc-avr avrdude avr-libc subversion
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
avr-libc ist schon die neueste Version.
gcc-avr ist schon die neueste Version.
subversion ist schon die neueste Version.
avrdude ist schon die neueste Version.
make ist schon die neueste Version.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 31 nicht aktualisiert.
pi@ccs-ht-rasp /nanoCUL $ lsusb
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 006: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 001 Device 005: ID 046d:c52b Logitech, Inc. Unifying Receiver
pi@ccs-ht-rasp /nanoCUL $ dir
flash.sh  nanoCUL433.hex  nanoCUL868.hex  README
pi@ccs-ht-rasp /nanoCUL $ make program
make: *** No rule to make target 'program'.  Schluss.
pi@ccs-ht-rasp /nanoCUL $

pi@ccs-ht-rasp ~ $ ls -l /dev/serial/by-id/
insgesamt 0
lrwxrwxrwx 1 root root 13 Sep  2 08:57 usb-FTDI_FT232R_USB_UART_A98J3XX9-if00-port0 -> ../../ttyUSB1
lrwxrwxrwx 1 root root 13 Sep  2 08:57 usb-FTDI_FT232R_USB_UART_A9ULXRVF-if00-port0 -> ../../ttyUSB0

Stehe hier mit meinen Kenntnissen an.

Wie gehe ich hier wirklich vor, um das hex File vorzubereiten, bzw. die hex Files auf die nanoCul's zu bekommen.
 
« Letzte Änderung: 04 September 2015, 12:46:22 von Burny4600 »
Mfg Chris

Raspberry Pi 2/2+/3/3+/4 / Betriebssystem: Bullseye Lite
Schnittstellen: RFXtrx433E, SIGNALduino, MQTT, nanoCUL, HM-MOD-UART, 1-Wire, LAN, ser2net, FHEM2FEHEM
Devices: S.USV, APC-USV, Fronius Datalogger Web 2, FS20, IT, Resol VBUS & DL2, TEK603, WMR200, YouLess, Homematic, MQTT

Offline BlackStone

  • Full Member
  • ***
  • Beiträge: 198
Antw:Selbstbau nanoCUL Inbetriebnahme für Raspberry Pi 2 Model B SBC
« Antwort #1 am: 02 September 2015, 11:18:30 »
nun, mal dumm stellen.  :P

ich bin make und soll einen nano per usb flashen. ^^

schande aber auch...... sind ja mehr wie einer da im kreis trapps, welchen denn nur .....traps....gähn ne keinen bock mehr.

auf, gut deutsch du hast mehrere nanos am usb port. jedoch gehen die anleitungen, welche auf linux/raspi ausgeführt werden alle davon aus das nur einer am port hängt. so musst du jedoch die hex datei per hand in den richtigen schieben. oder den 2 ten. kurz abmachen. so das du nur einen dran hast.
wobei ich selbst flasche meist ber AVRisp MKII aus der arduino ide, ist jedoch geschmacksache.
« Letzte Änderung: 02 September 2015, 11:24:14 von BlackStone »

Offline Burny4600

  • Hero Member
  • *****
  • Beiträge: 1912
Selbstbau nanoCUL für 433 und 868MHz für Raspberry Pi 2 Model B SBC
« Antwort #2 am: 02 September 2015, 12:35:08 »
Das ist mir schon klar das nur einer nach dem anderen geflasht werden kann.
Bin zwar ein dummer Anfänger aber das habe ich schon geschnalt.

Siehe Anhang:
pi@ccs-ht-rasp /nanoCUL $ lsusb
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 006: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 001 Device 005: ID 046d:c52b Logitech, Inc. Unifying Receiver

Aber die Konfiguration jedes einzelnen funktioniert bei mir nicht nach den beiden Anleitungen.


pi@ccs-ht-rasp ~ $ cd /nanoCUL
pi@ccs-ht-rasp /nanoCUL $ dir
flash.sh  nanoCUL433.hex  nanoCUL868.hex  README
pi@ccs-ht-rasp /nanoCUL $ make program
make: *** No rule to make target 'program'.  Schluss.
pi@ccs-ht-rasp /nanoCUL $

« Letzte Änderung: 04 September 2015, 12:48:15 von Burny4600 »
Mfg Chris

Raspberry Pi 2/2+/3/3+/4 / Betriebssystem: Bullseye Lite
Schnittstellen: RFXtrx433E, SIGNALduino, MQTT, nanoCUL, HM-MOD-UART, 1-Wire, LAN, ser2net, FHEM2FEHEM
Devices: S.USV, APC-USV, Fronius Datalogger Web 2, FS20, IT, Resol VBUS & DL2, TEK603, WMR200, YouLess, Homematic, MQTT

Offline carlos

  • Developer
  • Full Member
  • ****
  • Beiträge: 473
Antw:Selbstbau nanoCUL Inbetriebnahme für Raspberry Pi 2 Model B SBC
« Antwort #3 am: 02 September 2015, 15:04:26 »
Warum rufts du nicht einfach flash.sh auf?
FHEM svn auf Intel NUC mit proxmox,1 UDOO, 3 Raspberry Pi, signalduino, nanoCUL, div. Homematic Komponenten, toom Baumarkt Funksteckdosen, einige sonoffs, hue, shelly

Offline Burny4600

  • Hero Member
  • *****
  • Beiträge: 1912
Selbstbau nanoCUL für 433 und 868MHz für Raspberry Pi 2 Model B SBC
« Antwort #4 am: 02 September 2015, 15:24:04 »
Wie starte ich flash.sh.

Hat sich erledigt.

bash flash.sh hat zur Lösung geführt.
« Letzte Änderung: 04 September 2015, 12:48:30 von Burny4600 »
Mfg Chris

Raspberry Pi 2/2+/3/3+/4 / Betriebssystem: Bullseye Lite
Schnittstellen: RFXtrx433E, SIGNALduino, MQTT, nanoCUL, HM-MOD-UART, 1-Wire, LAN, ser2net, FHEM2FEHEM
Devices: S.USV, APC-USV, Fronius Datalogger Web 2, FS20, IT, Resol VBUS & DL2, TEK603, WMR200, YouLess, Homematic, MQTT

Offline Burny4600

  • Hero Member
  • *****
  • Beiträge: 1912
Selbstbau nanoCUL für 433 und 868MHz für Raspberry Pi 2 Model B SBC
« Antwort #5 am: 02 September 2015, 18:43:21 »
Anderes Problem:
Die nanoCUL's laufen und sind intitialisiert.

Habe aber eine Fehlermeldung im log.

2015.09.02 18:26:42 4: CUL_send:  nanoCUL433Ax     
2015.09.02 18:26:42 4: CUL_send:  nanoCUL433X2 1     
2015.09.02 18:26:42 2: Switched nanoCUL433 rfmode to SlowRF
2015.09.02 18:26:59 4: CUL_send:  nanoCUL868Ax     
2015.09.02 18:26:59 4: CUL_send:  nanoCUL868Zx     
2015.09.02 18:26:59 4: CUL_send:  nanoCUL868X2 1     
2015.09.02 18:26:59 2: Switched nanoCUL868 rfmode to SlowRF
2015.09.02 18:27:27 0: Server shutdown
2015.09.02 18:27:27 5: SW: X00
2015.09.02 18:27:27 5: SW: X00
2015.09.02 18:27:29 1: Including fhem.cfg
2015.09.02 18:27:29 3: telnetPort: port 7072 opened
2015.09.02 18:27:30 3: WEB: port 8083 opened
2015.09.02 18:27:30 3: WEBphone: port 8084 opened
2015.09.02 18:27:30 3: WEBtablet: port 8085 opened
2015.09.02 18:27:30 2: eventTypes: loaded 8 events from /opt/fhem/log/eventTypes.txt
2015.09.02 18:27:30 3: Opening COC device /dev/ttyAMA0
2015.09.02 18:27:30 3: Setting COC serial parameters to 38400,8,N,1
2015.09.02 18:27:30 3: COC device opened
2015.09.02 18:27:39 1: Cannot init /dev/ttyAMA0, ignoring it (COC)
2015.09.02 18:27:39 3: Opening nanoCUL433 device /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A98J3XX9-if00-port0
2015.09.02 18:27:39 3: Setting nanoCUL433 serial parameters to 38400,8,N,1
2015.09.02 18:27:39 3: nanoCUL433 device opened
2015.09.02 18:27:42 3: nanoCUL433: Possible commands: BCFiAGMKUYRTVWXefLltx
2015.09.02 18:27:42 3: Opening nanoCUL868 device /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A9ULXRVF-if00-port0
2015.09.02 18:27:42 3: Setting nanoCUL868 serial parameters to 38400,8,N,1
2015.09.02 18:27:42 3: nanoCUL868 device opened
2015.09.02 18:27:46 3: nanoCUL868: Possible commands: BCFiAZEGMKUYRTVWXefltx
2015.09.02 18:27:46 1: Including /opt/fhem/log/fhem.save
2015.09.02 18:27:46 1: usb create starting
2015.09.02 18:27:46 1: usb create end
2015.09.02 18:27:46 0: Featurelevel: 5.6
2015.09.02 18:27:46 0: Server started with 13 defined entities (version $Id: fhem.pl 9163 2015-08-30 07:57:51Z rudolfkoenig $, os linux, user fhem, pid 2453)

Was muss ich hier noch anpassen?
Wie richte ich den Sende / Empfang ein für FS20 und IT Komponenten
« Letzte Änderung: 04 September 2015, 12:49:07 von Burny4600 »
Mfg Chris

Raspberry Pi 2/2+/3/3+/4 / Betriebssystem: Bullseye Lite
Schnittstellen: RFXtrx433E, SIGNALduino, MQTT, nanoCUL, HM-MOD-UART, 1-Wire, LAN, ser2net, FHEM2FEHEM
Devices: S.USV, APC-USV, Fronius Datalogger Web 2, FS20, IT, Resol VBUS & DL2, TEK603, WMR200, YouLess, Homematic, MQTT

Offline BlackStone

  • Full Member
  • ***
  • Beiträge: 198
Antw:Selbstbau nanoCUL Inbetriebnahme für Raspberry Pi 2 Model B SBC
« Antwort #6 am: 03 September 2015, 04:32:44 »
Spontan fällt mit dazu nur ein das die evtl, schon belegt ist.

hast du die referenzen zum ttyAMA0 in den dateien
/boot/cmdline.txt   und
/etc/inittab
noch drin ?

wenn ja einfach ausklammern, bzw löschen.

Offline Burny4600

  • Hero Member
  • *****
  • Beiträge: 1912
Selbstbau nanoCUL für 433 und 868MHz für Raspberry Pi 2 Model B SBC
« Antwort #7 am: 04 September 2015, 12:43:05 »
Gut das dürfte der Fehler gewesen sein.

Jetzt habe ich das Problem, dass sich die nanoCUL's initialisiert haben, aber dennoch nichts empfangen bzw. senden.
Ich sehe zwar auf den Audarino's das die LEDs flackern wenn ich ein Gerät steuern möchte.
Es wird auch je nach Gerät der richtige Audarino ausgewählt, aber es tut sich nichts.

Die fhem.cfg sieht beim Start des FHEM Server jetzt so aus.
2015.09.04 11:17:13 1: Including fhem.cfg
2015.09.04 11:17:13 3: telnetPort: port 7072 opened
2015.09.04 11:17:14 3: WEB: port 8083 opened
2015.09.04 11:17:14 3: WEBphone: port 8084 opened
2015.09.04 11:17:14 3: WEBtablet: port 8085 opened
2015.09.04 11:17:14 2: eventTypes: loaded 31 events from /opt/fhem/log/eventTypes.txt
2015.09.04 11:17:14 3: Opening nanoCUL433 device /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A98J3XX9-if00-port0
2015.09.04 11:17:14 3: Setting nanoCUL433 serial parameters to 38400,8,N,1
2015.09.04 11:17:14 3: nanoCUL433 device opened
2015.09.04 11:17:17 3: nanoCUL433: Possible commands: BCFiAGMKUYRTVWXefLltx
2015.09.04 11:17:17 3: Opening nanoCUL868 device /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A9ULXRVF-if00-port0
2015.09.04 11:17:17 3: Setting nanoCUL868 serial parameters to 38400,8,N,1
2015.09.04 11:17:17 3: nanoCUL868 device opened
2015.09.04 11:17:21 3: nanoCUL868: Possible commands: BCFiAZEGMKUYRTVWXefltx
2015.09.04 11:17:21 1: Including /opt/fhem/log/fhem.save
2015.09.04 11:17:21 1: usb create starting
2015.09.04 11:17:21 3: Probing CUL device /dev/ttyAMA0
2015.09.04 11:17:21 3: Probing TCM_ESP3 device /dev/ttyAMA0
2015.09.04 11:17:22 3: Probing FRM device /dev/ttyAMA0
2015.09.04 11:17:27 1: usb create end
2015.09.04 11:17:27 0: Featurelevel: 5.6
2015.09.04 11:17:27 0: Server started with 42 defined entities (version $Id: fhem.pl 9163 2015-08-30 07:57:51Z rudolfkoenig $, os linux, user fhem, pid 2304)

Ansteuerung eines Gerätes sieht so aus.
2015.09.04 12:25:22 3: FS20 set R_OG1_WZ off
2015.09.04 12:25:22 5: nanoCUL868 sending F1b1b1500
2015.09.04 12:25:22 5: SW: F1b1b1500
2015.09.04 12:25:24 3: FS20 set R_OG1_WZ on
2015.09.04 12:25:24 5: nanoCUL868 sending F1b1b1511
2015.09.04 12:25:24 5: SW: F1b1b1511

Da ich Aufgrund der unterschiedlichen Bauanleitungen nicht mehr sicher was richtig oder falsch ist, habe ich laut Anhang den Zusammenbau vorgenommen.
Vielleicht ist hier doch noch ein Fehler vorhanden den ich korrogieren muß.

Habe die Audarino's mit vorgefertigen nanoCUL433.hex und nanoCUL868.hex geflasht die für diesen Anwendungsfall passen sollten.

Nur momentan komme ich so nicht weiter.
Was ist alles für die nanoCUL's wirklich zu berücksichtigen bzw. der richtige Vorgang für die Inbetriebnahme.
« Letzte Änderung: 04 September 2015, 13:08:25 von Burny4600 »
Mfg Chris

Raspberry Pi 2/2+/3/3+/4 / Betriebssystem: Bullseye Lite
Schnittstellen: RFXtrx433E, SIGNALduino, MQTT, nanoCUL, HM-MOD-UART, 1-Wire, LAN, ser2net, FHEM2FEHEM
Devices: S.USV, APC-USV, Fronius Datalogger Web 2, FS20, IT, Resol VBUS & DL2, TEK603, WMR200, YouLess, Homematic, MQTT

Offline BlackStone

  • Full Member
  • ***
  • Beiträge: 198
Antw:Selbstbau nanoCUL für 433 und 868MHz für Raspberry Pi 2 Model B SBC
« Antwort #8 am: 04 September 2015, 22:53:07 »
nu, wenn du z.b. homematic (868mhz)damit emfangen möchtest musst du den rfmode auf homematic einstellen.
und dann die geräte pairen, sonst wird das alles was emfangen wird einfach verworfen.

Offline Burny4600

  • Hero Member
  • *****
  • Beiträge: 1912
Antw:Selbstbau nanoCUL für 433 und 868MHz für Raspberry Pi 2 Model B SBC
« Antwort #9 am: 05 September 2015, 10:45:53 »
Homematik wird nicht benötigt.

Es sollen lediglich die IT und FS20 Geräte angezeigt und gesteuert werden.

Und da bin ich mir nicht ganz sicher ob alles richtig eingestellt ist für den Empfang und das Senden bei den nanoCUL's.

Grundsetzlich werden ja die richtigen nanoCUL's angesteuert wie schon beschrieben.
Sind hier bei den CUL's noch Konfigurationen für den Emfang und das Senden notwendig?

Es hat den anschein das diese CUL's ein wenig taub sind und leistungschwach.

Auf welche Frequenz und Bandbreite genau sollen die CUL's eingestellt für IT und FS20 Geräte eingestellt werden?
« Letzte Änderung: 05 September 2015, 11:12:04 von Burny4600 »
Mfg Chris

Raspberry Pi 2/2+/3/3+/4 / Betriebssystem: Bullseye Lite
Schnittstellen: RFXtrx433E, SIGNALduino, MQTT, nanoCUL, HM-MOD-UART, 1-Wire, LAN, ser2net, FHEM2FEHEM
Devices: S.USV, APC-USV, Fronius Datalogger Web 2, FS20, IT, Resol VBUS & DL2, TEK603, WMR200, YouLess, Homematic, MQTT

Offline BlackStone

  • Full Member
  • ***
  • Beiträge: 198
Antw:Selbstbau nanoCUL für 433 und 868MHz für Raspberry Pi 2 Model B SBC
« Antwort #10 am: 05 September 2015, 19:12:00 »
Na denn musst du den rfmode auf SlowRF stellen, denn die IT und FS20 laufen auf 433 mhz, soweit ich weiß. für FS20 muss es auf SlowRf sein, das weis ich zumindest.

Offline Burny4600

  • Hero Member
  • *****
  • Beiträge: 1912
Antw:Selbstbau nanoCUL für 433 und 868MHz für Raspberry Pi 2 Model B SBC
« Antwort #11 am: 05 September 2015, 19:44:38 »
FS20 laufen aber auf 868Mhz und nicht auf 433Mhz.
Mfg Chris

Raspberry Pi 2/2+/3/3+/4 / Betriebssystem: Bullseye Lite
Schnittstellen: RFXtrx433E, SIGNALduino, MQTT, nanoCUL, HM-MOD-UART, 1-Wire, LAN, ser2net, FHEM2FEHEM
Devices: S.USV, APC-USV, Fronius Datalogger Web 2, FS20, IT, Resol VBUS & DL2, TEK603, WMR200, YouLess, Homematic, MQTT

Offline BlackStone

  • Full Member
  • ***
  • Beiträge: 198
Antw:Selbstbau nanoCUL für 433 und 868MHz für Raspberry Pi 2 Model B SBC
« Antwort #12 am: 05 September 2015, 20:23:14 »
naja, dennoch müssen die fs20 auf slowrf gestellt sein.

Offline Burny4600

  • Hero Member
  • *****
  • Beiträge: 1912
Antw:Selbstbau nanoCUL für 433 und 868MHz für Raspberry Pi 2 Model B SBC
« Antwort #13 am: 07 September 2015, 17:53:51 »
Also, ich habe den nanoCUL so eingestellt wie es funktionieren sollte für die FS20 Geräte.
Nur funktioniert die Steuerung nicht wirklich zufrieden stellend.
Die IT Geräte funktionieren dafür alle.

Ebenso kommt es vor, dass auf einmal bei STATE disconnected steht und ich den nanoCUL ab- und wieder anstecken muß.

Was mir aufgefallen ist, ist das der nanoCUL868 viele Einträge die der nanoCUL433 hat nicht besitzt.
Dafür den Eintrag fhtbuf => No answer.


CMDS              BCFiAZEGMKUYRTVWXefltx
Clients            :FS20:FHT.*:KS300:USF1000:BS:HMS::CUL_EM:CUL_WS:CUL_FHTTK:CUL_HOERMANN::ESA2000:CUL_IR:CUL_TX:Revolt:IT:UNIRoll:SOMFY::STACKABLE_CC:CUL_RFR::CUL_TCM97001:
DEF                /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A9ULXRVF-if00-port0@38400 0000
DeviceName   /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A9ULXRVF-if00-port0@38400
FD                  12
FHTID             0000
NAME              nanoCUL868
NR                  25
PARTIAL       
STATE             Initialized
TYPE               CUL
VERSION        V 1.05.04 a-culfw Build: 151 (2015-08-25_20-48-08) nanoCUL868 (F-Band: 868MHz)
initString        X21


CMDS              BCFiAGMKUYRTVWXefLltx
Clients         :FS20:FHT.*:KS300:USF1000:BS:HMS::CUL_EM:CUL_WS:CUL_FHTTK:CUL_HOERMANN::ESA2000:CUL_IR:CUL_TX:Revolt:IT:UNIRoll:SOMFY::STACKABLE_CC:CUL_RFR::CUL_TCM97001:
DEF                  /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A98J3XX9-if00-port0@38400 0000
DeviceName   /dev/serial/by-id/usb-FTDI_FT232R_USB_UART_A98J3XX9-if00-port0@38400
FD                 11
FHTID            0000
NAME             nanoCUL433
NR                 24
PARTIAL
RAWMSG       tA0F1661662E2
RSSI             -89
STATE           Initialized
TYPE             CUL
VERSION      V 1.05.04 a-culfw Build: 151 (2015-08-25_20-48-08) nanoCUL433 (F-Band: 433MHz)
initString      X21
nanoCUL433_MSGCNT   54
nanoCUL433_TIME        2015-09-07 17:47:55

Hat da der CUL einen Fehler oder der nano?
Den nanoCUL nochmals zu flashen hat hier auch keinen Erfolg gebracht.
« Letzte Änderung: 07 September 2015, 18:32:44 von Burny4600 »
Mfg Chris

Raspberry Pi 2/2+/3/3+/4 / Betriebssystem: Bullseye Lite
Schnittstellen: RFXtrx433E, SIGNALduino, MQTT, nanoCUL, HM-MOD-UART, 1-Wire, LAN, ser2net, FHEM2FEHEM
Devices: S.USV, APC-USV, Fronius Datalogger Web 2, FS20, IT, Resol VBUS & DL2, TEK603, WMR200, YouLess, Homematic, MQTT

Offline BlackStone

  • Full Member
  • ***
  • Beiträge: 198
Antw:Selbstbau nanoCUL für 433 und 868MHz für Raspberry Pi 2 Model B SBC
« Antwort #14 am: 07 September 2015, 20:26:01 »
das der nanocul die Verbindung verliert kommt mir bekannt vor, ich vermute mal du hast den selbst gestrickt. aus einemArduino Nano v3 (Clone).
das hatte mich auch mal zum mäusemelken gebracht. bis ich auf einen kleinen Bug Gestosen bin, der genau die nano v3 Clones mit ftdi Chip betrifft.
denn dort wurde aus welchen gründen auch immer vergessen den Testpin auf Masse zu ziehen. stattdessen hängt der sozusagen einfach in der Luft.
nach dem ich den nach gebrückt hatte lief es auf einmal ohne murren. und dabei ist mir aufgefallen das ich einige nano (clones), habe wo genau die Brücke gesetzt war und einige wo es nicht der Fall war.

dazu einfach PIN 25 und 26 Brücken. http://www.opentilt.org/fixduino-800px.jpg

 

decade-submarginal