Autor Thema: (amunra)-Platine für HM-MOD-UART-RPI mit USR-TCP232-T(2) / ESP8266 / USB  (Gelesen 13378 mal)

Offline chons

  • Full Member
  • ***
  • Beiträge: 130
Ich würde mich für einen HMAURT mit LAN und Gehäuse interessieren..
Ist das hier noch aktuell ?
An wen kann ich mich wenden ?
die Platine bekommst Du hier das Gehäuse ist eine Strapubox Typ 2024 und den USR-TCP232-T bekommst du bei Amaz*** ;o)
« Letzte Änderung: 25 August 2017, 09:12:22 von chons »

Offline chons

  • Full Member
  • ***
  • Beiträge: 130
Wenn ich den nächsten Schwung Platinen erhalte, kann ich auch noch mehr Bilder machen. Bestellt habe ich die Platinen allerdings bei DirtyPCBs.
Ok, danke - sind die beiden Platinen nur an den markierten stellen miteinander verbunden (siehe Screenshot)? Die Info reicht mir dann im Prinzip schon?

Online gloob

  • Hero Member
  • *****
  • Beiträge: 2275
Ich denke mal schon. Die Platinen von DirtyPCB kommen alle einzeln und fertig getrennt an.
Raspberry Pi 3 | miniCUL 433MHz | nanoCUL 868 MHz | nanoCUL 433 MHz | MySensors WLAN Gateway | LaCrosse WLAN Gateway | SignalESP 433 MHz | SignalESP 868 MHz | HM-MOD-UART WLAN Gateway | IR - 360 Grad WLAN Gateway

Offline Morgennebel

  • Hero Member
  • *****
  • Beiträge: 1133
  • Proud systemd-free zone
Moin,


ich wollte diese Woche meine eingelagerten Platinen v1.2 für LAN mit USR-T2-Modul fertigmachen - leider funktionieren die nicht wie gewünscht.

Das LAN-Modul meldet sich, kann konfiguriert werden - d.h. USB auf 3.3V und LAN-Modul arbeiten einwandfrei. Jedoch das Homematic-Modul reagiert überhaupt nicht.

Hat jemand die V1.2-Platine für LAN erfolgreich zusammengelötet und gibt es irgendwo eine abzuarbeitende Korrektur/Ergänzungsübersicht?

Danke, -MN
Einziger Spender an FHEM e.V. mit Dauerauftrag seit >= 24 Monaten

FHEM: LattePanda x86 4/64GB
In-Use: STELLMOTOR, VALVES, PWM-PWMR, Xiaomi, Allergy, Proplanta, UWZ, MQTT, vThings, Homematic, Luftsensor.info, ESP8266, ESERA

Offline tndx

  • Full Member
  • ***
  • Beiträge: 332
Hast Du auch ein CP2102-Modul zur Stromversorgung benutzt und seine Datenleitungen mit der Platine verbunden? Dann findest Du hier die Lösung: https://forum.fhem.de/index.php/topic,83442.msg810730.html#msg810730

Offline Morgennebel

  • Hero Member
  • *****
  • Beiträge: 1133
  • Proud systemd-free zone
Danke,


Das klingt ganz nach mir.... Morgen mal kontrollieren...

Danke, -MN
Einziger Spender an FHEM e.V. mit Dauerauftrag seit >= 24 Monaten

FHEM: LattePanda x86 4/64GB
In-Use: STELLMOTOR, VALVES, PWM-PWMR, Xiaomi, Allergy, Proplanta, UWZ, MQTT, vThings, Homematic, Luftsensor.info, ESP8266, ESERA

Offline Morgennebel

  • Hero Member
  • *****
  • Beiträge: 1133
  • Proud systemd-free zone
Moin Moin,


ich hab noch ein LAN-Modul zusammengelötet, diesmal ohne Datenleitungen. Funktionierte prima mit der Firmware-Version 1.2.1.
Dann erfolgreich auf 1.4.1. aktualisiert - und seitdem geht gar nix mehr.

Ich habe getestet: unterschiedliche Netzteile, unterschiedliche Kabel, unterschiedliche Switch-Ports, DHCP und Statische IP, seriellen Server von auf 9600, 19200 und 115200 Baud 8N1 konfiguriert - kein Unterschied.

Logfile sagt dieses:

2018.12.04 17:25:51 1: 192.168.1.113:1000 reappeared (LAN2HMCUL1)
2018.12.04 17:25:51 1: 192.168.1.113:1000 disconnected, waiting to reappear (LAN2HMCUL1)
2018.12.04 17:25:55 1: HMUARTLGW LAN2HMCUL1 did not respond for the 1. time, resending
2018.12.04 17:25:56 1: 192.168.1.113:1000 reappeared (LAN2HMCUL1)
2018.12.04 17:25:56 1: 192.168.1.113:1000 disconnected, waiting to reappear (LAN2HMCUL1)
2018.12.04 17:26:00 1: HMUARTLGW LAN2HMCUL1 did not respond for the 1. time, resending
2018.12.04 17:26:02 1: 192.168.1.113:1000 reappeared (LAN2HMCUL1)
2018.12.04 17:26:02 1: 192.168.1.113:1000 disconnected, waiting to reappear (LAN2HMCUL1)
2018.12.04 17:26:06 1: HMUARTLGW LAN2HMCUL1 did not respond for the 1. time, resending
2018.12.04 17:26:07 1: 192.168.1.113:1000 reappeared (LAN2HMCUL1)
2018.12.04 17:26:07 1: 192.168.1.113:1000 disconnected, waiting to reappear (LAN2HMCUL1)
2018.12.04 17:26:13 1: 192.168.1.113:1000 reappeared (LAN2HMCUL1)
2018.12.04 17:26:13 1: 192.168.1.113:1000 disconnected, waiting to reappear (LAN2HMCUL1)
2018.12.04 17:26:17 1: HMUARTLGW LAN2HMCUL1 did not respond for the 1. time, resending
2018.12.04 17:26:18 1: 192.168.1.113:1000 reappeared (LAN2HMCUL1)
2018.12.04 17:26:18 1: 192.168.1.113:1000 disconnected, waiting to reappear (LAN2HMCUL1)
2018.12.04 17:26:23 1: HMUARTLGW LAN2HMCUL1 did not respond for the 1. time, resending
2018.12.04 17:26:24 1: 192.168.1.113:1000 reappeared (LAN2HMCUL1)
2018.12.04 17:26:28 1: HMUARTLGW LAN2HMCUL1 did not respond for the 1. time, resending
2018.12.04 17:26:28 1: 192.168.1.113:1000 disconnected, waiting to reappear (LAN2HMCUL1)
2018.12.04 17:26:30 1: 192.168.1.113:1000 reappeared (LAN2HMCUL1)
2018.12.04 17:26:30 1: 192.168.1.113:1000 disconnected, waiting to reappear (LAN2HMCUL1)
2018.12.04 17:26:34 1: HMUARTLGW LAN2HMCUL1 did not respond for the 1. time, resending
2018.12.04 17:26:35 1: 192.168.1.113:1000 reappeared (LAN2HMCUL1)
2018.12.04 17:26:35 1: 192.168.1.113:1000 disconnected, waiting to reappear (LAN2HMCUL1)
2018.12.04 17:26:40 1: HMUARTLGW LAN2HMCUL1 did not respond for the 1. time, resending
2018.12.04 17:26:41 1: 192.168.1.113:1000 reappeared (LAN2HMCUL1)
2018.12.04 17:26:41 1: 192.168.1.113:1000 disconnected, waiting to reappear (LAN2HMCUL1)
2018.12.04 17:26:45 1: HMUARTLGW LAN2HMCUL1 did not respond for the 1. time, resending
2018.12.04 17:26:46 1: 192.168.1.113:1000 reappeared (LAN2HMCUL1)
2018.12.04 17:26:48 1: 192.168.1.113:1000 disconnected, waiting to reappear (LAN2HMCUL1)
2018.12.04 17:26:51 1: HMUARTLGW LAN2HMCUL1 did not respond for the 1. time, resending
2018.12.04 17:26:51 1: 192.168.1.113:1000 reappeared (LAN2HMCUL1)
2018.12.04 17:26:52 1: 192.168.1.113:1000 disconnected, waiting to reappear (LAN2HMCUL1)
2018.12.04 17:26:55 1: HMUARTLGW LAN2HMCUL1 did not respond for the 1. time, resending
2018.12.04 17:26:57 1: 192.168.1.113:1000 reappeared (LAN2HMCUL1)
2018.12.04 17:26:57 1: 192.168.1.113:1000 disconnected, waiting to reappear (LAN2HMCUL1)
2018.12.04 17:27:01 1: HMUARTLGW LAN2HMCUL1 did not respond for the 1. time, resending
2018.12.04 17:27:03 1: 192.168.1.113:1000 reappeared (LAN2HMCUL1)
2018.12.04 17:27:03 1: 192.168.1.113:1000 disconnected, waiting to reappear (LAN2HMCUL1)
2018.12.04 17:27:07 1: HMUARTLGW LAN2HMCUL1 did not respond for the 1. time, resending
2018.12.04 17:27:08 1: 192.168.1.113:1000 reappeared (LAN2HMCUL1)
2018.12.04 17:27:12 1: 192.168.1.113:1000 disconnected, waiting to reappear (LAN2HMCUL1)
2018.12.04 17:27:12 1: HMUARTLGW LAN2HMCUL1 did not respond for the 1. time, resending
2018.12.04 17:27:15 1: 192.168.1.113:1000 reappeared (LAN2HMCUL1)
2018.12.04 17:27:15 1: 192.168.1.113:1000 disconnected, waiting to reappear (LAN2HMCUL1)

Jemand gute Ideen?

Danke, -MN
Einziger Spender an FHEM e.V. mit Dauerauftrag seit >= 24 Monaten

FHEM: LattePanda x86 4/64GB
In-Use: STELLMOTOR, VALVES, PWM-PWMR, Xiaomi, Allergy, Proplanta, UWZ, MQTT, vThings, Homematic, Luftsensor.info, ESP8266, ESERA

Offline PeMue

  • Developer
  • Hero Member
  • ****
  • Beiträge: 4347
Hallo Morgennebel,

Du holst die Versorgungsspannung aus dem Netzteil über die USB Buchse? Woher kommen die 3,3 V? Aus dem Spannungsregler des LAN-Moduls? Sorry für die Frage, aber ich kenne die Leiterplatte nicht im Detail. Ggf. könnte hier ein Problem sein und vielleicht braucht braucht das HM Modul mit der Firmware v1.4.1 mehr Strom.

Gruß PeMue
1x FB7170 (29.04.88) 5.7 1xCUNO2 1.67 2xEM1000WZ 2xUniroll 1xASH2200 3xHMS100T(F)
1x RPi BV2LCDCSM 1.63 5.7 2xMAX HKT, 1xMAX RT, V200KW1
1xFB 7490 (113.06.05) 5.7 1xCUL V3 1.63 1xHM-CC-RT-DN 1.4 1xHM-TC-IT-WM 1.1 1xHB-UW-Sen-THPL-O 0.15 1x-I 0.14OTAU 1xRFXtrx 90 1xWT440H 1xCM160 3xTFA30.3150 5xFA21

Offline Morgennebel

  • Hero Member
  • *****
  • Beiträge: 1133
  • Proud systemd-free zone
Hi PeMue,


die Versorgungsspannung beim LAN-Modul erfolgt durch USB (5V) und ein CP2102 MICRO USB Modul, das die 3.3V erzeugt.
Das USB-Netzteil liefert max. 2A.

Ich bin echt ratlos... Es lief ja für das Firmware-Update...

Ciao, -MN
Einziger Spender an FHEM e.V. mit Dauerauftrag seit >= 24 Monaten

FHEM: LattePanda x86 4/64GB
In-Use: STELLMOTOR, VALVES, PWM-PWMR, Xiaomi, Allergy, Proplanta, UWZ, MQTT, vThings, Homematic, Luftsensor.info, ESP8266, ESERA

Offline tndx

  • Full Member
  • ***
  • Beiträge: 332
Kennst Du dieses Problem: https://wiki.fhem.de/wiki/CP2102#3.3V_werden_.C3.BCberschritten.

Kann sein, dass die zu hohe Spannung das Funkmodul gegrillt hat  :-\

Offline Morgennebel

  • Hero Member
  • *****
  • Beiträge: 1133
  • Proud systemd-free zone
(*seufz*)

Das purzelte irgendwie am Rand meiner Gehirnschale entlang, ist aber irgendwie nie in meinem Bewußtsein angekommen...

Multimeter, wo bist Du...?

Danke, -MN
Einziger Spender an FHEM e.V. mit Dauerauftrag seit >= 24 Monaten

FHEM: LattePanda x86 4/64GB
In-Use: STELLMOTOR, VALVES, PWM-PWMR, Xiaomi, Allergy, Proplanta, UWZ, MQTT, vThings, Homematic, Luftsensor.info, ESP8266, ESERA

 

decade-submarginal